0.7.10 pre-release
#11
(10-10-2018, 01:08 AM)hunderteins Wrote: on 4.4.154-1122 I got no hdmi-sound, mpv with mpp is no longer working.
Yeah - sound is an issue as per my posts 5 & 9 above.

(10-10-2018, 01:08 AM)hunderteins Wrote: Also the cpu-fan is barely moving when I fiddle with  pwm-fan/hwmon/hwmon0/pwm1
The release sheet has
0.7.10: Improve FAN for RockPro64,
Not sure what that entails, but a change in behaviour can be expected. Have you tried tux's fanctl? I would reckon start with that?
ROCKPro64 v2.1 2GB, SM961 128GB NVMe for rootfs, HDMI video & sound, Bluetooth keyboard & mouse
Started Bionic minimal - now Cosmic, Openbox desktop for general purpose daily PC.
  Reply
#12
thank you, yes sound and mpp was already mentioned. Sorry.

My fan is louder (vibrations) when running quarder or half the speed than at fullspeed. So tux's fanctl is not for me, but I like his work, max temp 58°C was just what I asked myself.
  Reply
#13
(10-11-2018, 03:33 AM)hunderteins Wrote: thank you, yes sound and mpp was already mentioned. Sorry.

My fan is louder (vibrations) when running quarder or half the speed than at fullspeed. So tux's fanctl is not for me, but I like his work, max temp 58°C was just what I asked myself.

Hello hunderteins

Does you have same symptoms with 1097 kernel version?
rockpro64 4.4.138-1097-rockchip-ayufan-gb5128c0a1684

I have nice temps, with this kernel version , I haven  upgraded yet.
Code:
top - 01:25:44 up 2 days, 12:54,  0 users,  load average: 6.46, 6.40, 6.94
Tasks: 199 total,   1 running, 198 sleeping,   0 stopped,   0 zombie
%Cpu(s):  2.1 us,  0.4 sy, 97.2 ni,  0.0 id,  0.0 wa,  0.0 hi,  0.2 si,  0.0 st
KiB Mem :  3968804 total,  1008976 free,   831068 used,  2128760 buff/cache
KiB Swap:  1984392 total,  1984392 free,        0 used.  3051340 avail Mem

its up and kicking..  Shy
Code:
[email protected]:~# cat /sys/class/{thermal/thermal_zone{0,1}/temp,hwmon/hwmon0/pwm1}
56111
46875
204

its not so high, even though is full throttle
but it also depends in the environment around, here now its more coold :S
  Reply
#14
Wink 
(10-11-2018, 03:33 AM)hunderteins Wrote: thank you, yes sound and mpp was already mentioned. Sorry.

My fan is louder (vibrations) when running quarder or half the speed than at fullspeed. So tux's fanctl is not for me, but I like his work, max temp 58°C was just what I asked myself.

Hello hunderteins,
It could be related with so other problems,
test the kernel I put above, it works ok, for me..

What is the Fan you are using?
current consumption, CFM values,dimentions( WxLxH)

You can always edit fanctl parameters, with:
Code:
vi /usr/sbin/fanctl

I decided to use Lua, (which can be compiled, but doesn't need to, and its fast with lower footprint ), precisely because it can be easily tuned.

You can tune it, to your Active cooling setup [Image: wink.png]
You can lower the values, if you own a fan with bigger CFM specs, and probably with bigger size.

Between 39C and 60C, it has a function, that can be adapted to your needs.
Also it could be that your fan needs more power to start, it can be tuned too.

Some days ago, I brought a new fan, and I thought that it could be better solution, but I ended up, with inicial setup, because of vibration...
Temps were really good, it could drop them for less than 45C, at full throttle, on all cores!
But then, I was feeling like I was flying a jet air plain and vibrations were high.. Sad

The big thing here is that the silicone pads that come with heatsink, are really good for mechanical stability, they in fact improve a lot the situation..
If not,  at long term... the CPU could endup with its balls grid array stalled, and oxidation behind them..creating bad contacts, and in a BGA case, this cannot be solved without proper soldering solution..
So its all depends ...

But happens that this conversation gave me the ideia of creating 2 profiles..
One for 20mm tall fan, and one for 10mm tall.  Cool
With a one point, set location,
so that it could easily change profiles and response curves..
will be in my next todo list..
  Reply
#15
Hello,
I think, I got hdmi-sound working again on 4.4.154 for the rockpro64.
Can someone apply the attached patch and confirm my finding?
TIA,
hunderteins


Attached Files
.txt   0.7.10-fix_hdmi_audio.patch.txt (Size: 506 bytes / Downloads: 28)
  Reply
#16
Methinks this involves compiling 4.4.154 kernel, and beforehand applying a patch? If there are no other takers I will pull 4.4 for a compile, you will need to tell me how to apply the patch!

(As the idiot I am I looked at the 4.19 clk-rk3399.c - found nothing at all like your patch. Then realized there is no HDMI sound at 4.19! I am set-up to compile 4.18 or 4.19 but they are far more challenging to get HDMI sound as for a start they are not generating the soundcards.)
ROCKPro64 v2.1 2GB, SM961 128GB NVMe for rootfs, HDMI video & sound, Bluetooth keyboard & mouse
Started Bionic minimal - now Cosmic, Openbox desktop for general purpose daily PC.
  Reply
#17
Anyone else have issues with bionic-minimal-rockpro64-0.7.10-1072-arm64 stopping working after a day or two of uptime?

It's happened on previous builds as well. Throws an error (can't recall, I rebooted) and when I restart no SSH.

Don't have time to pinpoint at the moment, just asking to see if anyone else has encountered an issue like this.
  Reply
#18
@duckkcud No, very stable here. What's your setup?
Sorry for any mistakes. English is not my native language

1. RP64 v2.0 / PCIe NVMe as root / sd-card as boot / 2,5 Zoll HDD 1TB (USB3) using as Webserver .... (Kernel 4.4.167-1140-rockchip-ayufan-g6f266fb5d677)
2. RP64 v2.1 / PCIe SATA Marvell 88SE9230 Chipsatz / sd-card / 2 * 2,5 Zoll 2TB HDD (raid1) / using as NAS / Kernel 5.0.0-1101-ayufan-g41eeb7cd789e
3. RP64 v2.1 / testing.....testing....testing

https://forum.frank-mankel.org/category/14/rockpro64



  Reply
#19
@hunderteins -  Had to install python to get off the starting line which is odd, as it is not needed for 4.18/4.19.

Anyway, I get a compile error fairly quickly so complete log pasted below. I am building on my RockPro itself if that makes any difference. But this kind of error is way beyond my skills - I never wrote a line of c in my life! Also couldn't PM you as you have PM disabled.


Code:
$ make -j6 bindeb-pkg
  HOSTCC  scripts/basic/fixdep
  HOSTCC  scripts/basic/bin2c
  HOSTCC  scripts/kconfig/conf.o
  HOSTCC  scripts/kconfig/zconf.tab.o
  HOSTLD  scripts/kconfig/conf
scripts/kconfig/conf  --silentoldconfig Kconfig
  CHK     include/config/kernel.release
make KBUILD_SRC=
  CHK     include/config/kernel.release
  CHK     include/generated/uapi/linux/version.h
  CHK     include/generated/utsrelease.h
  HOSTCC  scripts/dtc/dtc.o
  HOSTCC  scripts/dtc/flattree.o
  CC      scripts/mod/empty.o
  HOSTCC  scripts/selinux/genheaders/genheaders
  HOSTCC  scripts/dtc/fstree.o
  HOSTCC  scripts/mod/mk_elfconfig
  HOSTCC  scripts/dtc/data.o
  CC      scripts/mod/devicetable-offsets.s
  HOSTCC  scripts/selinux/mdp/mdp
  HOSTCC  scripts/dtc/livetree.o
  MKELF   scripts/mod/elfconfig.h
  CHK     scripts/mod/devicetable-offsets.h
  UPD     scripts/mod/devicetable-offsets.h
  HOSTCC  scripts/mod/sumversion.o
  HOSTCC  scripts/kallsyms
  HOSTCC  scripts/conmakehash
  HOSTCC  scripts/recordmcount
  HOSTCC  scripts/dtc/treesource.o
  HOSTCC  scripts/mod/modpost.o
  HOSTCC  scripts/dtc/srcpos.o
  HOSTCC  scripts/resource_tool
  HOSTCC  scripts/dtc/checks.o
  HOSTCC  scripts/dtc/util.o
  CC      kernel/bounds.s
  CHK     include/generated/timeconst.h
  UPD     include/generated/timeconst.h
  CHK     include/generated/bounds.h
  HOSTCC  scripts/dtc/dtc-lexer.lex.o
  UPD     include/generated/bounds.h
  CC      arch/arm64/kernel/asm-offsets.s
  HOSTCC  scripts/dtc/dtc-parser.tab.o
  HOSTCC  scripts/mod/file2alias.o
  CHK     include/generated/asm-offsets.h
  UPD     include/generated/asm-offsets.h
  CALL    scripts/checksyscalls.sh
  HOSTCC  scripts/mkkrnlimg
  HOSTCC  scripts/sortextable
  HOSTCC  scripts/asn1_compiler
  LDS     arch/arm64/kernel/vdso/vdso.lds
  VDSOA   arch/arm64/kernel/vdso/gettimeofday.o
  VDSOA   arch/arm64/kernel/vdso/note.o
  VDSOA   arch/arm64/kernel/vdso/sigreturn.o
  HOSTLD  scripts/mod/modpost
  VDSOL   arch/arm64/kernel/vdso/vdso.so.dbg
  HOSTLD  scripts/dtc/dtc
  VDSOSYM include/generated/vdso-offsets.h
  CC      init/main.o
  CHK     include/generated/compile.h
  CC      init/do_mounts.o
  CC      init/do_mounts_rd.o
  CC      init/do_mounts_initrd.o
  HOSTCC  usr/gen_init_cpio
  UPD     include/generated/compile.h
  CC      init/do_mounts_dm.o
  CC      init/noinitramfs.o
  GEN     usr/initramfs_data.cpio.gz
  AS      usr/initramfs_data.o
  CC      init/initramfs.o
  LD      usr/built-in.o
  CC      arch/arm64/kernel/debug-monitors.o
  AS      arch/arm64/kernel/entry.o
  CC      init/calibrate.o
  CC      arch/arm64/kernel/irq.o
  CC      init/init_task.o
  CC      arch/arm64/kernel/fpsimd.o
  CC      arch/arm64/mm/dma-mapping.o
  CC      init/version.o
  LD      init/mounts.o
  CC      arch/arm64/mm/extable.o
  CC      arch/arm64/mm/fault.o
  AS      arch/arm64/kernel/entry-fpsimd.o
  LD      init/built-in.o
  CC      arch/arm64/kernel/process.o
  LD      arch/arm64/net/built-in.o
  CC      arch/arm64/kernel/ptrace.o
  CC      arch/arm64/kernel/setup.o
  CC      arch/arm64/mm/init.o
  AS      arch/arm64/mm/cache.o
  CC      arch/arm64/mm/copypage.o
  CC      arch/arm64/kernel/signal.o
  CC      arch/arm64/mm/flush.o
  CC      arch/arm64/mm/ioremap.o
  CC      arch/arm64/kernel/sys.o
  CC      arch/arm64/kernel/stacktrace.o
  CC      arch/arm64/kernel/time.o
  CC      arch/arm64/kernel/traps.o
  CC      arch/arm64/kernel/io.o
  CC      arch/arm64/mm/mmap.o
  CC      arch/arm64/kernel/vdso.o
  AS      arch/arm64/kernel/hyp-stub.o
  CC      arch/arm64/kernel/psci.o
  CC      arch/arm64/mm/pgd.o
  CC      arch/arm64/kernel/cpu_ops.o
arch/arm64/kernel/vdso.c: In function ‘vdso_init’:
arch/arm64/kernel/vdso.c:119:6: warning: ‘memcmp’ reading 4 bytes from a region of size 1 [-Wstringop-overflow=]
error, forbidden warning:vdso.c:119
  if (memcmp(&vdso_start, "\177ELF", 4)) {
      ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
make[3]: *** [scripts/Makefile.build:277: arch/arm64/kernel/vdso.o] Error 1
make[3]: *** Waiting for unfinished jobs....
  CC      arch/arm64/kvm/../../../virt/kvm/kvm_main.o
  CC      arch/arm64/mm/mmu.o
  CC      arch/arm64/crypto/sha1-ce-glue.o
  AS      arch/arm64/crypto/sha1-ce-core.o
make[2]: *** [Makefile:1031: arch/arm64/kernel] Error 2
make[2]: *** Waiting for unfinished jobs....
  CC      arch/arm64/crypto/sha2-ce-glue.o
  AS      arch/arm64/crypto/sha2-ce-core.o
  CC      arch/arm64/crypto/ghash-ce-glue.o
  CC      arch/arm64/mm/context.o
  AS      arch/arm64/crypto/ghash-ce-core.o
  CC      arch/arm64/kvm/../../../virt/kvm/coalesced_mmio.o
  CC      arch/arm64/kvm/../../../virt/kvm/eventfd.o
  CC      arch/arm64/kvm/../../../virt/kvm/vfio.o
  CC      arch/arm64/crypto/aes-ce-cipher.o
  CC      arch/arm64/crypto/aes-ce-ccm-glue.o
  CC      arch/arm64/kvm/../../../arch/arm/kvm/arm.o
  CC      arch/arm64/kvm/../../../arch/arm/kvm/mmu.o
  AS      arch/arm64/mm/proc.o
  CC      arch/arm64/mm/pageattr.o
  AS      arch/arm64/crypto/aes-ce-ccm-core.o
  CC      arch/arm64/mm/hugetlbpage.o
  CC      arch/arm64/crypto/aes-glue-ce.o
  AS      arch/arm64/crypto/aes-ce.o
  CC      arch/arm64/crypto/crc32-arm64.o
  LD      arch/arm64/mm/built-in.o
  CC      arch/arm64/kvm/../../../arch/arm/kvm/mmio.o
  CC      arch/arm64/kvm/../../../arch/arm/kvm/psci.o
  CC      arch/arm64/kvm/../../../arch/arm/kvm/perf.o
  CC      arch/arm64/kvm/emulate.o
  LD      arch/arm64/crypto/sha1-ce.o
  LD      arch/arm64/crypto/sha2-ce.o
  LD      arch/arm64/crypto/ghash-ce.o
  LD      arch/arm64/crypto/aes-ce-ccm.o
  LD      arch/arm64/crypto/aes-ce-blk.o
  LD      arch/arm64/crypto/built-in.o
  CC      arch/arm64/kvm/inject_fault.o
  CC      arch/arm64/kvm/regmap.o
  AS      arch/arm64/kvm/hyp.o
  AS      arch/arm64/kvm/hyp-init.o
  CC      arch/arm64/kvm/handle_exit.o
  CC      arch/arm64/kvm/guest.o
  CC      arch/arm64/kvm/debug.o
  CC      arch/arm64/kvm/reset.o
  CC      arch/arm64/kvm/sys_regs.o
  CC      arch/arm64/kvm/sys_regs_generic_v8.o
  CC      arch/arm64/kvm/../../../virt/kvm/arm/vgic.o
  CC      arch/arm64/kvm/../../../virt/kvm/arm/vgic-v2.o
  CC      arch/arm64/kvm/../../../virt/kvm/arm/vgic-v2-emul.o
  CC      arch/arm64/kvm/../../../virt/kvm/arm/vgic-v3.o
  CC      arch/arm64/kvm/../../../virt/kvm/arm/vgic-v3-emul.o
  CC      arch/arm64/kvm/../../../virt/kvm/arm/arch_timer.o
  CC      arch/arm64/kvm/hyp/vgic-v2-sr.o
  CC      arch/arm64/kvm/hyp/vgic-v3-sr.o
  CC      arch/arm64/kvm/hyp/timer-sr.o
  CC      arch/arm64/kvm/hyp/sysreg-sr.o
  CC      arch/arm64/kvm/hyp/debug-sr.o
  AS      arch/arm64/kvm/hyp/entry.o
  CC      arch/arm64/kvm/hyp/switch.o
  LD      arch/arm64/kvm/kvm.o
  AS      arch/arm64/kvm/hyp/fpsimd.o
  CC      arch/arm64/kvm/hyp/tlb.o
  AS      arch/arm64/kvm/hyp/hyp-entry.o
  LD      arch/arm64/kvm/hyp/built-in.o
  LD      arch/arm64/kvm/built-in.o
make[1]: *** [scripts/package/Makefile:96: bindeb-pkg] Error 2
make: *** [Makefile:1319: bindeb-pkg] Error 2
ROCKPro64 v2.1 2GB, SM961 128GB NVMe for rootfs, HDMI video & sound, Bluetooth keyboard & mouse
Started Bionic minimal - now Cosmic, Openbox desktop for general purpose daily PC.
  Reply
#20
Actually one thing I have noticed since upgrading to Cosmic is the compiler seems a little bit more chatty. I guess it is a newer version of gcc, and it is checking more. And while 4.18 and 4.19 compiles just have warnings (in colour!) 4.4 has outright fails.
ROCKPro64 v2.1 2GB, SM961 128GB NVMe for rootfs, HDMI video & sound, Bluetooth keyboard & mouse
Started Bionic minimal - now Cosmic, Openbox desktop for general purpose daily PC.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Ayufan 5.4.0 rc1 release - cannot boot Mentaluproar 0 48 11-04-2019, 11:46 PM
Last Post: Mentaluproar
Big Grin Feature Complete Debian Desktop Release Mrfixit2001 152 16,770 10-09-2019, 05:42 PM
Last Post: bcnaz
  Release 0.9.14 Ubuntu Mate desktop, LXDE, OMV, Docker CE (container) Luke 0 260 08-30-2019, 09:29 AM
Last Post: Luke
  New Stable release from Ayufan (0.8.3) Luke 13 1,743 08-06-2019, 05:19 PM
Last Post: andyburn
  ayufan 0.7.12 pre-release images (help testing) Luke 11 1,649 03-22-2019, 05:10 PM
Last Post: Luke
Star 0.7.9 Linux release from ayufan Luke 48 17,086 02-25-2019, 02:55 PM
Last Post: Luke
  RETRO-GAMING: ANNOUNCING BETA RELEASE OF RECALBOX FOR THE ROCKPRO64 Mrfixit2001 28 3,345 02-22-2019, 04:03 PM
Last Post: Luke
Big Grin ANNOUNCING RECALBOX FOR THE ROCKPRO64 - ALPHA RELEASE Mrfixit2001 20 4,955 01-10-2019, 11:42 AM
Last Post: Luke
  0.7.11 pre-release Bullet64 0 493 10-25-2018, 01:53 PM
Last Post: Bullet64
  No more update on ayufan's github release Ryan 4 798 09-30-2018, 06:16 PM
Last Post: Takenover83

Forum Jump:


Users browsing this thread: 1 Guest(s)