[Oct 09] Stock Android 7.1.2 (20180921) - RockPro64 | [Sept 25] KDE Neon (20180917) - Pinebook / Slackware Aarch64 Miniroot (20180901) - ROCK64 | [Aug 6] Debian Stretch Minimal 64bit (0.7.8) / Ubuntu 18.04 Bionic LXDE Desktop Image (0.7.8) / Ubuntu 18.04 Bionic minimal 64bit / 32bit Image (0.7.8) / Ubuntu 18.04 Bionic Containers Image (0.7.8) / Stretch OpenMediaVault OS Image armhf / Stretch OpenMediaVault OS Image arm64 ( 0.7.8) - ROCK64

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy


USB 2.0 OTG port
#1
I have rock64 board, flashed Ubuntu 18.04 Bionic minimal 64bit Image booting off of sd-card. Updated rk3328-rock64.dts


Code:
&usb20_otg {
    dr_mode = "**peripheral**";
    status = "okay";
};

compiled and updated rk3328-rock64.dtb. Connected usb (type A) cable, rock64 USB 2.0 OTG port - latop. Laptop couldn't detect the usb-serial connection though.


Is rock64 OTG port working? am I missing any steps?

Any suggestion is very much appreciated because otg support is the blocker!!

Thank you in advance,
Gautham
Reply
#2
Hi,

You must enable USB Serial gadget and configure it to make it working.
There is commit made by ayufan on his repo which adds ETH gadget, look it and you can change it to be as Serial gadget:
https://github.com/ayufan-rock64/linux-p...99b691ff4a
Also, there is some articles how to make it on Raspberry Pi Zero: https://forum.armbian.com/topic/1735-tut...onnection/ or on AllWinner devices https://github.com/dpavlin/usb-otg .

Good luck

-gamiee
Reply
#3
Thank for the suggestion. Works like a charm !!.
Reply
#4
(10-10-2018, 11:40 AM)gautham159 Wrote: Thank for the suggestion. Works like a charm !!.

any chance you can give me a rundown of what exactly you did?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)