Freeze/reboot/errors when compiling - unable to make - reproducible and not isolated
(10-01-2018, 02:36 AM)hunderteins Wrote: aarch64 can't be the problem. I just got hashcat-4.2.1.tar.gz, extracted it, installed opencl and compiled it with
$ CFLAGS="-mtune=cortex-a53 -march=armv8-a+crc+crypto" CC=gcc-7 make -j4
$ ls -l hashcat
-rwxr-xr-x 1 user users 730496 Oct  1 10:22 hashcat

on altlinux sisyphus.

    On a fresh installation, I did
apt-get install opencl-headers
The following NEW packages will be installed:
  opencl-c-headers opencl-clhpp-headers opencl-headers

     I then added buster to my /etc/apt/sources.list
deb buster main contrib non-free
deb-src buster main contrib non-free
deb buster/updates main contrib non-free
deb-src buster/updates main contrib non-free
deb buster-updates main contrib non-free
deb-src buster-updates main contrib non-free

     and did,
apt-get update
apt-get install gcc-7
The following NEW packages will be installed:
  binutils-aarch64-linux-gnu binutils-common cpp-7 gcc-7 gcc-7-base gcc-8-base libasan4 libbinutils libgcc-7-dev libisl19 liblsan0 libmpfr6 libtsan0
The following packages will be upgraded:
  binutils libatomic1 libc-bin libc-dev-bin libc-l10n libc6 libc6-dev libcc1-0 libgcc1 libgomp1 libitm1 libmpc3 libubsan0 locales

tar -zxf hashcat-4.2.1.tar.gz
cd hashcat-4.2.1
CFLAGS="-mtune=cortex-a53" CC=gcc-7 make -j4
gcc -c -mtune=cortex-a53 -pipe -std=gnu99 -Iinclude/ -IOpenCL/ -Ideps/lzma_sdk/ -O2 -Ideps/OpenCL-Headers/ -DWITH_HWMON deps/lzma_sdk/LzmaDec.c -o obj/LzmaDec.NATIVE.STATIC.o
    Compiling hangs and system reboots.
tar -zxf hashcat-4.2.1.tar.gz
cd hashcat-4.2.1
CC=gcc-7 make
gcc -c -pipe -std=gnu99 -Iinclude/ -IOpenCL/ -Ideps/lzma_sdk/ -O2 -Ideps/OpenCL-Headers/ -DWITH_HWMON deps/lzma_sdk/LzmaDec.c -o obj/LzmaDec.NATIVE.STATIC.o
    I found identical results with CC="gcc-7" (i.e. gcc-7 in quotation marks). I also tried this whole rigamarole with gcc-8.
    I have added 1GB of swap to no avail.

    What have I done wrong?

Messages In This Thread
RE: Freeze/reboot/errors when compiling - unable to make - reproducible and not isolated - by jovval - 10-02-2018, 08:10 AM

Possibly Related Threads…
Thread Author Replies Views Last Post
  i2c0 transfers cause bus errors michaelanburaj 0 1,768 07-14-2020, 02:25 PM
Last Post: michaelanburaj
  Unable to boot armbian fchazal 2 4,085 05-19-2020, 06:43 PM
Last Post: Rocklobster
  gstreamer unable to process dvbsrc from ATSC tuner dongle grkblood13 1 3,096 08-31-2019, 09:01 PM
Last Post: grkblood13
  Errors were encountered while processing: initramfs-tools MotoTom 0 2,489 03-03-2019, 11:53 AM
Last Post: MotoTom
Question HDD filesystem corruption at reboot / poweroff (DietPi) WrongWorld 1 3,061 02-11-2019, 04:00 PM
Last Post: WrongWorld
  USB drive powered off after reboot huberttrz 1 3,199 12-20-2018, 05:39 PM
Last Post: huberttrz
  Spontaneous Reboot during scp with Ubuntu bionic 0.7.8-1061 perniciouscaffeine 0 1,978 10-16-2018, 05:34 PM
Last Post: perniciouscaffeine
  [solved] Unable to start X Osiander 8 11,997 10-03-2018, 03:54 AM
Last Post: jovval
  Cannot make DAC Add-on Board work under debian szclsya 0 1,966 09-29-2018, 12:57 AM
Last Post: szclsya
  USB Errors with ASI camera GuLinux 0 1,914 09-18-2018, 03:48 AM
Last Post: GuLinux

Forum Jump:

Users browsing this thread: 1 Guest(s)