Marvel 9215 Sata controller support
#1
Could the following sata controller be supported on the rockpro?

http://www.sybausa.com/index.php?route=p...uct_id=722

It has pcie x4 and uses the marvel 9215 chipset.
  Reply
#2
(09-03-2018, 02:38 PM)MisterA Wrote: Could the following sata controller be supported on the rockpro?

http://www.sybausa.com/index.php?route=p...uct_id=722

It has pcie x4 and uses the marvel 9215 chipset.

I don't see why not i would check to see if it has arm modules to load into the kernel......
  Reply
#3
(09-07-2018, 08:50 AM)jerry110 Wrote:
(09-03-2018, 02:38 PM)MisterA Wrote: Could the following sata controller be supported on the rockpro?

http://www.sybausa.com/index.php?route=p...uct_id=722

It has pcie x4 and uses the marvel 9215 chipset.

I don't see why not i would check to see if it has arm modules to load into the kernel......

I think it could be made to work. Right now however in get a kernel panic with every pcie card I tested.
Perhaps a kernel recompile will be needed. Not sure what is going on.
  Reply
#4
Hello,

I got the following SATA controller card with the Marvell 88SE9230 chipset working: https://www.amazon.de/gp/product/B01ENKQ...UTF8&psc=1

The trick was to put pci=nomsi into the kernel boot parameters in /boot/extlinux/extlinux.conf

(also, before you start looking for driver errors for hours, check if your hard disks are actually working, a defective one cost me n hour of debugging today Big Grin )
  Reply
#5
(09-24-2018, 04:31 PM)mmatyas Wrote: Hello,

I got the following SATA controller card with the Marvell 88SE9230 chipset working: https://www.amazon.de/gp/product/B01ENKQ...UTF8&psc=1

The trick was to put pci=nomsi into the kernel boot parameters in /boot/extlinux/extlinux.conf

(also, before you start looking for driver errors for hours, check if your hard disks are actually working, a defective one cost me n hour of debugging today Big Grin )

Ok, I will try that. 

Until now when I do a coldboot (I plugin the powersupply and then hit the powerbutton) I see the three leds on de pcie card light up, but I get an error message and the system hangs (see picture attached). 

error messag PCIe

When I then reset the system (~warmboot) the three leds light up for second and then go out, and the pcie card gets extremely hot. Eventually the system hangs with a kernelpanic again.
  Reply
#6
(09-24-2018, 04:31 PM)mmatyas Wrote: Hello,

I got the following SATA controller card with the Marvell 88SE9230 chipset working: https://www.amazon.de/gp/product/B01ENKQ...UTF8&psc=1

The trick was to put pci=nomsi into the kernel boot parameters in /boot/extlinux/extlinux.conf

(also, before you start looking for driver errors for hours, check if your hard disks are actually working, a defective one cost me n hour of debugging today Big Grin )

Nice job  Smile

Can you please post some benchmarks?
Sorry for any mistakes. English is not my native language

1. RP64 v2.1 / PCIe SATA JMS585 Chipsatz / Booting from an 2,5 Zoll SSD on port 5/ 2 * 3,5 Zoll 4TB HDD (raid1) md0 / 2 * 2,5 Zoll 2TB HDD (raid1) md1 / using as NAS / Kernel 5.6.0-1137-ayufan-ge57f05e7bf8f

2. RP64 v2.1 / testing.....testing....testing 

https://forum.frank-mankel.org/category/14/rockpro64
  Reply
#7
Adding the switch does not work in my case.

Overall I find the board to be very unstable. Different results after reboots.

1. When I boot with the pcie card inserted: the system hangs during boot.
2. When I reboot: the card doesn't seem to initialise properly (leds poweron but fade out after a second) but the system boots. The card gets extremely hot, 'lspci' doesn't show a thing.

Doing a reboot by pulling the power cable and reinserting it results in situation 2. 
Pulling the cable and booting the system once without the PCIe card and then powering it off and inserting the PCIe card, and then do a boot results in the cycle above restarting again.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  ROCKPro64 with 16 ports SATA controller ZeblodS 16 6,375 01-21-2021, 08:59 PM
Last Post: Film Gab
  Won't boot with SATA card rjzak 4 736 01-09-2021, 05:56 PM
Last Post: kuleszdl
  SATA issues machina 25 9,146 10-16-2020, 12:16 PM
Last Post: lrb
  Rockpro64 Sata Card kills itself jerry110 19 8,260 10-15-2020, 04:22 AM
Last Post: GreyLinux
  Cheap 4-port SATA card working with RockPro64 4Gb andyburn 6 2,310 08-10-2020, 08:36 PM
Last Post: zer0sig
  PCI Express x4 Device Support machinevault 4 2,220 07-13-2020, 01:32 PM
Last Post: pgwipeout
  PCI-e to Dual SATA-II Interface Card only works with one disk taube 4 1,396 12-27-2019, 10:42 AM
Last Post: taube
  Sata power cable sputnik13 1 742 08-15-2019, 06:32 PM
Last Post: tllim
  Need to add various Wifi chipset support slappymcphee 6 1,786 08-15-2019, 05:26 PM
Last Post: evilbunny
  JMicron cipset SATA PCI-E card support Yroth 2 921 07-27-2019, 08:52 PM
Last Post: stuartiannaylor

Forum Jump:


Users browsing this thread: 1 Guest(s)