[Feb 26] Recalbox beta v3.1- Rock64 |[Feb 26] Recalbox 190222- RockPro64 / Minimal Debian by mrfixit2001 - 190222 - RockPro64 |[Feb 26] Q4OS 2.7-r2 - Pinebook 1080P / Pinebook |[Feb 22] Batocera Linux 5.20-20190121- RockPro64 | [Feb 19] Manjaro KDE 19.02 / Manjaro LXQT 19.02 - Pinebook1080P / Pinebook | [Feb 19] Slackware Aarch64 Miniroot and XFCE 20190201 - RockPro | [Feb 19] Slackware Aarch64 Miniroot and XFCE 20190201 - Rock64

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy


Tool to Control Fan - fanctl
(12-25-2018, 09:29 PM)tuxd3v Wrote:
(12-25-2018, 05:59 PM)stFfn Wrote: this
Code:
[email protected]:~# ls -l /usr/bin/lua && find /usr -name liblua\*
lrwxrwxrwx 1 root root 15 Dec 25 21:24 /usr/bin/lua -> /usr/bin/lua5.3
/usr/share/doc/liblua5.3-dev
/usr/share/doc/liblua5.1-0
/usr/share/doc/liblua5.3-0
/usr/share/doc/liblua5.1-0-dev
/usr/lib/arm-linux-gnueabihf/liblua5.1.a
/usr/lib/arm-linux-gnueabihf/liblua5.1.so.0
/usr/lib/arm-linux-gnueabihf/liblua5.1.so.0.0.0
/usr/lib/arm-linux-gnueabihf/liblua5.3-c++.so
/usr/lib/arm-linux-gnueabihf/liblua5.3.so.0.0.0
/usr/lib/arm-linux-gnueabihf/liblua5.1.so
/usr/lib/arm-linux-gnueabihf/liblua5.3-c++.a
/usr/lib/arm-linux-gnueabihf/liblua5.1-c++.so
/usr/lib/arm-linux-gnueabihf/liblua5.1-c++.so.0.0.0
/usr/lib/arm-linux-gnueabihf/liblua5.3-c++.so.0.0.0
/usr/lib/arm-linux-gnueabihf/liblua5.3.a
/usr/lib/arm-linux-gnueabihf/liblua5.3.so.0
/usr/lib/arm-linux-gnueabihf/liblua5.1-c++.so.0
/usr/lib/arm-linux-gnueabihf/liblua5.3-c++.so.0
/usr/lib/arm-linux-gnueabihf/liblua5.1-c++.a
/usr/lib/arm-linux-gnueabihf/liblua5.3.so

Remove lua 5.1 interpreter  is the easiest way..
Other way would be using alternatives..

but this should solve the problem:

Code:
apt-get remove lua5.1 lua5.1-dev

I reinstalled the system and installed only lua 5.3 and dev.

Code:
[email protected]:~# apt-cache policy lua5.3 lua5.3-dev
lua5.3:
 Installed: 5.3.3-1
 Candidate: 5.3.3-1
 Version table:
*** 5.3.3-1 500
       500 http://cdn.debian.net/debian stretch/main arm64 Packages
       100 /var/lib/dpkg/status
liblua5.3-dev:
 Installed: 5.3.3-1
 Candidate: 5.3.3-1
 Version table:
*** 5.3.3-1 500
       500 http://cdn.debian.net/debian stretch/main arm64 Packages
       100 /var/lib/dpkg/status

but i cant install your master now...
Code:
[email protected]:~# luarocks build https://raw.githubusercontent.com/tuxd3v/ats/master/ats-master-0.rockspec
-bash: luarocks: command not found
what can i do?
Reply
(12-26-2018, 03:33 AM)stFfn Wrote:
Code:
[email protected]:~# luarocks build https://raw.githubusercontent.com/tuxd3v/ats/master/ats-master-0.rockspec
-bash: luarocks: command not found
what can i do?

Does you installed LuaRocks?
If yes, it is not finding it..

Check were luarocks is installed:
Code:
which luarocks

If its not Installed, you need to install it.
Reply
(12-26-2018, 05:46 AM)tuxd3v Wrote:
(12-26-2018, 03:33 AM)stFfn Wrote:
Code:
[email protected]:~# luarocks build https://raw.githubusercontent.com/tuxd3v/ats/master/ats-master-0.rockspec
-bash: luarocks: command not found
what can i do?

Does you installed LuaRocks?
If yes, it is not finding it..

Check were luarocks is installed:
Code:
which luarocks

If its not Installed, you need to install it.

no i did not instrall it. i thought lua5.3 is the correct thing i need?

what exactly do i need to install and how can i install it?
Reply
Hello Tuxdev are you still there? Smile
Reply
(12-26-2018, 05:56 AM)stFfn Wrote: no i did not instrall it. i thought lua5.3 is the correct thing i need?

what exactly do i need to install and how can i install it?

Hello, you need to follow all the steps in GitHub page project.
It could be that you maybe need to add something to the dynamic link,and rebuild the cache.

with ldconfig

Its difficult to debug without proper access to the system  Sad
Reply
(01-03-2019, 06:26 AM)tuxd3v Wrote:
(12-26-2018, 05:56 AM)stFfn Wrote: no i did not instrall it. i thought lua5.3 is the correct thing i need?

what exactly do i need to install and how can i install it?

Hello, you need to follow all the steps in GitHub page project.
It could be that you maybe need to add something to the dynamic link,and rebuild the cache.

with ldconfig

Its difficult to debug without proper access to the system  Sad
is there any way i could communitcate with you live? like on facebook or something?
Reply
Ok i Figured out my Misstake.... now i can install your Master. But now i have a new Problem. Your Master is now Newer and i cant find anything to edit in it. its Version 0.2.0.

i Cant find the 3 Profiles where i can choose how big the fan is and i cant find the value to edit on how fast the fan should spin.... Undecided
Reply
(01-05-2019, 01:05 PM)stFfn Wrote: Ok i Figured out my Misstake.... now i can install your Master. But now i have a new Problem. Your Master is now Newer and i cant find anything to edit in it. its Version 0.2.0.

i Cant find the 3 Profiles where i can choose how big the fan is and i cant find the value to edit on how fast the fan should spin.... Undecided

Hello stFfn,
Sorry for not replying to you soon, I have been in work in another Country..

Yes, the version that is in Master, is yet the Latest stable version..
It was released to stable some days ago, v0.2.0.

The profiles was dropped, because is was dificult to achieve good profiles with a lot of people having different setups..  Undecided
I made a Tutorial about this new version.

Basicaly it have a file in /etc/ats.conf
On this file, you can edit Max pwm( power for Fan )
if you want fan always on or On/oFF, and so on  Shy

For some time the version that is in Master branch, could be broken now, because I am/will when I have some free time, Continue the work, to add support for control also via GPIO, internal board i2c, GPIO i2c, 1wire etc.  Shy

So that you could use what you want, for example, use Fan Header conecOr for CPU  Fan, and GPIO for NASCasa for example, or another configuration.
To do that, I need to redesign the Application backend, with a common Interface, for several functions, but I want iT To be standard, so that could be easli extended..

Long story short: For Some time, better to install the Stable release, the last one v0.2.0( Method 2. )
Some days ago, I updated the Tutorial for that.

You can edit /etc/ats.conf, with nano, or vi
Regards
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)