Rock64 - can not connect via store's USB-to-serial nor see (if) booting.
#1
My attempts (five steps) and my question follow.


1.    With the store's USB adapter, I have flashed eMMC 16GB using Etcher on a Windows 7 laptop with the image in the second link that follows.
https://etcher.io/
https://github.com/ayufan-rock64/linux-b...m64.img.xz

2.    I have put the eMMC in my Rock64.

3.    I have wired and connected the store's USB-to-serial adapter and my Rock64.
    On USB-to-serial adapter (pins at right):
Jumper is south (facing me) and set on east pair of pins, S1 and 3V3.
GND: black (goes to GND on Rock64's PI-2 bus)
RTX: brown (goes to TXD on Rock64's PI-2 bus)
TXD: white (goes to RTX on Rock64's PI-2 bus)
3V3: red (most northward cable) - NOT CONNECTED to Rock64
    On Rock64, PI-2 bus (long set of pins) is most northward; HDMI is south; GigE/USB is east.
    Bottom (southern) pins are numbered odd starting at 1 (going to 39); top (northern) pins are numbered even starting at 2 (going to 40). See,
    bottom (southern) pin (this is the leftmost one):
1  3.3V PWR - DO NOT use. See Serial Console for the Rock64 - https://forum.pine64.org/showthread.php?tid=4928 - NO EXPLANATION given for why!
    top (northern) pins:
6  GND: black (goes to GND on USB adapter)
8  TXD: brown (goes to RTX on USB adapter)
10 RTX: white (goes to TXD on USB adapter)
    Executive Summary:
USB    Rock64
GND <---> GND
Rx <---> Tx
Tx <---> Rx

4.    I have tried putty on Windows 7 (to no avail), and then minicom on Debian, and now Raspian.
    Upon plugging in USB-to-serial adapter on Debian, I saw/see a red led (and iirc, a light blue led next to it, at  least on Debian)
# dmesg | tail -n 10
    gave
# usb 6-1: ch341-uart converter now attached to ttyUSB0
    I issued
# minicom -s -D /dev/ttyUSB0 -b 1500000
    which returned (for both Debian and now Raspian)
Welcome to minicom 2.7

OPTIONS: I18n
Compiled on May  7 2017, 05:18:49.
Port /dev/ttyUSB0, 14:19:34

Press CTRL-A Z for help on special keys

5. I plugged in power which lit an additional led on the Rock64. I see no change at my console (minicom).

ADDENUM: blue led is lit @RPi too; HDMI connected but monitor shows nothing.

QUESTION: What did I omit/do wrong, or what should I be doing next (or should have done before)?
  Reply
#2
(08-30-2018, 06:50 AM)jovval Wrote: My attempts (five steps) and my question follow.


1.    With the store's USB adapter, I have flashed eMMC 16GB using Etcher on a Windows 7 laptop with the image in the second link that follows.
https://etcher.io/
https://github.com/ayufan-rock64/linux-b...m64.img.xz

2.    I have put the eMMC in my Rock64.

3.    I have wired and connected the store's USB-to-serial adapter and my Rock64.
    On USB-to-serial adapter (pins at right):
Jumper is south (facing me) and set on east pair of pins, S1 and 3V3.
GND: black (goes to GND on Rock64's PI-2 bus)
RTX: brown (goes to TXD on Rock64's PI-2 bus)
TXD: white (goes to RTX on Rock64's PI-2 bus)
3V3: red (most northward cable) - NOT CONNECTED to Rock64
    On Rock64, PI-2 bus (long set of pins) is most northward; HDMI is south; GigE/USB is east.
    Bottom (southern) pins are numbered odd starting at 1 (going to 39); top (northern) pins are numbered even starting at 2 (going to 40). See,
    bottom (southern) pin (this is the leftmost one):
1  3.3V PWR - DO NOT use. See Serial Console for the Rock64 - https://forum.pine64.org/showthread.php?tid=4928 - NO EXPLANATION given for why!
    top (northern) pins:
6  GND: black (goes to GND on USB adapter)
8  TXD: brown (goes to RTX on USB adapter)
10 RTX: white (goes to TXD on USB adapter)
    Executive Summary:
USB    Rock64
GND <---> GND
Rx <---> Tx
Tx <---> Rx

4.    I have tried putty on Windows 7 (to no avail), and then minicom on Debian, and now Raspian.
    Upon plugging in USB-to-serial adapter on Debian, I saw/see a red led (and iirc, a light blue led next to it, at  least on Debian)
# dmesg | tail -n 10
    gave
# usb 6-1: ch341-uart converter now attached to ttyUSB0
    I issued
# minicom -s -D /dev/ttyUSB0 -b 1500000
    which returned (for both Debian and now Raspian)
Welcome to minicom 2.7

OPTIONS: I18n
Compiled on May  7 2017, 05:18:49.
Port /dev/ttyUSB0, 14:19:34

Press CTRL-A Z for help on special keys

5. I plugged in power which lit an additional led on the Rock64. I see no change at my console (minicom).

ADDENUM: blue led is lit @RPi too; HDMI connected but monitor shows nothing.

QUESTION: What did I omit/do wrong, or what should I be doing next (or should have done before)?

Please post a photo on your board and USB-to-serial adapter connection.
  Reply
#3
Is your board booting from SD card.
  Reply
#4
(09-03-2018, 06:03 AM)Rocklobster Wrote: Is your board booting from SD card.

I have now tried with a microSD card installed. It is readable, showing the debian installer on a rpi, and looks OK.

With or without the serial cable attached, my Rock64 does not appear to boot.

I do have an ethernet cable plugged into the Rock64. Shouldn't the adapter's light(s) come on if the Rock64 successfully boots?
  Reply
#5
Now that you have your board booting post a picture as suggested by tllim above.
  Reply
#6
(09-04-2018, 02:30 PM)Rocklobster Wrote: Now that you have your board booting post a picture as suggested by tllim above.

EDIT: Also, when the serial cables are attached to the PI-2 bus and I connect the power, the dim blue led next to the bus goes dark while the red led stays lit. The power led goes from dim green to bright green. minicom disconnects and /dev/ttyUSB0 disappears replaced by /dev/ttyUSB1 (which gives me the same non-results when I try to connect to through it via minicom).

I have no evidence that the board is booting. The ethernet jack shows no lights and my dhcpd shows no request for an IP.

As I stated,
"With or without the serial cable attached, my Rock64 does not appear to boot.

I do have an ethernet cable plugged into the Rock64. Shouldn't the adapter's light(s) come on if the Rock64 successfully boots? "

I can not post a picture, as I do not have a camera. Otherwise, I would have gladly complied with your first request. I did not mean to seem rude.

If I can track down a camera with suitable software, I will post a shot of what I have. I appreciate your interest and your willingness to help.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Centos 8 Stream on Rock64 ayoungdukie 1 133 06-07-2021, 11:50 AM
Last Post: zer0sig
  Talos on ROCK64 cjyar 2 141 06-04-2021, 11:50 AM
Last Post: cjyar
  CentOS 7 for Rock64 pineadmin 3 2,692 05-30-2021, 08:20 AM
Last Post: ayoungdukie
  Rock64 CRUX-ARM (aarch64) mara 0 110 05-27-2021, 02:22 PM
Last Post: mara
  DietPi OS for ROCK64 MichaIng 15 3,924 05-24-2021, 07:46 AM
Last Post: MichaIng
  openwrt for the rock64 wilsonYan 14 5,990 05-23-2021, 07:53 AM
Last Post: stamasd
  RETRO-GAMING: UPDATED RELEASE OF RECALBOX FOR THE ROCK64 Mrfixit2001 32 24,397 05-22-2021, 07:01 AM
Last Post: fartadeadrian
  Armbian for Rock64 pineadmin 31 20,676 05-08-2021, 09:35 AM
Last Post: Wizzard
  slarm64 (unofficial slackware) Rock64 RK3328 (aarch64) mara 113 60,697 05-02-2021, 04:48 AM
Last Post: mara
  Setting a MAC on Rock64 U-Boot kiriakos 2 565 03-23-2021, 04:51 AM
Last Post: kiriakos

Forum Jump:


Users browsing this thread: 1 Guest(s)