adb connection failed
I can not connect adb using USB-C or TCP.

- Using USB type C to C
    no device

- Using tcp(ping is succeed)
    adb connect
    unable to connect to Connection refused

If someone succeeds, please help me.

Thank you!
It works fine for me, check the wiki here.
Note use of the top USB2 port has NOT been verified - looking at the schematic it seems it may in fact be the type 3 USB A port that is OTG. But for sure I have had no problems with the type C port
  • ROCKPro64 v2.1 2GB, 16Gb eMMC for rootfs, SX8200Pro 512GB NVMe for /home, HDMI video & sound, Bluetooth keyboard & mouse. Arch (5.14 kernel, Openbox desktop) for general purpose daily PC.
  • PinePhone BraveHeart now v1.2b 3/32Gb daily driver, dual boot via p-boot with Mobian/f2fs/Phosh on eMMC, Arch/ext4/Phosh on SDcard
  • PinePhone v1.2a 2G/16Gb that needs USB board replaced
I'm also trying to get this working. when I plugged into the USB 2.0 OTG port. nothing happened. I found a type-c to type-a cable and plugged it in. my computer recognized a new device.

I am using adb to sideload gapps from

however the signature verification failed.
error: 21

it seems to be timing out at around 50% of file transfer.
I have the exact same problem.

adb devices return no device.
adb connect is falling despite that the ping is working.

I did try on android 7 and android 8. I also tried on all usb 2 ports. For usb c, I use a hub c to 3 and connect it to the MacBook pro. Also note that I tried on a MacPro with ubuntu.

lsusb on both machines, never show the rockpro64 :/ and adb is not working.

On the device itself I am developer mode and try all transfer mode possible (MTP, PTP...)

please help!
Actually, I bought a usb c to usb 3 and it works now.

Forum Jump:

Users browsing this thread: 1 Guest(s)