PCI-E add-on Success & Failures
#21
Ok, so so it seems the Pine64 pcie works, and the Delock 4 channel works only with mainline. So switched to the mainline kernel and because of my 64GB eMMC had to use the kernel patch. I find that the mainline gives me dropouts when streaming (even with mainline on the pine64 pcie and my WD Red)... So I switched back to ayufan's 4.4 kernel version of stretch: that works ok, but I would like to use 4 channels!
So I switched again to the armbian image: it feels faster,but also can not get de the Delock pcie working on the 4.4 kernel. But when I install the 4.20 one I can not boot with eMMC,but also not with SD?? So I can not check whether this one will lead to dropouts as well..

Anyone here tried the armbian 5.75 stretch images? Is there also a kernel patch necessary for the eMMC and maybe already available in the distributed kernels? And any idea why even SD boot wil not work?

Edit: Unfortunately the armbian 4.20 kernel does not contain dtb entries for pwm it seems, so I am back on the ayufan image  Tongue. The "mmc_cmdqueue=off" kernel append seems to be the reason the SD does not start. I only need to add it when booting from the emmc.
The mainline kernel 5 seems to solve my streaming error. Will do some further testing and will retry my Delock pcie as well...

Edit2: Kernel 4.20 indeed made the stream crawl. Sticking to 5 for now. Also working with the Delock pcie. Seems stable enough. Booting from SD for now as not sure what the effect off the mmc_cmdqueue off exactly entails...
  Reply
#22
Hi,

I am also using an 88SE9230 based PCIE card #, but as a matter do not get this up and running.


There are only some slightly differences to the DeLock one, which might not get the device working.

Like the Memory at region 5 is at a different address due to the bigger expansion ROM, which is also active.

Code:
01:00.0 SATA controller: Marvell Technology Group Ltd. 88SE9230 PCIe SATA 6Gb/s Controller (rev 11) (prog-if 01 [AHCI 1.0])
       Subsystem: Marvell Technology Group Ltd. 88SE9230 PCIe SATA 6Gb/s Controller
       Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
       Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
       Interrupt: pin A routed to IRQ 236
       Region 0: I/O ports at 0000
       Region 1: I/O ports at 0000
       Region 2: I/O ports at 0000
       Region 3: I/O ports at 0000
       Region 4: I/O ports at 0000
       Region 5: Memory at fa040000 (32-bit, non-prefetchable) [size=2K]
       Expansion ROM at fa000000 [size=256K]
       Capabilities: [40] Power Management version 3
               Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot+,D3cold-)
               Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
       Capabilities: [50] MSI: Enable- Count=1/1 Maskable- 64bit-
               Address: fee30040  Data: 0000
       Capabilities: [70] Express (v2) Legacy Endpoint, MSI 00
               DevCap: MaxPayload 512 bytes, PhantFunc 0, Latency L0s <1us, L1 <8us
                       ExtTag- AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
               DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
                       RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
                       MaxPayload 256 bytes, MaxReadReq 512 bytes
               DevSta: CorrErr- UncorrErr- FatalErr- UnsuppReq- AuxPwr- TransPend-
               LnkCap: Port #0, Speed 5GT/s, Width x2, ASPM L0s L1, Exit Latency L0s <512ns, L1 <64us
                       ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
               LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- CommClk-
                       ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
               LnkSta: Speed 5GT/s, Width x2, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
               DevCap2: Completion Timeout: Not Supported, TimeoutDis+, LTR-, OBFF Not Supported
               DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled
               LnkCtl2: Target Link Speed: 5GT/s, EnterCompliance- SpeedDis-
                        Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
                        Compliance De-emphasis: -6dB
               LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete-, EqualizationPhase1-
                        EqualizationPhase2-, EqualizationPhase3-, LinkEqualizationRequest-
       Capabilities: [e0] SATA HBA v0.0 BAR4 Offset=00000004
       Capabilities: [100 v1] Advanced Error Reporting
               UESta:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
               UEMsk:  DLP- SDES- TLP- FCP- CmpltTO- CmpltAbrt- UnxCmplt- RxOF- MalfTLP- ECRC- UnsupReq- ACSViol-
               UESvrt: DLP+ SDES+ TLP- FCP+ CmpltTO- CmpltAbrt- UnxCmplt- RxOF+ MalfTLP+ ECRC- UnsupReq- ACSViol-
               CESta:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr-
               CEMsk:  RxErr- BadTLP- BadDLLP- Rollover- Timeout- NonFatalErr+
               AERCap: First Error Pointer: 00, GenCap- CGenEn- ChkCap- ChkEn-


Does someone have an idea to also get that one working?
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  4K Success? bprotas 1 546 08-08-2018, 06:22 AM
Last Post: gabrielsr

Forum Jump:


Users browsing this thread: 1 Guest(s)