EMMC not booting while SD does.
#21
I just want to note, I did try booting from a sd card, and using dd to copy the image over to the emmc via the tutorial in the guide section. Tutorial worked fine, but unfortunately my board still would not boot from the emmc.
#22
I got eMMC working by flashing SPI from here:

https://github.com/ayufan-rock64/linux-u...df02018479
#23
(09-28-2018, 05:02 PM)jnoxon Wrote: I got eMMC working by flashing SPI from here:

https://github.com/ayufan-rock64/linux-u...df02018479
jnoxon Can you provide details whet did you done to run booting from emmc?
#24
(09-28-2018, 02:37 PM)Takenover83 Wrote: I just want to note, I did try booting from a sd card, and using dd to copy the image over to the emmc via the tutorial in the guide section. Tutorial worked fine, but unfortunately my board still would not boot from the emmc.

Did you found solution?
#25
(10-13-2018, 03:23 AM)jarcik Wrote:
(09-28-2018, 02:37 PM)Takenover83 Wrote: I just want to note, I did try booting from a sd card, and using dd to copy the image over to the emmc via the I sitll tutorial in the guide section. Tutorial worked fine, but unfortunately my board still would not boot from the emmc.

Did you found solution?
I still have not.
#26
(10-13-2018, 11:59 AM)Takenover83 Wrote:
(10-13-2018, 03:23 AM)jarcik Wrote:
(09-28-2018, 02:37 PM)Takenover83 Wrote: I just want to note, I did try booting from a sd card, and using dd to copy the image over to the emmc via the I sitll tutorial in the guide section. Tutorial worked fine, but unfortunately my board still would not boot from the emmc.

Did you found solution?
I still have not.

Did you try flash spi with u-boot (https://github.com/ayufan-rock64/linux-u...df02018479 ), jnoxon wrote that helped him with boot from emmc
#27
(10-14-2018, 12:52 PM)jarcik Wrote:
(10-13-2018, 11:59 AM)Takenover83 Wrote:
(10-13-2018, 03:23 AM)jarcik Wrote:
(09-28-2018, 02:37 PM)Takenover83 Wrote: I just want to note, I did try booting from a sd card, and using dd to copy the image over to the emmc via the I sitll tutorial in the guide section. Tutorial worked fine, but unfortunately my board still would not boot from the emmc.

Did you found solution?
I still have not.

Did you try flash spi with u-boot (https://github.com/ayufan-rock64/linux-u...df02018479 ), jnoxon wrote that helped him with boot from emmc
I did. That's how I came to the realization that the EMMC can be used if I am not using it to boot. I found out by accident. I was attempting to boot from usb via spi/u-boot when I finally got my rootfs that was on the emmc to boot. It pulled the boot partition from the usb, then booted the rootfs from emmc. But I have yet to get the emmc to work alone.
#28
(10-14-2018, 12:52 PM)jarcik Wrote:
(10-13-2018, 11:59 AM)Takenover83 Wrote:
(10-13-2018, 03:23 AM)jarcik Wrote:
(09-28-2018, 02:37 PM)Takenover83 Wrote: I just want to note, I did try booting from a sd card, and using dd to copy the image over to the emmc via the I sitll tutorial in the guide section. Tutorial worked fine, but unfortunately my board still would not boot from the emmc.

Did you found solution?
I still have not.

Did you try flash spi with u-boot (https://github.com/ayufan-rock64/linux-u...df02018479 ), jnoxon wrote that helped him with boot from emmc

i have the same issue with RockPro64. SD card boots. eMMC not.

i did try to flash SPI with https://github.com/ayufan-rock64/linux-u...df02018479 the image did start (white LED was blinking once a second) but i had no output on HDMI. it just did not have any effect on booting behavior.

is there some other way to get my RockPro64 to boot eMMC? the SD is really slow...
#29
Why flash SPI when you will boot from eMMC ? SPI is only memory for u-boot.

So RP64 will load u-boot from SPI, and then search for an bootable device. (USB2, USB3) PCIe don't work atm.

So, erase your SPI and flash the image to your eMMC. Then boot your system.

To control the boot process use an uart-adapter.

Edit:
Quick test with ayufan image 0.7.13 works fine, and with wifi Wink
Sorry for any mistakes. English is not my native language

1. Quartz64 Model B, 4GB RAM

2. Quartz64 Model A, 4GB RAM

3. RockPro64 v2.1

https://linux-nerds.org/
#30
Bought a RockPro64, sata card, 5A psu, and a 32GB eMMC card, set up openmediavault with two drives and all was well - until the next morning. Something went wrong with it, lots of admin emails saying the drives no longer available, the eMMC card now only has 16gb instead of 32gb. After about 2 weeks pine64 finally properly answer emails (delay caused by Chinese NY it seems) saying to return the card so they can test it, more delay.

Pine64 got me to return the faulty eMMC for evaluation - they eventually sent me 'another' 32GB eMMC after agreeing that the module was faulty. The one they returned was also faulty (it was probably the same card that I sent) - except that this one showed as 31 GB (screenshot https://drive.google.com/open?id=1vlgrEdHTf20M2RUic9hiKghfqxCyfXts ). It now looks like the RockPro64 is faulty as it won't boot up with eMMC or SD card - there is no white light.

I am going to have another go at fixing this POJ today - if no joy then I am after a refund.

Edit: Looks like the RP64 may have fried my 32GB SD card as well.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Installation Debian on emmc: which U-Boot and where? vongillus 3 165 07-02-2022, 09:24 AM
Last Post: dkebler
  Booting my RockPro64 from NVMe drive PsySc0rpi0n 4 2,801 05-11-2022, 02:35 PM
Last Post: PsySc0rpi0n
  Flash to eMMC? Barugon 4 372 04-27-2022, 03:10 PM
Last Post: Barugon
  Sata HD stopped booting db579 2 480 03-11-2022, 03:34 PM
Last Post: db579
  rockpro64 emmc GreyLinux 8 2,646 11-08-2021, 01:56 PM
Last Post: GreyLinux
  eMMC 128gb flailingeffort 1 1,525 01-18-2021, 04:42 AM
Last Post: Wizzard
Exclamation need help booting off USB 3.0 HDD/SSD idontgetit 1 2,051 10-29-2020, 04:50 AM
Last Post: t4_4t
  Rockpro64 with PCI FC Card - Not booting (Sometimes) MSteam 1 1,893 10-25-2020, 07:42 PM
Last Post: MSteam
  RockPro64 eMMC boot euu 4 5,111 08-24-2020, 11:07 PM
Last Post: t4_4t
  sw4 jumper for disabling eMMC boot / multiboot ChriChri 0 1,543 03-09-2020, 08:54 AM
Last Post: ChriChri

Forum Jump:


Users browsing this thread: 1 Guest(s)