EMMC not booting while SD does.
#21
I just want to note, I did try booting from a sd card, and using dd to copy the image over to the emmc via the tutorial in the guide section. Tutorial worked fine, but unfortunately my board still would not boot from the emmc.
  Reply
#22
I got eMMC working by flashing SPI from here:

https://github.com/ayufan-rock64/linux-u...df02018479
  Reply
#23
(09-28-2018, 05:02 PM)jnoxon Wrote: I got eMMC working by flashing SPI from here:

https://github.com/ayufan-rock64/linux-u...df02018479
jnoxon Can you provide details whet did you done to run booting from emmc?
  Reply
#24
(09-28-2018, 02:37 PM)Takenover83 Wrote: I just want to note, I did try booting from a sd card, and using dd to copy the image over to the emmc via the tutorial in the guide section. Tutorial worked fine, but unfortunately my board still would not boot from the emmc.

Did you found solution?
  Reply
#25
(10-13-2018, 03:23 AM)jarcik Wrote:
(09-28-2018, 02:37 PM)Takenover83 Wrote: I just want to note, I did try booting from a sd card, and using dd to copy the image over to the emmc via the I sitll tutorial in the guide section. Tutorial worked fine, but unfortunately my board still would not boot from the emmc.

Did you found solution?
I still have not.
  Reply
#26
(10-13-2018, 11:59 AM)Takenover83 Wrote:
(10-13-2018, 03:23 AM)jarcik Wrote:
(09-28-2018, 02:37 PM)Takenover83 Wrote: I just want to note, I did try booting from a sd card, and using dd to copy the image over to the emmc via the I sitll tutorial in the guide section. Tutorial worked fine, but unfortunately my board still would not boot from the emmc.

Did you found solution?
I still have not.

Did you try flash spi with u-boot (https://github.com/ayufan-rock64/linux-u...df02018479 ), jnoxon wrote that helped him with boot from emmc
  Reply
#27
(10-14-2018, 12:52 PM)jarcik Wrote:
(10-13-2018, 11:59 AM)Takenover83 Wrote:
(10-13-2018, 03:23 AM)jarcik Wrote:
(09-28-2018, 02:37 PM)Takenover83 Wrote: I just want to note, I did try booting from a sd card, and using dd to copy the image over to the emmc via the I sitll tutorial in the guide section. Tutorial worked fine, but unfortunately my board still would not boot from the emmc.

Did you found solution?
I still have not.

Did you try flash spi with u-boot (https://github.com/ayufan-rock64/linux-u...df02018479 ), jnoxon wrote that helped him with boot from emmc
I did. That's how I came to the realization that the EMMC can be used if I am not using it to boot. I found out by accident. I was attempting to boot from usb via spi/u-boot when I finally got my rootfs that was on the emmc to boot. It pulled the boot partition from the usb, then booted the rootfs from emmc. But I have yet to get the emmc to work alone.
  Reply
#28
(10-14-2018, 12:52 PM)jarcik Wrote:
(10-13-2018, 11:59 AM)Takenover83 Wrote:
(10-13-2018, 03:23 AM)jarcik Wrote:
(09-28-2018, 02:37 PM)Takenover83 Wrote: I just want to note, I did try booting from a sd card, and using dd to copy the image over to the emmc via the I sitll tutorial in the guide section. Tutorial worked fine, but unfortunately my board still would not boot from the emmc.

Did you found solution?
I still have not.

Did you try flash spi with u-boot (https://github.com/ayufan-rock64/linux-u...df02018479 ), jnoxon wrote that helped him with boot from emmc

i have the same issue with RockPro64. SD card boots. eMMC not.

i did try to flash SPI with https://github.com/ayufan-rock64/linux-u...df02018479 the image did start (white LED was blinking once a second) but i had no output on HDMI. it just did not have any effect on booting behavior.

is there some other way to get my RockPro64 to boot eMMC? the SD is really slow...
  Reply
#29
Why flash SPI when you will boot from eMMC ? SPI is only memory for u-boot.

So RP64 will load u-boot from SPI, and then search for an bootable device. (USB2, USB3) PCIe don't work atm.

So, erase your SPI and flash the image to your eMMC. Then boot your system.

To control the boot process use an uart-adapter.

Edit:
Quick test with ayufan image 0.7.13 works fine, and with wifi Wink
Sorry for any mistakes. English is not my native language

1. RP64 v2.0 / PCIe NVMe as root / sd-card as boot / 2,5 Zoll HDD 1TB (USB3) using as Webserver .... (Kernel 4.4.167-1140-rockchip-ayufan-g6f266fb5d677)
2. RP64 v2.1 / PCIe SATA Marvell 88SE9230 Chipsatz / sd-card / 2 * 2,5 Zoll 2TB HDD (raid1) / using as NAS / Kernel 5.0.0-1101-ayufan-g41eeb7cd789e
3. RP64 v2.1 / testing.....testing....testing

https://forum.frank-mankel.org/category/14/rockpro64



  Reply
#30
Bought a RockPro64, sata card, 5A psu, and a 32GB eMMC card, set up openmediavault with two drives and all was well - until the next morning. Something went wrong with it, lots of admin emails saying the drives no longer available, the eMMC card now only has 16gb instead of 32gb. After about 2 weeks pine64 finally properly answer emails (delay caused by Chinese NY it seems) saying to return the card so they can test it, more delay.

Pine64 got me to return the faulty eMMC for evaluation - they eventually sent me 'another' 32GB eMMC after agreeing that the module was faulty. The one they returned was also faulty (it was probably the same card that I sent) - except that this one showed as 31 GB (screenshot https://drive.google.com/open?id=1vlgrEdHTf20M2RUic9hiKghfqxCyfXts ). It now looks like the RockPro64 is faulty as it won't boot up with eMMC or SD card - there is no white light.

I am going to have another go at fixing this POJ today - if no joy then I am after a refund.

Edit: Looks like the RP64 may have fried my 32GB SD card as well.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Availability of 128GB eMMC ? Arwen 1 263 07-22-2019, 11:28 AM
Last Post: Arwen
  RockPro64 not booting jekohk 10 700 06-09-2019, 01:53 PM
Last Post: Davidos
  board not working with EMMC RockPro64Newbie 1 187 05-10-2019, 02:22 AM
Last Post: Unkn0wn
  Problems with booting nJoy. 1 214 03-23-2019, 03:36 AM
Last Post: nJoy.
  Hardware issue overheating while booting and fail to boot DIDquest 13 1,074 03-23-2019, 02:50 AM
Last Post: nJoy.
  emmc / sd or ssd? LMM 3 368 02-22-2019, 08:51 AM
Last Post: LMM
  eMMC flash without usb reader jannerman 2 547 09-06-2018, 01:29 AM
Last Post: jannerman
Question Android 7.1 on EMMC not working, suggestions? SmartDIYTech 4 464 06-01-2018, 03:00 PM
Last Post: Luke

Forum Jump:


Users browsing this thread: 1 Guest(s)