[Nov 16] Arch Linux mainline XFCE (20181104) / NetBSD ([201811111550Z) - 1080P Pinebook |[Nov 13] Slackware Aarch64 Miniroot & XFCE (20181101) / NextCloudPi (11-04-18) / Armbian Debian Stretch Desktop & Armbian Ubuntu Bionic (5.65) - Rock64 |[Nov 12] Q4OS ( 2.4-r5) - 1080P Pinebook / Pinebook |[Nov 09] KDE Neon ( 20181104-1500) - 1080P Pinebook / Pinebook /Arch Linux (20181104) - Pinebook

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy


Two of our sopine's only register 1GB RAM
#1
Code:
U-Boot SPL 2018.03 (Jul 23 2018 - 18:13:46 +0200)
DRAM: 1024 MiB
Trying to boot from sunxi SPI


U-Boot 2018.03 (Jul 23 2018 - 18:13:46 +0200) Allwinner Technology

CPU:   Allwinner A64 (SUN50I)
Model: Pine64+
DRAM:  1 GiB
MMC:   SUNXI SD/MMC: 0, SUNXI SD/MMC: 1
Noticed 2 of the 42 sopines only sees 1GB DRAM instead of the 2GB. It's the same dram chip as the rest.. :-(
Anything I can test before I RMA these two?

Ps. Also the power led didn't work from start on these nodes but I didn't think much about that because some others have the same issue but they booted just fine. (Led is also to close to the plastic and stops working when you inserted them ~20 times)
Started using FreeBSD at version 2.0 but really started using it at around version 6.4. 
If it doesn't do what you want; hack it until it does!
Reply
#2
(08-07-2018, 06:56 PM)paradise Wrote:
Code:
U-Boot SPL 2018.03 (Jul 23 2018 - 18:13:46 +0200)
DRAM: 1024 MiB
Trying to boot from sunxi SPI


U-Boot 2018.03 (Jul 23 2018 - 18:13:46 +0200) Allwinner Technology

CPU:   Allwinner A64 (SUN50I)
Model: Pine64+
DRAM:  1 GiB
MMC:   SUNXI SD/MMC: 0, SUNXI SD/MMC: 1
Just noticed 1 of the 7 sopines only sees 1GB DRAM instead of the 2GB. It's the same dram chip as the rest.. :-(
Didn't check the other 35 nodes that carefully yet, hoping this one is just a loner.
Anything I can test before I RMA this one?

Ps. Also the power led didn't work from start on that node but I didn't think much about that because it booted just fine. It was telling the cluster it had 1003 MB RAM the whole time but I just didn't notice it until I made a GUI that shows all nodes and stats.
This is kind of strange. Please file a support ticket, http://support.pine64.org, and ask for RMA.
Reply
#3
Thanks, I did that.

Currently registering the other nodes in the cluster and I will know if it's just a single one.
It does look like u-boot really checks the de DRAM at power up or something, that's a pretty nice thing.

The DRAM chip seems to be placed okay on the board so it must be some address bus wire that's not connected or something which makes it more weird because I think this could only happen if it's the last of the address bus wires. (else you will be missing bytes all over the place but the node works just fine except of the 1GB)
Other thing I can think of is that the DRAM has some type of register that gets read and it tells the host that it's 1GB instead of 2GB?
Started using FreeBSD at version 2.0 but really started using it at around version 6.4. 
If it doesn't do what you want; hack it until it does!
Reply
#4
In total 2 of the 42 modules only see 1GB RAM instead of 2.
And on one of the 6 clusterboards 2 slots don't have ethernet. Just fixed with an air compressor, there was some small pieces of plastic stuck in the sockets

Support isn't responding, how do I get the RMA?
Started using FreeBSD at version 2.0 but really started using it at around version 6.4. 
If it doesn't do what you want; hack it until it does!
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  +SOPINE baseboard datasheet is different gamelaster 3 211 09-09-2018, 05:08 PM
Last Post: tllim
  How to control the SOPINE UART and SPI pins as GPIO? Pine 1 154 08-22-2018, 10:15 AM
Last Post: martinayotte
  Heatsink for SOPINE [email protected] 1 258 08-04-2018, 10:41 AM
Last Post: paradise
  SoPine eMMC compatibility Terra854 3 1,282 08-01-2018, 09:16 AM
Last Post: paradise
  SOPINE MAC Address [email protected] 2 124 07-24-2018, 02:35 AM
Last Post: [email protected]
  custom sopine baseboard - some (all) assembly still required maya.b 6 1,127 12-26-2017, 12:37 PM
Last Post: dkryder
  SoPine Use Cases Diogenes08 3 393 12-25-2017, 03:53 PM
Last Post: tllim
  Documentation for SOPINE gamelaster 2 639 10-18-2017, 04:36 AM
Last Post: gamelaster
  sopine+baseboard in thermal maya.b 7 718 06-23-2017, 10:02 AM
Last Post: netsean
  SOPINE with Allwinner A63 stephen fleming 3 875 06-22-2017, 01:17 AM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)