UART connection
#11
Some application doesn't support special rates, like picocom doesn't support 1500000 but minicom does.
Don't know about screen, maybe it is the same case ...
  Reply
#12
Screen works (as well as minicom and picocom). I use the following to start screen:

screen /dev/ttyUSB0 1500000

See also my howto for more information on the topic:
https://forum.pine64.org/showthread.php?tid=6387
  Reply
#13
(08-12-2018, 11:18 AM)Yoast Wrote: Screen works (as well as minicom and picocom).
Which version of picocom works for you ?
Mine, v1.7, gives me "FATAL: failed to add device /dev/ttyUSB0: Invalid baud rate" ...
  Reply
#14
(08-13-2018, 07:55 AM)martinayotte Wrote:
(08-12-2018, 11:18 AM)Yoast Wrote: Screen works (as well as minicom and picocom).
Which version of picocom works for you ?
Mine, v1.7, gives me "FATAL: failed to add device /dev/ttyUSB0: Invalid baud rate" ...

Code:
[[email protected]_arch ~]# picocom --help
picocom v3.1

Compiled-in options:
 TTY_Q_SZ is 0
 HIGH_BAUD is enabled
 USE_FLOCK is enabled
 LINENOISE is enabled
 HISTFILE is: .picocom_history
 USE_CUSTOM_BAUD is enabled

Most likely the compile options USE_CUSTOM_BAUD and HIGH_BAUD are needed to enable the 1.5M baud rate...
  Reply
#15
About screen's support for higher baud rates (1.5M) . There is a bug report and a (Debian only) patch that makes it work:
https://bugs.debian.org/cgi-bin/bugrepor...bug=860910

I've tried with screen running on arch and it gives me gibberish while minicom works perfectly...most of the time (I sometimes get spammed with pointy brackets "<") and that's with my Raspberry Pi 3's UART.

So, as far as I've seen, screen is only going to work if it is the patched version from Debian. (Unless the patch makes it upstream or you build it yourself with the patch.)
  Reply
#16
Thanks for pointing this out. For methe screen from openwrt was also not working at 1.5M
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)