[Nov 13] Slackware Aarch64 Miniroot & XFCE (20181101) / NextCloudPi (11-04-18) / Armbian Debian Stretch Desktop & Armbian Ubuntu Bionic (5.65) - Rock64 |[Nov 12] Q4OS ( 2.4-r5) - 1080P Pinebook / Pinebook |[Nov 09] KDE Neon ( 20181104-1500) - 1080P Pinebook / Pinebook /Arch Linux (20181104) - Pinebook |[Nov 09]Arch Linux (20181104) /Armbian - Xenial (5.56) - PineA64-LTS / SOPINE |[Nov 09]Armbian (5.65) /Arch Linux (20181104) /motionEyeOS (20180627) - PINE A64(+) |[Nov 02] Volumio ( 2.462-2018-09-29) - Rock64 |[Oct 23] AOSC with Mate Desktop [20181016] - Pinebook / Q4OS (2.6-r3) - Pinebook

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy


Intermittent PSU Connection
#1
Hi all

Just received my RockPro64 and high power PSU from Pine64 shop. The PSU connection between the barrel connector on the PSU lead and the barrel connector on the RockPro64 board seems really intermittent on mine - with it proving very tricky to get the green power LED to stay on and boot to start. I have managed it a couple of times but it's really tricky.

Am I doing something obviously wrong?

Have raised a support ticket with Pine 64 - but thought I'd ask around here if there were any known issues?
Reply
#2
(07-23-2018, 10:16 AM)noggin Wrote: Hi all

Just received my RockPro64 and high power PSU from Pine64 shop. The PSU connection between the barrel connector on the PSU lead and the barrel connector on the RockPro64 board seems really intermittent on mine - with it proving very tricky to get the green power LED to stay on and boot to start. I have managed it a couple of times but it's really tricky.

Am I doing something obviously wrong?

Have raised a support ticket with Pine 64 - but thought I'd ask around here if there were any known issues?

There's something wrong with the connector on the PSU or on the board, mine does exactly the same thing. Rotate the PSU barrel in the socket until the green light comes on and then *don't touch it* or you'll cut power.

High quality QA right here folks.
Reply
#3
(08-09-2018, 11:59 PM)Arglebargle Wrote:
(07-23-2018, 10:16 AM)noggin Wrote: Hi all

Just received my RockPro64 and high power PSU from Pine64 shop. The PSU connection between the barrel connector on the PSU lead and the barrel connector on the RockPro64 board seems really intermittent on mine - with it proving very tricky to get the green power LED to stay on and boot to start. I have managed it a couple of times but it's really tricky.

Am I doing something obviously wrong?

Have raised a support ticket with Pine 64 - but thought I'd ask around here if there were any known issues?

There's something wrong with the connector on the PSU or on the board, mine does exactly the same thing. Rotate the PSU barrel in the socket until the green light comes on and then *don't touch it* or you'll cut power.

High quality QA right here folks.

If there is any vertical pressure on my power connector the power is interrupted. Just a tiny amount of pressure from the tension in the cable will do this. This makes the board effectively unusable.

It's taking a while to resolve via the support ticket system, my last update with requested information remains un-answered after 5 days...
Reply
#4
Customer support have asked me to return my RockPro64 and my PSU - which I've done. Fingers crossed for a speedy RMA process.
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Connection 2k LCD displays over MIPI AI_newsettler 1 140 11-06-2018, 07:54 AM
Last Post: FancyPBJ
  WiFi/BT, How to make a connection? Aesop 0 213 09-27-2018, 11:07 PM
Last Post: Aesop

Forum Jump:


Users browsing this thread: 1 Guest(s)