ROCK64 NAS problem
#1
I am trying to move my NAS from a RPi2 to a ROCK64 (4GB).  Everything is working except I can't get the drives to mount at startup.  In the RPi version, it was done by adding the drive info to the fstab file.  When I do that on the ROCK64, it hangs during boot.  I can mount them manually on the command line via Putty on my Windows 10 Desktop.  After they are mounted, everything is working well, but if something causes the ROCK64 to reboot, I can't see the drives on the LAN until I mount them.  I wrote a script to mount the four drives with one command line, but I would like to have them mount automatically at startup.  I am running stretch-mate-rock64-0.5.15-136-20171222-arm64.
  Reply
#2
(06-24-2018, 04:09 PM)wjburl Wrote: I am trying to move my NAS from a RPi2 to a ROCK64 (4GB).  Everything is working except I can't get the drives to mount at startup.  In the RPi version, it was done by adding the drive info to the fstab file.  When I do that on the ROCK64, it hangs during boot.  I can mount them manually on the command line via Putty on my Windows 10 Desktop.  After they are mounted, everything is working well, but if something causes the ROCK64 to reboot, I can't see the drives on the LAN until I mount them.  I wrote a script to mount the four drives with one command line, but I would like to have them mount automatically at startup.  I am running stretch-mate-rock64-0.5.15-136-20171222-arm64.

That should not be a problem. Show us the content of your /etc/fstab and /boot/efi/extlinux/extlinux.conf
  Reply
#3
rontant, thanks for responding.

Since I made the original post, I gave up and installed Open Media Vault and that is working well. I don't think I'll revisit the original project. I guess I need to close this thread. This is my 2nd ROCK64 SBC and it is really outperforming my RPi2 by an order of magnitude.

Since I've overwritten the SD card, I can't I don't the data in /boot/efi/extlinux/extlinux.conf. The info I added to /etc/fstab was:

UUID=2291d8b3-ef45-469c-aa97-3c9fafa86f85 /media/OldIomegaDrive ext4 defaults,user,exec 0 0
UUID=0bc03e5c-4f6a-4b42-ab5b-ee62f191e328 /media/TCMMovies ext4 defaults,user,exec 0 0
UUID=05f8302e-3a6a-49db-99d1-00c4d6302425 /media/DriveDBackup ext4 defaults,user,exec 0 0
UUID=81e17742-2be9-42e1-888d-ad4cfea1c206 /media/Seagate5TBdrive ext4 defaults,user,exec 0 0
  Reply
#4
Sorry, did not see this before, but I believe in making life easy and I use Webmin to configure my Rock64 home server, it handles all mounting etc.. May be worth a look. I have never used Open Media Vault, so hope it is working well for you.
  Reply
#5
stealthbanana, Thanks. It took me a few attempts to get OMV setup the way I wanted, but it has been working well since. One issue I had was that my HDDs already had data and OMV wants to format the drives and start over. It doesn't let you share an entire drive, so I had to move the contents of a drive to a folder and share that folder. Now that it is working, I'm hesitant to try another option. My Rock64 is considerably faster than the RPi 2 I had been using.
  Reply
#6
It can produce a bit of messy output on the command line, but you can use CRON to do this pretty much bullet proof!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Centos 8 Stream on Rock64 ayoungdukie 1 113 06-07-2021, 11:50 AM
Last Post: zer0sig
  Talos on ROCK64 cjyar 2 130 06-04-2021, 11:50 AM
Last Post: cjyar
  CentOS 7 for Rock64 pineadmin 3 2,664 05-30-2021, 08:20 AM
Last Post: ayoungdukie
  Rock64 CRUX-ARM (aarch64) mara 0 102 05-27-2021, 02:22 PM
Last Post: mara
  DietPi OS for ROCK64 MichaIng 15 3,874 05-24-2021, 07:46 AM
Last Post: MichaIng
  openwrt for the rock64 wilsonYan 14 5,939 05-23-2021, 07:53 AM
Last Post: stamasd
  RETRO-GAMING: UPDATED RELEASE OF RECALBOX FOR THE ROCK64 Mrfixit2001 32 24,318 05-22-2021, 07:01 AM
Last Post: fartadeadrian
  Armbian for Rock64 pineadmin 31 20,587 05-08-2021, 09:35 AM
Last Post: Wizzard
  slarm64 (unofficial slackware) Rock64 RK3328 (aarch64) mara 113 60,594 05-02-2021, 04:48 AM
Last Post: mara
  Setting a MAC on Rock64 U-Boot kiriakos 2 557 03-23-2021, 04:51 AM
Last Post: kiriakos

Forum Jump:


Users browsing this thread: 1 Guest(s)