bionic lxde 0.6.xx was not getting audio/sound
#1
I had no audio/sound with bionic-lxde images, I tried pre-release 0.6.55 so went to release 0.6.44 but had same problem. I tried google but not find answer, so google more to learn about ALSA and pulseaudio, seems problem with pulseaudio default sink, and I created following file and now can get audio.
If you get no audio, give this a try.

rock64@rock64:~$ cat ~/.config/pulse/default.pa
.include /etc/pulse/default.pa
set-default-sink alsa_output.platform-hdmi-sound.stereo-fallback

rock64@rock64:~$
  Reply
#2
Good advice. In the modern day, the majority of sound problems I've had under Linux (and not just on the Rock64) have been due to PulseAudio being used rather than ALSA. It'll be nice when pulse can finally die out. Smile
Community administrator and sysadmin for PINE64
(Translation: If something breaks on the website, forum, or chat network, I'm a good person to yell at about it)

  Reply
#3
(06-20-2018, 12:25 AM)jose_s_c Wrote: I had no audio/sound with bionic-lxde images, I tried pre-release 0.6.55 so went to release 0.6.44 but had same problem. I tried google but not find answer, so google more to learn about ALSA and pulseaudio, seems problem with pulseaudio default sink, and I created following file and now can get audio.
If you get no audio, give this a try.

rock64@rock64:~$ cat ~/.config/pulse/default.pa
.include /etc/pulse/default.pa
set-default-sink alsa_output.platform-hdmi-sound.stereo-fallback

rock64@rock64:~$

Thank you Jose! I wasn't getting audio in Ubuntu bionic lxde either through HDMI or the 3.5 jack. modifying /etc/pulse/default.pa to add that set-default-sink line at the end solved my problem!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  mainline kernel sound support Openwrt lucize 2 1,246 05-01-2020, 05:09 PM
Last Post: PakoSt
  armbian / bionic - hdmi to vga not functioning on newer5.4 kapqa 1 880 03-31-2020, 07:19 PM
Last Post: tllim
  Ayufan LXDE with Teamviewer or Dwservice? cenicero 0 628 03-14-2020, 06:39 AM
Last Post: cenicero
Bug mpph264enc output doesn't work on bionic rompelstompel 11 6,294 11-15-2019, 10:00 AM
Last Post: gounthar
  Release 0.9.14 Ubuntu Mate desktop, LXDE, OMV, Docker CE (container) Luke 1 2,043 09-19-2019, 07:00 AM
Last Post: Malmgren
  Owncloud installation on Ubuntu Bionic Count Omega 9 3,413 07-19-2019, 03:54 AM
Last Post: stuartiannaylor
  Sound on 3.5mm LXDE georgetina1 1 835 01-21-2019, 09:37 AM
Last Post: pas059
  Screen lock fail Bionic-lxde-rock64-0.7.8-1061-arm64 electrique 0 718 12-28-2018, 11:00 PM
Last Post: electrique
  HDMI sound on ayufan 0.7.x Trash_Can_Man 0 950 10-26-2018, 12:57 PM
Last Post: Trash_Can_Man
  Spontaneous Reboot during scp with Ubuntu bionic 0.7.8-1061 perniciouscaffeine 0 714 10-16-2018, 05:34 PM
Last Post: perniciouscaffeine

Forum Jump:


Users browsing this thread: 1 Guest(s)