Strange R64 behavior with a USB keyboard on 0.6.44
#11
(06-02-2018, 10:32 PM)pfeerick Wrote:
(06-02-2018, 07:43 PM)jl_678 Wrote: I can confirm that this solved the problem.  Thank you!  As an FYI, LOGLEVEL_DEFAULT was 4. Printk was  7 4 1 7.  Echoing 4 to it turned it into 4 4 1 7, and this solved the error message issue.

Great! Glad to hear it worked. Since you had a 7 4 1 7, and the LOGLEVEL_DEFAULT was correctly set at 4, you may still need to reapply it at boot, as something has changed it.

As a followup (should have included this before), this is what the grouping means. There's also a great write-up about what it all means here.

Code:
4       4       1       7
current    default    minimum    boot-time-default

Hi,

for a Linux-Newbie, can you give me a hint how to resolve the issue temporary and how to fix it for every reboot?

Thank you and best regards
David
  Reply
#12
(06-04-2018, 01:47 AM)Kunibert Wrote: for a Linux-Newbie, can you give me a hint how to resolve the issue temporary and how to fix it for every reboot?

sudo nano /etc/sysctl.conf

Remove the # at the beginning of the following line and then edit to suit

#kernel.printk = 3 4 1 3
  Reply
#13
(06-04-2018, 02:01 AM)evilbunny Wrote:
(06-04-2018, 01:47 AM)Kunibert Wrote: for a Linux-Newbie, can you give me a hint how to resolve the issue temporary and how to fix it for every reboot?

sudo nano /etc/sysctl.conf

Remove the # at the beginning of the following line and then edit to suit

#kernel.printk = 3 4 1 3

Thx, try it this evening!
  Reply
#14
(06-02-2018, 07:43 PM)jl_678 Wrote:
(06-01-2018, 10:38 PM)pfeerick Wrote:
(06-01-2018, 08:32 PM)jl_678 Wrote:
(06-01-2018, 03:14 PM)Rocklobster Wrote: Did you manage to resolve the spurious output from the keyboard presses.

Hi,

No, there has been no resolution.  I assume that it will need the next update to fix,


I can also reproduce this on the 0.6.44 bionic images with a wireless keyboard. I'd say this will go away once the dmc memory issues are resolved.

The referenced commit does indeed look to be the cause of the messages. From the looks of things you shouldn't be seeing those messages by default, as the default kernel log level for the images appears to be '4' (do a cat /proc/config.gz | gunzip | grep LOGLEVEL_DEFAULT to see what your kernel was compiled with) and this is a level 6 message (meaning a log level greater than 6 is needed to see it). Anyway, If you check /proc/sys/kernel/printk, and and the number is 7 or higher, do a echo 4 > /proc/sys/kernel/printk when logged in with su or some such method of getting around the fact you can't sudo when piping. That should stop you seeing the rockchip-sip messages. However, it won't stick, so will need to be reapplied after a reboot or power cycle, so you may want to set it in rc.local, etc.


Code:
[ 5063.080668] usb 3-1: new full-speed USB device number 2 using ohci-platform
[ 5063.269736] usb 3-1: New USB device found, idVendor=046d, idProduct=c52e
[ 5063.269769] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 5063.269791] usb 3-1: Product: USB Receiver
[ 5063.269811] usb 3-1: Manufacturer: Logitech
[ 5063.279854] input: Logitech USB Receiver as /devices/platform/ff5d0000.usb/usb3/3-1/3-1:1.0/0003:046D:C52E.0001/input/input1
[ 5063.332708] hid-generic 0003:046D:C52E.0001: input,hidraw0: USB HID v1.11 Keyboard [Logitech USB Receiver] on usb-ff5d0000.usb-1/input0
[ 5063.340356] input: Logitech USB Receiver as /devices/platform/ff5d0000.usb/usb3/3-1/3-1:1.1/0003:046D:C52E.0002/input/input2
[ 5063.392028] hid-generic 0003:046D:C52E.0002: input,hiddev0,hidraw1: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-ff5d0000.usb-1/input1
[ 5070.714003] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5070.764764] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5071.292766] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5071.412763] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5071.916767] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5072.020763] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5073.837079] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5074.076776] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5074.172778] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5074.236762] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5075.749101] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5075.932772] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5076.028758] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]
[ 5076.108755] rockchip-sip: function[82000008]: args:[2,0,2] => res:[0,2ed96880,0,0]

I can confirm that this solved the problem.  Thank you!  As an FYI, LOGLEVEL_DEFAULT was 4. Printk was  7 4 1 7.  Echoing 4 to it turned it into 4 4 1 7, and this solved the error message issue.

Thank you!

This also fixed it for me. Thank you
  Reply
#15
(06-07-2018, 12:13 PM)gene83 Wrote: This also fixed it for me. Thank you

No problem. You'll also want to do the bit evilbunny mentioned so it sticks on the next boot.

Quote:sudo nano /etc/sysctl.conf

Remove the # at the beginning of the following line and then edit to suit

#kernel.printk = 3 4 1 3


The below should make the change in one fell swoop as long as the parameter hasn't been un-commented.
Code:
sudo sed -i "s/#kernel.printk.*/kernel.printk 4 4 1 7/g" /etc/sysctl.conf
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Exclamation Strange graphical "glitches" grpeople 10 867 09-06-2018, 03:19 PM
Last Post: Luke
  monitor setting & keyboard issues gpine1 2 388 05-27-2018, 03:51 PM
Last Post: Luke
  keyboard/mouse freeze after 2-3 seconds on Debian Davo-CC 4 1,212 12-15-2017, 09:54 AM
Last Post: Davo-CC

Forum Jump:


Users browsing this thread: 1 Guest(s)