[Archived] Initial Linux release from ayufan (0.6.XX)
#41
GPIOs work
Homepage: https://ayufan.eu

Releases:
Rock/Pro 64/Pinebook Pro: LinuxChromium OS
So/Pine A64/Pinebook: LinuxAndroid 6.0Android 7.1

Buy me a Beer
#42
Hi All
Just loaded up
bionic-lxde-rockpro64-0.7.3-1040-arm64.img
Everything appears to be working except the mouse pointer does not show up.
If you right click you get popups
occasionally as you move the mouse around you see the menubar items flicker. If you judge it right you can bring up the individual menu icons.
Has anyone else seen this.
I have done the engineering mode and removed the resistor but that is to do with the pci power problem.
#43
(07-07-2018, 11:31 AM)mikeD Wrote: Hi All
Just loaded up
bionic-lxde-rockpro64-0.7.3-1040-arm64.img
Everything appears to be working except the mouse pointer does not show up.
If you right click you get popups
occasionally as you move the mouse around you see the menubar items flicker. If you judge it right you can bring up the individual menu icons.
Has anyone else seen this.
I have done the engineering mode and removed the resistor but that is to do with the pci power problem.

Yep, rendering 'planes' are wrong.
You can find me on IRC, Discord and Twitter


#44
:-) OK
#45
This is how you fix desktop, including mouse cursor:


Code:
sudo apt-get update
sudo apt-get install xserver-xorg-video-armsoc


Reboot and everything should work as expected.

[edit] to get sound working via HDMI:


Code:
`pacmd set-default-sink alsa_output.platform-hdmi-dp-sound.stereo-fallback


Enjoy 1080p youtube (in firefox) Wink
You can find me on IRC, Discord and Twitter


#46
thats great many thanks.
I have another problem now which is unexplained.
If I burn the image to sd the rockpro boots no problem.
As soon as I either shutdown or do a sudo reboot.
linux will no restart.
The only way to get the board to work is to reimage the SD which of course deletes all the updates etc.
Cannot seam to get round this one.
Any ideas on this one.
Kind Regards
MikeD
#47
I have just re-imaged the SD again.
Gone through the update and install as directed.
To see if it solved the problem I did the following.

ctrl-alt-F1 to get back to a login prompt.
then staopped the lxdm service with
/etc/init.d/lxdm stop.

Then restarted with
/etc/init.d/lxdm start.
I then get my desktop with working mouse all looked OK so that is a fix.
However, my board then crashed and I am back to not being able to reboot it. Without re-imaging the SD
Wondering if I have a faulty board.
regards.
MikeD
#48
(07-08-2018, 01:54 PM)mikeD Wrote: I have just re-imaged the SD again.
Gone through the update and install as directed.
To see if it solved the problem I did the following.

ctrl-alt-F1 to get back to a login prompt.
then staopped the lxdm service with
/etc/init.d/lxdm stop.

Then restarted with
/etc/init.d/lxdm start.
I then get my desktop with working mouse all looked OK so that is a fix.
However, my board then crashed and I am back to not being able to reboot it. Without re-imaging the SD
Wondering if I have a faulty board.
regards.
MikeD

Yep, fixed in newest image. Was a issue with resize_rootfs apparently. Now also mouse cursor works out of the box.
You can find me on IRC, Discord and Twitter


#49
0.7.4
looking really good now.
thanks
mikeD
#50
Thread closed and archived. New release from ayufan is 0.7.8. Discussion on 0.7.8 and future pre-releases here.
You can find me on IRC, Discord and Twitter




Possibly Related Threads...
Thread Author Replies Views Last Post
  Rockpro64 and stock arch linux TaborFife 6 562 01-15-2020, 05:17 PM
Last Post: dragop
  Problem with compiling ayufans linux kernel voegelit 4 162 01-14-2020, 07:38 AM
Last Post: patstew
  Ayufan 5.4.0 rc1 release - cannot boot Mentaluproar 2 207 01-05-2020, 02:39 PM
Last Post: mmiigg
  Release 0.9.14 Ubuntu Mate desktop, LXDE, OMV, Docker CE (container) Luke 1 484 12-10-2019, 01:30 PM
Last Post: Helium75
  Reboot problem on latest ayufan and 4.4 /dev/null 2 312 11-27-2019, 04:23 AM
Last Post: dukla2000
  poor HDD performance - ayufan mainline OMV Mentaluproar 0 79 11-11-2019, 10:26 PM
Last Post: Mentaluproar
  My PCIe disk controller works with Linux 5.3.6 guannais 1 167 10-30-2019, 07:11 PM
Last Post: guannais
  Linux Build Help: Stuck at "Starting kernel ..." ihamilton 2 416 10-10-2019, 12:51 PM
Last Post: ihamilton
Big Grin Feature Complete Debian Desktop Release Mrfixit2001 152 18,108 10-09-2019, 05:42 PM
Last Post: bcnaz
  Void Linux WIP losinggeneration 0 276 10-04-2019, 03:23 AM
Last Post: losinggeneration

Forum Jump:


Users browsing this thread: 1 Guest(s)