How to enable mate/startx on boot in jessie
#1
I have a 2gb pineA64+.  I used this image https://www.armbian.com/pine64/ and got a barebones termina.

Installed xorg and mate-desktop-environment through apt-get.  Now I am having a hardtime getting it to stick at booting.

I did add a line exec startx in ~/.profile. But it boots the pine64 and asks for credentials in terminal and only gets to the gui after credentials are entered.  I also couldnt fine /etc/default/grub toset it up there.

What am I missing here??
  Reply
#2
(05-22-2018, 11:55 PM)desai_amogh Wrote: I have a 2gb pineA64+.  I used this image https://www.armbian.com/pine64/ and got a barebones termina.

Installed xorg and mate-desktop-environment through apt-get.  Now I am having a hardtime getting it to stick at booting.

I did add a line exec startx in ~/.profile. But it boots the pine64 and asks for credentials in terminal and only gets to the gui after credentials are entered.  I also couldnt fine /etc/default/grub toset it up there.

What am I missing here??

You won't find a "/etc/default/grub" as grub isn't used with the pine64. 

With systemd, you'll need to do a "systemctl set-default graphical.target" in order to make the change from terminal to GUI boot... I don't know if you need to do anything more than that. You may want to have a look at the install-desktop script that ayufan uses on his distros and configure a few other bits whilst you're at it...

https://github.com/ayufan-pine64/linux-b...desktop.sh
  Reply
#3
I did try running the https://github.com/ayufan-pine64/linux-b...desktop.sh script

by # ./install_desktop.sh script mate

but it errored it couldn't find these packages:
ubuntu-mate-core
ubuntu-mate-desktop
ubuntu-mate-lightdm-theme
ubuntu-mate-wallpapers-xenial
lightdm

I can post the exact error in some time and also try systemctl set-default graphical.target
  Reply
#4
systemctl set-default graphical.target

Above command does set the default target to grapical target through a symlink. But has no effect on reboot. I have to manually run startx after logging in.
  Reply
#5
(05-26-2018, 01:14 PM)Pantera: Wrote: systemctl set-default graphical.target
worked for me under Ubuntu for Rock64. startx still did not work, upon reboot, I'm back into X11.
  Reply
#6
(11-26-2018, 11:51 AM)pantera Wrote:
(05-26-2018, 01:14 PM)Pantera: Wrote: systemctl set-default graphical.target
worked for me under Ubuntu for Rock64. startx still did not work, upon reboot, I'm back into X11.

Just to conclude this.  I finally gave up on Armbian as the latest version wouldn't boot with the micro usb and 3.2 Amp charger.  While Auyfan's Debian minimal booted without any issues.  I finally managed to resolve all the errors with repos and dependencies  with Mate desktop and get a stable Debian Stretch with Mate Desktop up and running.

For reference I have collated all the steps here, if anyone is stuck like me.
https://amoghdesai.com/technology/how-to...-pine64-a/
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Armbian enable toucscreen right-click burningkrome 0 268 12-03-2018, 03:05 PM
Last Post: burningkrome
  PineA64+ Armbian not boot, black screen and log klode 3 466 10-14-2018, 04:02 AM
Last Post: evilbunny
  How to make a GTK app start up fullscreen on boot? julu 2 1,246 02-28-2017, 05:57 PM
Last Post: julu

Forum Jump:


Users browsing this thread: 1 Guest(s)