Is PCIE x4 bootable for NVMe SSD under Linux
#41
Hi,

I managed to move the FS on a NVMe SSD and to start on it from a SD card using this link:
https://forum.frank-mankel.org/topic/208...vme-platte

But I don't get if there is a way to start directly from the NVMe without micro SD card.

Is there still no SPI option to boot from the NVMe?
#42
Quote:But I don't get if there is a way to start directly from the NVMe without micro SD card.

No, it's not possible. u-boot can't do it atm.

Easy way to boot from nvme is to use armbian nand-sata-install script Wink
Sorry for any mistakes. English is not my native language

1. RP64 v2.1 / PCIe SATA JMS585 Chipsatz / Booting from an 2,5 Zoll SSD on port 5/ 2 * 3,5 Zoll 4TB HDD (raid1) md0 / 2 * 2,5 Zoll 2TB HDD (raid1) md1 / using as NAS / Kernel 5.6.0-1137-ayufan-ge57f05e7bf8f

2. RP64 v2.1 / testing.....testing....testing

3. Quartz64 Model A with 4GB RAM

https://forum.frank-mankel.org/category/14/rockpro64
#43
(12-17-2018, 01:23 AM)Bullet64 Wrote:
Quote:Easy way to boot from nvme is to use armbian nand-sata-install script Wink

Thanks a lot for you reply!

Unfortunately I just gave a try, the script is running well, but when I shutdown the device once it's done and remove the eMMC, while starting, only the green power LED light up, neither the white LED from the board or the green on the NVMe PCIe card light up :-(

If I put back the eMMC, I am starting on it as usual, not on the NVMe.

Here are the steps I have followed:
I have selected the option 6:
   
I have selected a partition on the NVMe:
   
Then the copie was running:
   
And finally:
   

I removed the power cable; the eMMC;
I putted back the power cable and then... nothing excepted the power green LED and the RJ45 port LEDs (I have waited for severals minutes but still...).

I just saw this message during the process:
Quote:mount: wrong fs type, bad option, bad superblock on /dev/nvme0n1p3,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
There it is (after a reboot):
Quote:[    5.333132] zram0: detected capacity change from 0 to 52428800
[    5.536695] EXT4-fs (zram0): mounted filesystem without journal. Opts: discard
[    5.627696] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[    6.430433] random: nonblocking pool is initialized
[    6.969421] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    7.002656] nr_pdflush_threads exported in /proc is scheduled for removal
[    7.037717] NET: Registered protocol family 17
[    8.967918] rk_gmac-dwmac fe300000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[    9.631755] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[   17.635845] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2

I have no idea what I am doing wrong :-(
#44
You can't boot from nvme only. That script will use the nvme as root device. Bootdevice must be on sd-card, spi memory or on eMMC.
Sorry for any mistakes. English is not my native language

1. RP64 v2.1 / PCIe SATA JMS585 Chipsatz / Booting from an 2,5 Zoll SSD on port 5/ 2 * 3,5 Zoll 4TB HDD (raid1) md0 / 2 * 2,5 Zoll 2TB HDD (raid1) md1 / using as NAS / Kernel 5.6.0-1137-ayufan-ge57f05e7bf8f

2. RP64 v2.1 / testing.....testing....testing

3. Quartz64 Model A with 4GB RAM

https://forum.frank-mankel.org/category/14/rockpro64
#45
(12-21-2018, 03:31 PM)Bullet64 Wrote: You can't boot from nvme only. That script will use the nvme as root device. Bootdevice must be on sd-card, spi memory or on eMMC.

Sorry I get it wrong but isn't it the goal of the nand-sata-install script to set the boot on the SPI and the rootfs on the NVMe?

[Image: attachment.php?aid=1282]

(12-21-2018, 03:31 PM)Bullet64 Wrote: You can't boot from nvme only. That script will use the nvme as root device. Bootdevice must be on sd-card, spi memory or on eMMC.

I guess I need to flash the SPI before to run this script, I will give another try (last time the blinking LED never stoped Undecided).
#46
When you flash spi and the white led begins to blink its finished.
Sorry for any mistakes. English is not my native language

1. RP64 v2.1 / PCIe SATA JMS585 Chipsatz / Booting from an 2,5 Zoll SSD on port 5/ 2 * 3,5 Zoll 4TB HDD (raid1) md0 / 2 * 2,5 Zoll 2TB HDD (raid1) md1 / using as NAS / Kernel 5.6.0-1137-ayufan-ge57f05e7bf8f

2. RP64 v2.1 / testing.....testing....testing

3. Quartz64 Model A with 4GB RAM

https://forum.frank-mankel.org/category/14/rockpro64
#47
Thanks!

I don't manage to boot directly on the SPI + NVMe SSD though, even with the nand-sata-install script.

Here are my logs: https://drive.google.com/drive/folders/1...sp=sharing

It sounds like SPI + NVMe SSD boot is not working on the RP64 :-(
#48
For what i know, actual u-boot can only boot from USB and PXE.

I am using NVMe as root device with sd-card (boot device).
Sorry for any mistakes. English is not my native language

1. RP64 v2.1 / PCIe SATA JMS585 Chipsatz / Booting from an 2,5 Zoll SSD on port 5/ 2 * 3,5 Zoll 4TB HDD (raid1) md0 / 2 * 2,5 Zoll 2TB HDD (raid1) md1 / using as NAS / Kernel 5.6.0-1137-ayufan-ge57f05e7bf8f

2. RP64 v2.1 / testing.....testing....testing

3. Quartz64 Model A with 4GB RAM

https://forum.frank-mankel.org/category/14/rockpro64
#49
Thanks for sharing your experience, I have spend too much time on this, I guess I will do like you, and buy a SD card just to boot from it.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Other boot options than Sdcard for linux 5.x kernel? MisterA 2 168 07-14-2021, 02:37 PM
Last Post: TRS-80
Brick Maintained Linux booting from eMMC ootoovak 5 368 07-06-2021, 02:28 PM
Last Post: TRS-80
  WiFi not working with PCIe SSD installed mikeD 0 213 05-25-2021, 07:48 AM
Last Post: mikeD
  Power supply underpowered for Rockpro64, deficient PCIe SATA card, or something else? daffy 8 774 05-20-2021, 10:04 PM
Last Post: t4_4t
  Booting from NVME ilovegentoo 11 4,225 05-10-2021, 02:06 PM
Last Post: rrowles2000
  Booting Linux/Debian from the eMMC linuxha 4 867 03-02-2021, 07:01 PM
Last Post: linuxha
  Xen EFI with Alpine Linux dom0 sir.lami 0 981 08-26-2020, 12:25 PM
Last Post: sir.lami
  Linux Host - QEMU Android Guest? rik-shaw 0 860 07-09-2020, 08:02 PM
Last Post: rik-shaw
  RETRO GAMING BATOCERA LINUX + ROSHAMBO CASE - Tutoriel Fr TheMiniCakeTV 0 1,714 07-02-2020, 12:45 PM
Last Post: TheMiniCakeTV
  Arch Linux on RockPro64 mmatyas 30 24,339 05-30-2020, 12:08 PM
Last Post: mmatyas

Forum Jump:


Users browsing this thread: 1 Guest(s)