Is PCIE x4 bootable for NVMe SSD under Linux
#41
Hi,

I managed to move the FS on a NVMe SSD and to start on it from a SD card using this link:
https://forum.frank-mankel.org/topic/208...vme-platte

But I don't get if there is a way to start directly from the NVMe without micro SD card.

Is there still no SPI option to boot from the NVMe?
  Reply
#42
Quote:But I don't get if there is a way to start directly from the NVMe without micro SD card.

No, it's not possible. u-boot can't do it atm.

Easy way to boot from nvme is to use armbian nand-sata-install script Wink
Sorry for any mistakes. English is not my native language

1. RP64 v2.0 / PCIe NVMe as root / sd-card as boot / 2,5 Zoll HDD 1TB (USB3) using as Webserver .... (Kernel 4.4.167-1140-rockchip-ayufan-g6f266fb5d677)
2. RP64 v2.1 / PCIe SATA Marvell 88SE9230 Chipsatz / sd-card / 2 * 2,5 Zoll 2TB HDD (raid1) / using as NAS / Kernel 5.0.0-1101-ayufan-g41eeb7cd789e
3. RP64 v2.1 / testing.....testing....testing

https://forum.frank-mankel.org/category/14/rockpro64



  Reply
#43
(12-17-2018, 01:23 AM)Bullet64 Wrote:
Quote:Easy way to boot from nvme is to use armbian nand-sata-install script Wink

Thanks a lot for you reply!

Unfortunately I just gave a try, the script is running well, but when I shutdown the device once it's done and remove the eMMC, while starting, only the green power LED light up, neither the white LED from the board or the green on the NVMe PCIe card light up :-(

If I put back the eMMC, I am starting on it as usual, not on the NVMe.

Here are the steps I have followed:
I have selected the option 6:
   
I have selected a partition on the NVMe:
   
Then the copie was running:
   
And finally:
   

I removed the power cable; the eMMC;
I putted back the power cable and then... nothing excepted the power green LED and the RJ45 port LEDs (I have waited for severals minutes but still...).

I just saw this message during the process:
Quote:mount: wrong fs type, bad option, bad superblock on /dev/nvme0n1p3,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.
There it is (after a reboot):
Quote:[    5.333132] zram0: detected capacity change from 0 to 52428800
[    5.536695] EXT4-fs (zram0): mounted filesystem without journal. Opts: discard
[    5.627696] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[    6.430433] random: nonblocking pool is initialized
[    6.969421] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    7.002656] nr_pdflush_threads exported in /proc is scheduled for removal
[    7.037717] NET: Registered protocol family 17
[    8.967918] rk_gmac-dwmac fe300000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[    9.631755] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2
[   17.635845] cdn-dp fec00000.dp: Direct firmware load for rockchip/dptx.bin failed with error -2

I have no idea what I am doing wrong :-(
  Reply
#44
You can't boot from nvme only. That script will use the nvme as root device. Bootdevice must be on sd-card, spi memory or on eMMC.
Sorry for any mistakes. English is not my native language

1. RP64 v2.0 / PCIe NVMe as root / sd-card as boot / 2,5 Zoll HDD 1TB (USB3) using as Webserver .... (Kernel 4.4.167-1140-rockchip-ayufan-g6f266fb5d677)
2. RP64 v2.1 / PCIe SATA Marvell 88SE9230 Chipsatz / sd-card / 2 * 2,5 Zoll 2TB HDD (raid1) / using as NAS / Kernel 5.0.0-1101-ayufan-g41eeb7cd789e
3. RP64 v2.1 / testing.....testing....testing

https://forum.frank-mankel.org/category/14/rockpro64



  Reply
#45
(12-21-2018, 03:31 PM)Bullet64 Wrote: You can't boot from nvme only. That script will use the nvme as root device. Bootdevice must be on sd-card, spi memory or on eMMC.

Sorry I get it wrong but isn't it the goal of the nand-sata-install script to set the boot on the SPI and the rootfs on the NVMe?

[Image: attachment.php?aid=1282]

(12-21-2018, 03:31 PM)Bullet64 Wrote: You can't boot from nvme only. That script will use the nvme as root device. Bootdevice must be on sd-card, spi memory or on eMMC.

I guess I need to flash the SPI before to run this script, I will give another try (last time the blinking LED never stoped Undecided).
  Reply
#46
When you flash spi and the white led begins to blink its finished.
Sorry for any mistakes. English is not my native language

1. RP64 v2.0 / PCIe NVMe as root / sd-card as boot / 2,5 Zoll HDD 1TB (USB3) using as Webserver .... (Kernel 4.4.167-1140-rockchip-ayufan-g6f266fb5d677)
2. RP64 v2.1 / PCIe SATA Marvell 88SE9230 Chipsatz / sd-card / 2 * 2,5 Zoll 2TB HDD (raid1) / using as NAS / Kernel 5.0.0-1101-ayufan-g41eeb7cd789e
3. RP64 v2.1 / testing.....testing....testing

https://forum.frank-mankel.org/category/14/rockpro64



  Reply
#47
Thanks!

I don't manage to boot directly on the SPI + NVMe SSD though, even with the nand-sata-install script.

Here are my logs: https://drive.google.com/drive/folders/1...sp=sharing

It sounds like SPI + NVMe SSD boot is not working on the RP64 :-(
  Reply
#48
For what i know, actual u-boot can only boot from USB and PXE.

I am using NVMe as root device with sd-card (boot device).
Sorry for any mistakes. English is not my native language

1. RP64 v2.0 / PCIe NVMe as root / sd-card as boot / 2,5 Zoll HDD 1TB (USB3) using as Webserver .... (Kernel 4.4.167-1140-rockchip-ayufan-g6f266fb5d677)
2. RP64 v2.1 / PCIe SATA Marvell 88SE9230 Chipsatz / sd-card / 2 * 2,5 Zoll 2TB HDD (raid1) / using as NAS / Kernel 5.0.0-1101-ayufan-g41eeb7cd789e
3. RP64 v2.1 / testing.....testing....testing

https://forum.frank-mankel.org/category/14/rockpro64



  Reply
#49
Thanks for sharing your experience, I have spend too much time on this, I guess I will do like you, and buy a SD card just to boot from it.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Linux distro that will work with Kodi? SBCraok 7 122 9 hours ago
Last Post: snoopy_ca
  Arch Linux on RockPro64 mmatyas 25 7,902 09-10-2019, 01:58 PM
Last Post: mmatyas
  PCIe ath10k on RockPro64 dasfranky 5 146 08-31-2019, 11:36 AM
Last Post: tuxd3v
  PCIe Sata II adapter and ssd TRIM bavay 0 67 08-16-2019, 07:49 AM
Last Post: bavay
  u-boot for Arch Linux Arm prw 3 166 07-20-2019, 12:38 PM
Last Post: stuartiannaylor
  Major issues with 0.8.3 bionic mate and PCIe TheSupercomputer 2 182 07-03-2019, 03:38 PM
Last Post: ayufan
Information Update 22.02.2019 Feature-complete Debian build - SDIO WiFi/BT / PCIe / 3D / 2D Luke 99 12,642 06-07-2019, 04:34 AM
Last Post: beard5849
  NEMS Linux for RockPro64 pineadmin 0 357 05-09-2019, 05:51 PM
Last Post: pineadmin
  Image for ZFS on PCIe SATA drives with OpenVPN and WiFi caillou 0 184 02-26-2019, 05:14 PM
Last Post: caillou
Star 0.7.9 Linux release from ayufan Luke 48 16,507 02-25-2019, 02:55 PM
Last Post: Luke

Forum Jump:


Users browsing this thread: 1 Guest(s)