Laptop as a bridge for Rock64's internet connection
Hi all!

I've just got a Rock64, burned the official image (minimal Debian), connected to the monitor and the keyboard, launched it and... realized I need an internet connection. For this I can use a laptop (Debian again) connected via WiFi, which has one Ethernet port free. I've got some general descriptions about bridging and routing in Linux having WiFi but nothing worked so far. Say, I have a difficulty to connect to the Ethernet port of the WiFi access point. I believe it's quite a common case. Could someone, please, help me and provide a real case example solving such problem?
I'll specify the details.

There is a WiFi network with the access point at and the laptop at

Assume the laptop has to act as a router. Following the aforementioned instructions I've created network the the Ethernet interface of the laptop has ip All the commands:

sudo ifconfig eth0 up
sudo ifconfig eth0
echo 1 | sudo tee /proc/sys/net/ipv4/ip_forward
sudo iptables -t nat -A POSTROUTING -o wlan0 -s -j MASQUERADE

Locally, now you can ping both laptop's ips: and The current config is:
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
   link/ether ETH0-MAC brd ff:ff:ff:ff:ff:ff
   inet brd scope global eth0
      valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
   link/ether WLAN0-MAC brd ff:ff:ff:ff:ff:ff
   inet brd scope global wlan0
      valid_lft forever preferred_lft forever

Then I've set the rock64's Ethernet interface using `nmtui`: ip is, gateway is From now I can ping local ip but not the gateway. Checking the laptop's arp table I can't see the MAC of the rock64. Hence, I guess, no packets even sent via the cable.

So, the question is... what to do next?
Made a typo at the previous post. The correction is:

Quote:There is a WiFi network with the access point at and the laptop at
I've solved this issue using the built-in Network Manager of my distro. There I've selected "Shared to others computers" for the wired connection. I've canceled all the changes to all configuration files I made before. That's it, everything works automatically from both sides, the laptop and the Rock64.

However, the manual setup is still a miracle for me.

Possibly Related Threads...
Thread Author Replies Views Last Post
  Rock64 with Debian netinst usb Bloris 6 344 12-03-2019, 12:37 PM
Last Post: madalin
  The differences between Rock64 and RockPro64 phamoanh 1 292 06-12-2019, 10:44 PM
Last Post: evilbunny
  Custom Kernel for ROCK64 mayst 2 795 01-07-2019, 08:04 AM
Last Post: mayst
Bug Rock64 Login lpninja 1 460 10-04-2018, 12:02 AM
Last Post: tllim
  Rock64 suitable for headless TVHeadend install? elsmandino 3 993 06-26-2018, 11:37 AM
Last Post: Luke
  Will the Rock64 work as a mobile data storage device? Kennetht 1 306 03-29-2018, 10:07 AM
Last Post: xalius
  Rock64 OS eMMC boot ProfessionalDreamer 2 1,459 02-20-2018, 08:44 PM
Last Post: ProfessionalDreamer
  opencv on rock64 bendiro 4 1,314 02-07-2018, 05:08 AM
Last Post: xalius
  Kodi on Rock64 board cenguix 2 3,941 02-02-2018, 03:05 PM
Last Post: stuartiannaylor
  Rock64 USB 11b2p508 2 1,046 01-28-2018, 02:43 PM
Last Post: belfastraven

Forum Jump:

Users browsing this thread: 1 Guest(s)