HW Acceleration Working
#31
well we're in june and still no news...
  Reply
#32
news?
  Reply
#33
(06-06-2016, 10:16 AM)Metalazzo Wrote: well we're in june and still no news...

There is slight delay on the 64bit Mali binary driver release due to tuning, Allwinner informed me yesterday that they will release on June 15. I keep my finger cross.
  Reply
#34
well let's all keep our fingers cross Wink
  Reply
#35
(06-06-2016, 06:31 PM)tllim Wrote:
(06-06-2016, 10:16 AM)Metalazzo Wrote: well we're in june and still no news...

There is slight delay on the 64bit Mali binary driver release due to tuning, Allwinner informed me yesterday that they will release on June 15. I keep my finger cross.
Very exciting news. At least we have a projected date.
  Reply
#36
Let us count down days Smile. Hope they will deliver this time.
  Reply
#37
(06-06-2016, 06:31 PM)tllim Wrote:
(06-06-2016, 10:16 AM)Metalazzo Wrote: well we're in june and still no news...

There is slight delay on the 64bit Mali binary driver release due to tuning, Allwinner informed me yesterday that they will release on June 15. I keep my finger cross.

Two days left. My eyes are still crossed.
I sincerely hope the Mali driver will work and is on schedule...
  Reply
#38
Lol.. keep dreaming. We have a lot of issues on Android builds and no fixes.. no replies, no nothing from Pine.
Do you really expect them to deliver the mali driver?

It's everything up to Allwinner team and by the looks of it, they could care less. My hope for this board to be usable died some time ago, there's no interest from the Pine team besides shipping them so people can use them as paperweights.

You see no effort anywhere to pass from alpha to beta, we get long-time cycle releases with no apparent fixes for what matters and poor performance.

At least I know I'll never buy a Allwinner product ever again.
  Reply
#39
we hope... A lot of "arm board" has this problem about post-sale support...
  Reply
#40
(06-13-2016, 12:50 PM)CaptainZalo Wrote:
(06-06-2016, 06:31 PM)tllim Wrote:
(06-06-2016, 10:16 AM)Metalazzo Wrote: well we're in june and still no news...

There is slight delay on the 64bit Mali binary driver release due to tuning, Allwinner informed me yesterday that they will release on June 15. I keep my finger cross.

Two days left. My eyes are still crossed.
I sincerely hope the Mali driver will work and is on schedule...

Allwinner engineer experience xorg stack pointer issue but the issue happens before reaching video driver. I am currently bring in Lenny and also consult with longsleep and hopefully this stack point issue resolved soon. Following is my translation and original Chinese message, if anybody have idea to assist, always welcome.

Here is Allwinner response:

I means when using gcc complie xorg, the funwind-tables doesn't enable and this cause the xorg_backtrace()->stack return back value 1, then only can trace up to stack point first layer and appear /usr/bin/X (xorg_backtrace+0x5c) [0x55909ca75c]. If need to trace more layer of stack pointer, enable funwind-tbles is needed. Reload backtrace() stack still facing similar issue and currently only able to figure out using this method to check multi layer stack pointer problem.
 
https://wiki.debian.org/XStrikeForce/Xse..._I_need.3F doesn't resolve open multi layer stack pointer relationship problem.

From the 0x7f7875600c address reference to proc/pidof(X)/maps. I don't think we are yet in video library, and this is why need to trace down next stack pointer relationship.

We don't have experience on compiling xorg, and may facing more issue and longer the development cycle.

Below is the original message in Chinese:

我们的意思是xorg在编译的时候gcc没有打开 -funwind-tables选项,导致在xorg_backtrace()->backtrace()函数返回值为1,只能追踪到函数栈的第一层,只出现/usr/bin/X (xorg_backtrace+0x5c) [0x55909ca75c],要想追踪多层的函数栈必须打开 -funwind-tables,通过重载backtrace()函数也是碰到相似的问题,暂时也是想到这个办法打开多层函数栈关系问题
https://wiki.debian.org/XStrikeForce/Xse..._I_need.3F 并没有解决backtrace打印多层函数栈的问题。
0x7f7875600c这个地址看(proc/pidof(X)/maps),其并未在我们video库中,所以要追一下函数调用关系。
由于我们没有编译xorg的经验,遇到很多问题,周期会很长。
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Brand New LCD not working adamjedgar 3 1,513 03-11-2017, 12:20 AM
Last Post: simplexdan
  Pine64+: 3 working, 1 shows nothing on tv zumtra 1 1,201 07-30-2016, 05:47 PM
Last Post: tllim

Forum Jump:


Users browsing this thread: 4 Guest(s)