eMMC errors
#1
I am trying to setup Openmediavault onto my newly purchased Rock64.  I bought the USB eMMC adaptor to ease installations and I can write the image with no errors using the Pine64 Etcher application, but when I insert it and turn on my Rock64, I get the errors in the attached image (Sorry, I don't have any other way to capture it other than taking a picture with my phone.)

I have tried the following:

  • Removing and re-inserting the eMMC, making sure the contacts are clean
  • wiping it and reinstalling
  • On my Windows PC, 'cleaning' the disk completely and checking it for errors using the USB adaptor
What else should I be doing?

N00b question alert: The jumper on the board is only to be used IF you want to boot from SD Card, correct? You leave it open if you want to boot from eMMC?

Thanks in advance.

Daniel

   
"Don't mention the war!" - Basil Fawlty
  Reply
#2
I have just tried using the main Etcher program - no difference.

I also tried writing the eMMC on a USB2 port instead of USB3, just to eliminate that.

Could it be I have a faulty eMMC module?
"Don't mention the war!" - Basil Fawlty
  Reply
#3
(03-02-2018, 02:36 PM)MrFawlty Wrote: I am trying to setup Openmediavault onto my newly purchased Rock64.  I bought the USB eMMC adaptor to ease installations and I can write the image with no errors using the Pine64 Etcher application, but when I insert it and turn on my Rock64, I get the errors in the attached image (Sorry, I don't have any other way to capture it other than taking a picture with my phone.)

I have tried the following:

  • Removing and re-inserting the eMMC, making sure the contacts are clean
  • wiping it and reinstalling
  • On my Windows PC, 'cleaning' the disk completely and checking it for errors using the USB adaptor
What else should I be doing?

N00b question alert: The jumper on the board is only to be used IF you want to boot from SD Card, correct? You leave it open if you want to boot from eMMC?

Thanks in advance.

Daniel

Which image are you using, some 0.6.x versions had broken emmc support.

Yes, the jumped disables emmc.
  Reply
#4
I just used the installer, so version 0.5.15-136
"Don't mention the war!" - Basil Fawlty
  Reply
#5
(03-03-2018, 08:11 PM)MrFawlty Wrote: I just used the installer, so version 0.5.15-136

Are you able to mount and inspect the emmc card from a computer, either running linux or a live boot CD?
  Reply
#6
Yes. I get 6 "You need to Format this disc" pop-ups when I insert on my Windows PC (I don't have a Linux PC running).  I have attached what Disk Management reports. I can browse through to one of the partitions.  All the others are reported as 'Unformatted'

   

Well, this is weird. I pressed the reset button to see if that worked - no changes on the first 2 attempts but on the 3rd - it works! It booted into Openmediavault and I can set it up.

I'll report back once i try turning it off and on a few times.
"Don't mention the war!" - Basil Fawlty
  Reply
#7
I'm getting this problem too, both 32 and 64 bit builds.  If you boot from SD, does your networking work? I'm wondering if we have the same problem.
  Reply
#8
I HAVE A SOLUTION!

Had this exact problem and was beating my head against the wall for 3 days trying to get it to go. Eventually, I stumbled on this thread. https://forum.pine64.org/showthread.php?tid=5622

Turns out there's a bug with eMMC in the "Stable" version of openmediavault linked from the wiki page. In order to use eMMC you need to be on the latest (pre-release) version which is linked here https://github.com/ayufan-rock64/linux-build/releases

One thing I noticed is they don't have an SD to eMMC version so to use it you'll need to have an eMMC adapter to connect to your PC.

Could someone from PINE64 please update the wiki!
  Reply
#9
(04-01-2018, 08:45 PM)da_guy2 Wrote: I HAVE A SOLUTION!

Had this exact problem and was beating my head against the wall for 3 days trying to get it to go. Eventually, I stumbled on this thread. https://forum.pine64.org/showthread.php?tid=5622

Turns out there's a bug with eMMC in the "Stable" version of openmediavault linked from the wiki page. In order to use eMMC you need to be on the latest (pre-release) version which is linked here https://github.com/ayufan-rock64/linux-build/releases

One thing I noticed is they don't have an SD to eMMC version so to use it you'll need to have an eMMC adapter to connect to your PC.

Could someone from PINE64 please update the wiki!

We will put a note on the Wiki page. Once the next ayufan next "Stable" build released, we will revise back to use "Stable" release.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  USB -> eMMC is now available. Luke 13 5,192 03-20-2019, 10:11 AM
Last Post: SirRyanTheGeek
Brick How to Write an Image to the eMMC Module Tutorial MarkHaysHarris777 55 22,474 02-06-2019, 04:02 PM
Last Post: tllim
  flash image to sd/emmc through ethernet LMM 0 163 02-04-2019, 07:36 AM
Last Post: LMM
  Receiving errors about eMMC (?) acasta 10 1,475 08-20-2018, 04:41 PM
Last Post: asavah
  OMV - graphical distortion and SIP errors Mentaluproar 4 302 06-27-2018, 04:06 PM
Last Post: Mentaluproar
  Card emmc Auggoncalves 2 295 06-25-2018, 03:20 AM
Last Post: Auggoncalves
  Debian to eMMC? Hoerli 7 1,008 05-06-2018, 05:41 PM
Last Post: pfeerick
  [SOLVED] stuck at emmc dr_dre 10 1,383 04-29-2018, 05:10 PM
Last Post: pfeerick
  eMMC angelscream09 6 739 03-17-2018, 02:08 PM
Last Post: KeithJohnAlger
  USB -> eMMC adapter coming soon Luke 7 927 02-09-2018, 04:46 AM
Last Post: xalius

Forum Jump:


Users browsing this thread: 1 Guest(s)