Reboot Issue with ROCK64 Linux version 4.4.77-rockchip-ayufan-141
#1
I have a ROCK64 4GB setup and when I reboot I have a lot of trouble getting the unit stable.

Here are the errors that display on the screen:

core: dev_pm_opp_get_voltage: Invalid parameters
mali-utgard ff300000.gpu: Failed to get voltage for frequency 163840000: -34
devfreq ff300000.gpu: Couldn't update frequency transition information.

And then it goes into kernel panic mode.  I have to completely power down the unit,
remove the hdmi, ethernet, and keyboard cable, wait for 30 seconds and then it will boot.

I have tried a different power supply and plugging it in to a different power source.

I have 3 other similar ROCK64's working fine.
  Reply
#2
same here
  Reply
#3
(02-13-2018, 02:40 AM)djniio Wrote: same here

True. My restarting issue came up when I swapped over to an SSD through the USB. I have to physically power it on to get it to power up. Although I found my Rock64 very stable as long as I don't reboot it. I'm going on 23 days as a ProdWeb server. 

Trust me when I say, it would be nice for the occasional reboot, but it's 10 miles down the road churning along.

─➤  uptime

 09:49:19 up 22 days, 20:22
  Reply
#4
(02-22-2018, 09:54 AM)Rustproof Wrote:
(02-13-2018, 02:40 AM)djniio Wrote: same here

True. My restarting issue came up when I swapped over to an SSD through the USB. I have to physically power it on to get it to power up. Although I found my Rock64 very stable as long as I don't reboot it. I'm going on 23 days as a ProdWeb server. 

Trust me when I say, it would be nice for the occasional reboot, but it's 10 miles down the road churning along.

─➤  uptime

 09:49:19 up 22 days, 20:22

Are you running 0.6.1-141?

If so downgrade to the 0.5.15-136 stable build, although 0.6.15-175 seems to be fine, which I've been running for a while now.
  Reply
#5
I'm using: 4.4.77-rockchip-ayufan-136
  Reply
#6
(02-22-2018, 10:04 PM)Rustproof Wrote: I'm using: 4.4.77-rockchip-ayufan-136

The version in the thread title was confusing.

You would need to plug a serial device in to debug things further.
  Reply
#7
Thanks! That's the plan on my next build. I want to run it without restarting as long as I can.

─➤ uptime
12:12:33 up 23 days, 22:46
  Reply
#8
Hi all,

I'm getting basically te same error. My rock64 freezes roughly about every nights. My syslog isn't much weird, but my kernlog displays those tree lines before crash :
Code:
Jun 18 20:04:32 rock64 kernel: [ 1724.410661] core: dev_pm_opp_get_voltage: Invalid parameters
Jun 18 20:04:32 rock64 kernel: [ 1724.411610] mali-utgard ff300000.gpu: Failed to get voltage for frequency 163840000: -34
Jun 18 20:04:32 rock64 kernel: [ 1724.412124] devfreq ff300000.gpu: Couldn't update frequency transition information.

I am on 4.4.77-rockchip-ayufan-136. I have an USB3 hard drive connected (I have read threads where USB3 maybe part of the problem). I'm a bit stuck here, what can I do to investigate further ?
  Reply
#9
(06-23-2018, 03:54 AM)NablaMetal Wrote: Hi all,

I'm getting basically te same error. My rock64 freezes roughly about every nights. My syslog isn't much weird, but my kernlog displays those tree lines before crash :
Code:
Jun 18 20:04:32 rock64 kernel: [ 1724.410661] core: dev_pm_opp_get_voltage: Invalid parameters
Jun 18 20:04:32 rock64 kernel: [ 1724.411610] mali-utgard ff300000.gpu: Failed to get voltage for frequency 163840000: -34
Jun 18 20:04:32 rock64 kernel: [ 1724.412124] devfreq ff300000.gpu: Couldn't update frequency transition information.

I am on 4.4.77-rockchip-ayufan-136. I have an USB3 hard drive connected (I have read threads where USB3 maybe part of the problem). I'm a bit stuck here, what can I do to investigate further ?

136 is a very old build now, and it's very likely that your issue has been fixed in an updated build since then. As of right now, the latest release build is 239 or if you want to be on the bleeding edge there is 270, but the changes between the two only really pertain to the RockPro64 board.

For anyone reading this in the future -- what I am saying right now is almost definitely out of date! Check the Releases 
page!
Community administrator and sysadmin for PINE64
(Translation: If something breaks on the website, forum, or chat network, I'm a good person to yell at about it)

  Reply
#10
Hi fire219,

Yep I figured this out too. Because I used Pine64 Windows software installer for flashing my sdcard, I thought it would grab the latest kernel release (I flashed it a month ago).
I saw that 239 was latest stable on Github and installed it. After reboot, no problem so far. I guess i'll wait and see... I will come back here to report in any case.

Thank you
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Selling Rock64's dugalbug 6 288 10-19-2019, 12:12 PM
Last Post: dugalbug
Exclamation Rock64 v2 freeze help! JuanDTM 5 208 10-16-2019, 06:37 PM
Last Post: Rocklobster
  Rock64 for video surveillance martinschm 6 426 09-19-2019, 01:56 AM
Last Post: Jozek
  ROCK64 not booting TheGiolly 10 440 09-09-2019, 06:57 AM
Last Post: Rocklobster
  Rock64 v3 - POE P1V 3 547 08-18-2019, 05:51 AM
Last Post: mcerveny
  Rock64 board seems defective, how to confirm? Josk 1 172 08-15-2019, 08:24 PM
Last Post: tllim
  Change Mac address on Linux fahr 3 470 08-07-2019, 03:31 AM
Last Post: AlexS
  Purchase Rock64 V3? richardk 6 674 08-03-2019, 12:56 PM
Last Post: mcerveny
  Rock64 running OMV, how to setup RTL8812AU WiFi? electrosam 2 201 07-16-2019, 04:03 PM
Last Post: ayufan
  Rock64 random freezes BTB 3 306 07-01-2019, 10:17 AM
Last Post: Luke

Forum Jump:


Users browsing this thread: 1 Guest(s)