usermod and processes
I am trying to change the username from rock64 to something more personal. 

I have searched this forum and ubuntu's and in general. I am also running Xenial-Mate latest stable from the wiki. Fresh install to microSD.

If it helps at all, I've created a temp user called temp. 

For reference, I've mainly followed this write up done on

So I have made sure to not be logged into rock64 user when running the
sudo usermod -l rock64 <newuser>

But I get this message
"user rock64 is currently used by process 2245" even after having ran the command
sudo kill 2245

I have also been running these commands through the CLI when you hit ctl-alt-f1 at loggin.
i think you have to use root account to change rock64 name.
(01-05-2018, 12:29 PM)dkryder Wrote: i think you have to use root account to change rock64 name.

Thank you. I have been able to change the username and password. Verified by reboot and CLI login before GUI Desktop Environemtn login.

I believe I have associated the home directory. I was having issue then with logging into the desktop view the GUI login screen. No combination of old/new username/password worked for login.

Specifically, I followed these steps from ask ubuntu, barring step 9.

  1. At the start screen press Ctrl+Alt+F1.

  2. Log in using your username and password.

  3. Set a password for the "root" account.
    sudo passwd root
  4. Log out.
  5. Log in using the "root" account and the password you have previously set.
  6. Change the username and the home folder to the new name that you want.
    usermod -l <newname> -d /home/<newname> -m <oldname>
  7. Change the group name to the new name that you want.
    groupmod -n <newgroup> <oldgroup>
  8. Lock the "root" account.
    passwd -l root
  9. If you were using ecryptfs (encrypted home directory). Mount your encrypted directory using 
    ecryptfs-recover-private and edit <mountpoint>/.ecryptfs/Private.mntto reflect your new home directory.
  10. Log out.
  11. Press Ctrl+Alt+F7.
Tried to simply add a new user. Can add user, and CLI login, but no GUI desktop login.

Fresh install xenial-mate-rock64-0.5.15-136-arm64.img.xz on SD card via Etcher on ubuntu 16.04

Boot to GUI login -> ctl-alt-f1 to terminal

Change sudo password:
Login as root -
sudo su
change password
set it
adduser <nickname>
set password
set Full name - <Wholefirstname>
leave room/email/phone blank
GUI Login shows users: Rock64 and <Wholefirstname>
select <Wholefirstname>
use <nickname> password
reports: Incorrect password, please try again
And no combination of old and new user or root passwords work. Is there a step I am missing to simply add a user? Eventually I want Rock64 user replaced with my name, but keep the hostname as Rock64. I have tried changing the Rock64 user name as in previous posts, and now tried to add a user, and all with the same outcome (when commands and permissions done correctly) - Incorrect password, please try again

Forum Jump:

Users browsing this thread: 1 Guest(s)