Pinebook wont turn on. Keeps blinking power light
#11
Do you have a Pinebook or a Pinebook Pro? Those images are not interchangeable...
Come have a chat in the Pine A64 IRC channel >>
  Reply
#12
How did you flash the card? I've experienced an issue where some images that are compressed are requiring the image to be decompressed to boot. Even though Etcher and another app I use, ApplePiBaker, have great support for compressed images.
  Reply
#13
Finaly reinstalled the 64 gig emmc , pressed start button for 10 seconds , it restarted ok , had to order an usb to emmc adapter so i can install a new on on the 128 gig emmc chip
  Reply
#14
(12-18-2017, 01:50 AM)tllim Wrote:
(12-11-2017, 08:54 PM)Taelsdoll Wrote:
(12-03-2017, 11:02 AM)tllim Wrote:
(12-02-2017, 09:45 AM)Taelsdoll Wrote:
(12-02-2017, 02:44 AM)xalius Wrote: Did you leave it charging for a couple hours? Usually they are not shipped with full batteries and need to be charged first...

Yeah I did but it still blinks and there’s nothing on the screen

Please make sure that your microSD card loaded with Pinebook OS build, not PINE A64 OS build.

It is, I have flashed an SD card on the pine64 installer with armbian selected. Did not work, I also tried android but also did not work. Its like the pinebook turns on and off because it also makes a weird high pitched sound and it goes on and on. nothing so far is working, I even tried removing the battery and running on AC power but nothing.

Please unplug and plug in battery again and then plug in power supply, check whether this method will boot up. You can repeat this step several times until the Pinebook can boot. Once boot up, lets keep the power supply plug in until fully charge. The high pitch noise may due to the charger protection circuit keep trigger and rest.

Hi @Taelsdoll, did you solve this? I've had this problem with my original Pinebook since I bought it. I desided to try again now, after having it stashed away useless since I bought it over two years ago. 

This is happening: The power blinks and the high pitch noise is there. I have tried the instructions on disconnecting and connecting the battery and then plug the power cable many many times, with no luck. Just the same result every time. Also left it like that over night a few times too, still no progress. 

I really wish there was a way out ot this.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Wink Usuarios pinebook español luis 2 258 07-19-2020, 04:49 AM
Last Post: Villico
Sad Disappointment with the Pinebook leperotero 7 608 07-01-2020, 11:26 PM
Last Post: sujunmin
Smile Pinebook Wallpapers - submissions please! Luke 28 4,926 06-18-2020, 01:06 PM
Last Post: PixelPaintbrush
  Pinebook without stuck or dead pixel Timeo 6 472 06-01-2020, 04:45 AM
Last Post: pfeerick
  Looking to buy 1080p Pinebook (Western Canada) lonelyparty 0 210 05-01-2020, 06:26 PM
Last Post: lonelyparty
Smile New pinebook owner and user - ideas? trigger 6 685 04-29-2020, 07:38 PM
Last Post: tenderfoot
  pinebook for specific purposes chexmix 5 464 03-23-2020, 01:36 PM
Last Post: jezek
  Pinebook Clones ? matze79 0 378 02-08-2020, 01:28 PM
Last Post: matze79
  New orders for Pinebook rgeorge1 1 434 02-05-2020, 12:32 AM
Last Post: bcnaz
  Pinebook 1080p for sale Spain (Madrid) e-minguez 1 427 12-14-2019, 09:53 PM
Last Post: 642af6a5e392

Forum Jump:


Users browsing this thread: 1 Guest(s)