keyboard/mouse freeze after 2-3 seconds on Debian
I'm still doing my early tests and I'm not that familiar with this particular Debian build (I'm using the stock Debian build that is delivered by the pine64-installer application using the stock downloaded image).

I'm finding now that keyboard/mouse is freezing after about 2-3 seconds after reboot.  It works when the GUI is presented but then stops.  I'm trying to reconfigure the network addressing so I can't SSH into the device or read logs;  other than fry the build I'm a little unsure of the source of this problem.

Gear is a generic USB keyboard and a simple Logitech USB wireless mouse (worked well earlier on the same build), it seems to be an issue after reboot (soft or hard/switch).

Are there any suggestions or should I fry this build and re-do it?
i'd probably disconnect the keyboard and mouse and use a windows on screen keyboard. you could start with just the mouse to try to isolate. if condition still exists try unplugging key w/mouse plugged in.
Thanks, I actually ditched the build and started again with a new build cycle - I was having too many problems with that build (but am still not sure of root cause). So far it's been better behaved but I'm seeing much slower performance on initial tests than I expected; load times are good but some comparisons with a CPU miner (compared to a Pi v2 running Raspbian 32-bit) are showing similar speeds when this should be much faster.
Nothing conclusive yet, still very early days in testing.
The Rock (as well as the Pine) have a sha-2 crypto extension, so if you're not seeing smth like a 100-fold hashing speedup (compared to a Pi2/3) it's probably your software that's not capable of using it.
(11-27-2017, 01:31 AM)dontpostalot Wrote: The Rock (as well as the Pine) have a sha-2 crypto extension, so if you're not seeing smth like a 100-fold hashing speedup (compared to a Pi2/3) it's probably your software that's not capable of using it.

I don't believe this would use crypto-extensions (though I am not entirely sure of the software stack to be honest).  I re-compiled a newer release and managed to achieve roughly 12.1-12.5 (the Pi v3 is supposed to manage about 10.3, the Pi v2 only pumps out about 5.2).  

I'm having trouble with every distro I've tried so far though; 
- the stock Debian continues to fail (perhaps 6 out of 7 boots fail) with mouse/keyboard working for < 1 sec and then stopping
- Xenial Mate has been the most reliable however the window manager stops after a while and you can't click on anything (mouse/keyboard seems to still respond but to no avail)O
- DietPi with XFCE works until the screen blanks (power save) and then it never comes back again but the OS continues to run

I'd ideally like to use a very close-to-vanilla Debian release (I prefer that over Ubuntu forks), I've read of some of the issues being known to date so I am presuming it's just the early build of some of these OS's.

I've been monitoring temperatures when running the mining app and I'm hitting 72 degrees C an ambient temperature room of <20 degrees C, I'm currently looking for a workable passive cooling solution with a very tall sink or a way of mounting a much larger sink on top of some copper shims;  still working out how best to do that though, I suspect that temperature isn't healthy.  I'd love to get this thing up to 1.5ghz and test the miner out, I'm presuming current limitations relate to temperature concerns and the ram speed shipped on some boards.

Possibly Related Threads…
Thread Author Replies Views Last Post
  How to update/compile Debian 12.5? Wizardknight 0 9 4 hours ago
Last Post: Wizardknight
  Rock64 Debian 11 (Bullseye) install problem jbize 15 7,606 10-12-2023, 05:14 PM
Last Post: tpaul
  rock64-debian-mrfixit-190531.img.xz : missing /usr/lib/dri/ popi 5 5,030 08-12-2021, 04:55 AM
Last Post: igorp
  Debian build from mrfixit2001 Luke 18 26,259 05-17-2021, 02:35 AM
Last Post: Wizzard
  Debian kernel stuck at 4.4.167 Enig123 5 5,386 12-29-2020, 12:57 PM
Last Post: kwinz
  Debian (Vanilla) on Rock64 and eMMC - how ? as365n4 4 5,059 09-21-2020, 04:33 AM
Last Post: as365n4
  pcsx rearmed on rock64 debian stretch does not go fullscreen RockyBoulder 2 4,100 05-09-2020, 03:15 AM
Last Post: lawrencejd
  Fedora 31 crosscompilation fdt problem mimics debian 888789 kf5zmi 2 4,012 01-20-2020, 12:25 PM
Last Post: kf5zmi
  Upgrading Debian Stretch image to Buster cosuhi 2 4,606 08-27-2019, 02:42 AM
Last Post: Malmgren
  Ayufan Debian Stretch Openmediavault 4 5G Wifi Not Connecting Poincare 0 2,206 03-26-2019, 07:28 PM
Last Post: Poincare

Forum Jump:

Users browsing this thread: 1 Guest(s)