SD Card Doesn't Boot Rock64
#1
I just got my Rock64 and used the pine64 installer from pine64dev's github and installed Debian Stretch Minimal to my 32gb sd card. However, when I plug in the Rock64 and insert the sd card, nothing happens on screen. Am I doing something wrong? All 3 leds are on and I can turn the red and white ones off by holding the power button, but nothing happens on screen.
  Reply
#2
I just flashed Debian Stretch Minimal via PINE64 Installer onto my SAMSUNG EVO 16GB MicroSD Card and plugged to my 2GB ROCK64, boot it up and wait for the boot messages running through my monitor and finally reached login prompt. So, no problem with my setup.

Note that, I don't have eMMC, I just connect power cable, HDMI cable and network cable. I tried boot with jumper on the 2 pins near the power button and also boot without the jumper, both also no problem.

You can probably try flashing other OS or try another MicroSD Card.
  Reply
#3
from reading your post, especially this, "However, when I plug in the Rock64 and insert the sd card, " i wanted to be certain that i'm probably misunderstanding what you wrote in that the proper sequence is to place the sd card into the slot and then apply power. not that you apply power and then insert sd card. it has been my experience that initial read errors can happen by applying power before insertion of sd card.
  Reply
#4
(09-24-2017, 12:32 AM)dkryder Wrote: from reading your post, especially this, "However, when I plug in the Rock64 and insert the sd card, " i wanted to be certain that i'm probably misunderstanding what you wrote in that the proper sequence is to place the sd card into the slot and then apply power. not that you apply power and then insert sd card. it has been my experience that initial read errors can happen by applying power before insertion of sd card.

Actually it wasn't booting because I wasn't using an outlet to barrel for power - I was using a usb to barrel cable hoping that I could plug it into a portable battery. However it obviously didn't provide enough power, so when I switched to the outlet it started working. Thanks though
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Rock64 v3 - POE P1V 3 297 9 hours ago
Last Post: mcerveny
  Rock64 board seems defective, how to confirm? Josk 1 62 08-15-2019, 08:24 PM
Last Post: tllim
  Rock64 for video surveillance martinschm 4 199 08-12-2019, 11:55 AM
Last Post: pkfpeters
  Purchase Rock64 V3? richardk 6 423 08-03-2019, 12:56 PM
Last Post: mcerveny
  Rock64 running OMV, how to setup RTL8812AU WiFi? electrosam 2 114 07-16-2019, 04:03 PM
Last Post: ayufan
  Rock64 random freezes BTB 3 189 07-01-2019, 10:17 AM
Last Post: Luke
Sad Rock64 Seafile Installation klaus_nase 2 133 06-27-2019, 09:11 AM
Last Post: klaus_nase
  rock64, compile problems "illegal instruction", "memory fault" -> ddr_333Mhz? hunderteins 5 365 06-22-2019, 12:36 PM
Last Post: redfish
  Another non-booting ROCK64 SuburbanDad 13 654 06-19-2019, 01:48 AM
Last Post: mcerveny
  Plastic storage box for Rock64 matwey 1 108 06-18-2019, 10:56 PM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)