SD Card Doesn't Boot Rock64
#1
I just got my Rock64 and used the pine64 installer from pine64dev's github and installed Debian Stretch Minimal to my 32gb sd card. However, when I plug in the Rock64 and insert the sd card, nothing happens on screen. Am I doing something wrong? All 3 leds are on and I can turn the red and white ones off by holding the power button, but nothing happens on screen.
#2
I just flashed Debian Stretch Minimal via PINE64 Installer onto my SAMSUNG EVO 16GB MicroSD Card and plugged to my 2GB ROCK64, boot it up and wait for the boot messages running through my monitor and finally reached login prompt. So, no problem with my setup.

Note that, I don't have eMMC, I just connect power cable, HDMI cable and network cable. I tried boot with jumper on the 2 pins near the power button and also boot without the jumper, both also no problem.

You can probably try flashing other OS or try another MicroSD Card.
#3
from reading your post, especially this, "However, when I plug in the Rock64 and insert the sd card, " i wanted to be certain that i'm probably misunderstanding what you wrote in that the proper sequence is to place the sd card into the slot and then apply power. not that you apply power and then insert sd card. it has been my experience that initial read errors can happen by applying power before insertion of sd card.
#4
(09-24-2017, 12:32 AM)dkryder Wrote: from reading your post, especially this, "However, when I plug in the Rock64 and insert the sd card, " i wanted to be certain that i'm probably misunderstanding what you wrote in that the proper sequence is to place the sd card into the slot and then apply power. not that you apply power and then insert sd card. it has been my experience that initial read errors can happen by applying power before insertion of sd card.

Actually it wasn't booting because I wasn't using an outlet to barrel for power - I was using a usb to barrel cable hoping that I could plug it into a portable battery. However it obviously didn't provide enough power, so when I switched to the outlet it started working. Thanks though


Possibly Related Threads…
Thread Author Replies Views Last Post
  OpenWRT on the Rock64 CanadianBacon 5 983 03-31-2022, 01:29 PM
Last Post: CT456
  Rock64 bricked shawwwn 6 1,642 01-29-2022, 05:49 AM
Last Post: shawwwn
  Rock64 board not working, no HDMI no Ethernet. EDited 2 807 01-26-2022, 08:46 AM
Last Post: TRS-80
  Boot from SPI first mjnck 0 355 12-31-2021, 11:23 AM
Last Post: mjnck
  Rock64 <--> Rock64 Serial Connection mark1250 1 622 12-23-2021, 09:27 PM
Last Post: barray
  Are you guys still using Ayufan's OMV on your Rock64? AkiraSensei 0 613 11-26-2021, 07:01 PM
Last Post: AkiraSensei
  Rock64 kernel panics clay 15 4,304 10-17-2021, 06:30 PM
Last Post: Rocklobster
  Pine Rock64 eMMC lifespan moonspell79 3 1,760 08-19-2021, 06:46 PM
Last Post: bcnaz
  Rock64 No Audio - Solved wbecks 12 21,815 08-13-2021, 01:23 PM
Last Post: blakeadam
  Trustzone support for Rock64 capablegh 1 1,253 07-17-2021, 10:15 AM
Last Post: capablegh

Forum Jump:


Users browsing this thread: 1 Guest(s)