LibreELEC Krypton/Leia/Agile 64bit kernel 32bit libs
(03-16-2018, 12:51 PM)Trash_Can_Man Wrote:
(03-15-2018, 08:02 PM)Trash_Can_Man Wrote:
(03-13-2018, 05:33 PM)Trash_Can_Man Wrote: i just tried your r24 on my rock64, after their partition resize it restart and drops a lot of kernel panics on boot, i need to unplug and plug again the power, after that it works fine apparently but i cant make my tp-link t4uhp dual band wifi to work (it have the exact same chipset as the one you guys sell on your store here: rtl8812au) but i dont even have a remote idea of where to start...

Wired works fine so i can maybe download stuff but i have no idea where to start as this distro have no apt-get for a start, any guide/tips is greatly appreciated...

EDIT: forgot to add that i did this test on a spare SD card i had around and its still there waiting, i can do any test without much fear of screwing it because my main card is working perfectly (with ayufan ubuntu minimal tho, i want to jump to any tuned kodi build)

Follow up to this:
Its a device ID problem apparently, im no expert on linux stuff but google allways gives you tips about stuff and the module is there, i can force load it but it say "used by: 0", and when i check the modules.alias file there is the 2357:010D (wich is allmost the same card exept with less power) but there is no 2357:010F, the chipset (and driver i assume) is the same if you look at this and this...but the libreelec OS itself is locked and im not sure if i can edit stuff without recompiling...any help is totally appreciated...

Going deeper:
i found this: https://sites.google.com/site/andreierde...shfs-howto is that still current and works? seems like a very annoying proccess so i might ask first, all my assumptions are correct and editing that file and adding a line with the correct id causes the module to be linked to the device and this MAY solve my problem or am i totally barking at the wrong tree here?

Taking a detour on the subect maybe:
looking at https://lwn.net/Articles/143397/ seems like i can link a driver to a device (so kinda the opposite of what i was looking before but working the same, i guess) but: 
a) its to late and my head is about to explode (tho i love to learn new things even the brain gets tired) 
b) again im not sure if im barking at the right tree or if that solution is even permanent, seems like its lost on any reboot
c) im also not sure how to use that but again, its to late and im starting to even confuse numbers with letter, gonna try again tomorrow if i have time

Its me again!! i know you are happy to read me   Dodgy

So i did more research on the subject and editing the modules.alias file is a VERY BAD thing so im going to forget about that, also reading and googling more i found that i need to do:
Code:
echo 2357 010f > /sys/bus/usb/drivers/8812au/new_id

to add the device id to the driver, the command gives no error but if after that i do:

Code:
modinfo 8812au

the 2357 010f is still NOT on the list so i guess that the locked filesystem is biting me in the back again (without errors this time).

I also tried to use the 8812au driver on the ayufan stretch and bionic minimal images but those dont even include the 8812au module so im even worst on those (and i was unable to manually install the module on those, i didnt try to hard tho since i want to jump to the libreelec build, any side test is simply temporary)

So i think i finally hit a roadblock so im going to wait for any Raybuntu or any guru help/tips, thanks in advance for any help.

Final edit: just to be sure i plugged the adapter to a w7 pc and its working perfectly fine, so there is no hardware problems, the usb port on the rock64 work fine too and there is no chance for power problems because i use a self powered usb hub where i also plug an external hdd that also works perfect)

More info on this, now im TOTALLY sure that the 8812au driver works with my device id (2357:010f), i downloaded a few mins ago the last version of the armbian build for the rock64, the one with a desktop environment (btw, a bit bulky but perfect build, it simply start to their desktop env even with some basics like browser, mail, calculator, libreoffice etc, exelent to calm down the people complaining about a lack of desktop) but back to the point their build includes the 8812au driver and detects my board ootb, no config needed at all (exept that for some reason its randomly detected when plugged to my usb3.0 hub, maybe some setup thing, allways detected when plugged directly) so back to my subject and now with total security i ask:

How can i assign the 2357:010f device id to the 8812au driver easily as an advanced user (no dev knowledge) on libreelec, or if there is no simple way i humbly ask to add this device ID to the next libreelec build. Thanks for reading and any help is totally wellcome. Big Grin
  Reply


Messages In This Thread
RE: LibreELEC Krypton/Leia/Agile 64bit kernel 32bit libs - by Trash_Can_Man - 03-16-2018, 09:02 PM

Possibly Related Threads…
Thread Author Replies Views Last Post
  Security Patches for the Kernel kwinz 8 1,690 01-16-2021, 05:34 PM
Last Post: kuleszdl
  Debian kernel stuck at 4.4.167 Enig123 5 1,395 12-29-2020, 12:57 PM
Last Post: kwinz
  Arch Linux Arm --> Kernel 5.8 breaks installation as365n4 12 5,175 08-31-2020, 01:41 AM
Last Post: as365n4
  mainline kernel sound support Openwrt lucize 2 1,474 05-01-2020, 05:09 PM
Last Post: PakoSt
  5.3 kernel support? csrf 5 2,710 04-18-2020, 11:34 PM
Last Post: CameronNemo
  Help troubleshooting kernel panic gabrielfin 3 1,729 03-02-2020, 04:18 PM
Last Post: gabrielfin
  need a dts file to set some pins as pulldown interrupts in kernel using a DTO dkebler 0 833 02-05-2020, 10:58 PM
Last Post: dkebler
  Any advantages to using the mainline kernel dkebler 0 906 11-16-2019, 12:17 PM
Last Post: dkebler
  Does anybody run the mainline kernel? CameronNemo 3 1,922 09-09-2019, 07:56 PM
Last Post: CameronNemo
  Libreelec, Infrared, 1080p, "Restart" gigagames 0 979 03-16-2019, 05:30 AM
Last Post: gigagames

Forum Jump:


Users browsing this thread: 2 Guest(s)