noise random green pixel when plugged power supply only (solved. see edit.)
#1
Hello world. Hello world.

I received my pinebook 14 inch yesterday. It came with 3 half-dead black pixel on white background on original Xeinial Mate image ship. It is really not big deal. I just ran script to upgrade kernel, u-boot, and system to get rid of flicker backlight brightness problem. I started noticed noise random green pixel when I plugged power. Blue, green, and gray background are affected. Unplugged power will stop noise random green pixel in Armbian 5.32 image but Xeinial Mate 0.6.2 will not… just slowly continue in battery mode until sleep and wake up.

I am not only one. There is other person who have same problem as mine but he don’t mention power supply plug-in. Here’s link https://forum.pine64.org/showthread.php?tid=4843 That video is exently same problem as mine.

Sadly, Armbian 5.32 image caused my laptop got permanent 4th dead green pixel. It is worse nightmare than half-dead black pixel. I decided stop using Armbian image to come back Xeinial Mate 0.6.2. here's image https://drive.google.com/open?id=0B9ywmn...mR4bzhoUlE My eyes see green

Here’s spec of my power supply https://drive.google.com/open?id=0B9ywmn...TZEdjVKQXc Some guy in IRC said it’s ok.

Here are images I used
1. Original Xeinial Mate. (I am sure it is 0.5.2.)w
2. Upgraded Xeinial Mate 0.6.2 or 0.7.10-105, I think. I lost tracking again.
3. Stretch Minimal 0.7.10-105
4. Armbian 5.32

Now, I am using Xeinial Mate 0.6.2 on eMMc. (linux pinebook 3.10.105-bsp-1.2-ayufan-77 #1 SMP PREEMPT Sun July 7 12:09: UTC 2017 arcg64 GNU/Linux) I am trying redownload Xeinial Mate 0.5.2-59 for SD card now. I’ll update it later.

P.S. I opened ticket support for just in case. maybe they send replacements board (and screen if they can) if USB adapter as power supply still caused problem.

EDIT: Downgraded Xeinial Mate 0.5.2. There are no longer noise random green pixel when i plugged power supply but backlight brightness flickering made me triggered mad until turn off auto reduce backlight brightness on power management for battery mode or upgrade 0.6.2. i have no choice. Just disabled auto reduce backlight brightness. I played wallpaper background with blue. No problem at all. Thanks to guy at IRC for tips. I thinking get screen replacement due to permanent 4th dead green pixel. Im updating ticket support.

Also, I really like Armbian because chrome performance and good modified XFCE and preinstalled programs. but I must stay away from Armbian 5.32 or upgrade Xeinial Mate 0.6.2 to avoid noise random green pixel problem. Keep in Armbian 5.32 and Xeinial Mate 0.5.2 still uses 56hz refresh rate. Xeinial Mate 0.6.2 uses 63hz. I think it is power management software problem, not refresh rate
. Right now, I wanted report bug software but where? Let me know thanks.
If Microsoft ever does applications for Linux it means I've won.
Linus Torvalds
#2
Quote: ... I wanted report bug software but where?

In short this information needs to reach ayufan as he's the driving force behind the linux stuff on the PB. I suggest you report the issue on his git and only after doing so ping him in IRC to bring his attention to it. 
If its any conciliation, I've seen other users have the same issue -- its quite possible that setting the display to  60hz would resolve this.
You can find me on IRC, Discord and Twitter


#3
(09-06-2017, 09:35 AM)Luke Wrote: If its any conciliation, I've seen other users have the same issue -- its quite possible that setting the display to  60hz would resolve this.
Display setting GUI do not let me change hz on Armbian and Xeinial Mate both. I'll google up change hz on commandline.
If Microsoft ever does applications for Linux it means I've won.
Linus Torvalds
#4
(09-06-2017, 09:41 AM)BatteryDie Wrote:
(09-06-2017, 09:35 AM)Luke Wrote: If its any conciliation, I've seen other users have the same issue -- its quite possible that setting the display to  60hz would resolve this.
Display setting GUI do not let me change hz on Armbian and Xeinial Mate both. I'll google up change hz on commandline.

It probably needs to be changed in the device tree
You can find me on IRC, Discord and Twitter


#5
(09-06-2017, 09:52 AM)Luke Wrote:
(09-06-2017, 09:41 AM)BatteryDie Wrote:
(09-06-2017, 09:35 AM)Luke Wrote: If its any conciliation, I've seen other users have the same issue -- its quite possible that setting the display to  60hz would resolve this.
Display setting GUI do not let me change hz on Armbian and Xeinial Mate both. I'll google up change hz on commandline.

It probably needs to be changed in the device tree


Yes,  dts|dtb change necessary.
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
#6
I tried play with tweak brightness command (/sys/class/backlight/lcd0/brightness). it caused pop up noise random green pixels on Xeinial Mate 0.5.2 during plugged in power. I reinstalled OS to restored original brightness setting. Im trying back up that before try again tweak brightness command.

Edit: random noise green pixel screen came back after i ran apt-get upgrade but did not update script for uboot and kenal. Mmm. I do not read list of upgrade before type yes on commandline.
If Microsoft ever does applications for Linux it means I've won.
Linus Torvalds


Possibly Related Threads…
Thread Author Replies Views Last Post
  Disable auto power on? cel 0 1,114 12-22-2019, 08:41 AM
Last Post: cel
  [SOLVED] Pinebook stopped to charge UltraBloxX 7 4,269 10-17-2019, 04:09 AM
Last Post: pfeerick
  Add separate power button? maddmike 2 1,369 12-17-2018, 04:35 PM
Last Post: maddmike
  Power supply clarification maldus 5 2,443 12-17-2018, 03:55 AM
Last Post: maldus
  Power LED / Charging LED Question d97 4 2,147 11-21-2018, 10:26 AM
Last Post: Noxmiles
  UK Power Adapter? dejan 5 2,785 12-06-2017, 04:44 PM
Last Post: DigitalStefan
  Pinebook LCD pixel errors? kuszinger 3 1,735 11-24-2017, 03:11 AM
Last Post: dejan
  Internal power connector problem stealthbanana 1 1,230 09-19-2017, 10:45 AM
Last Post: MarkHaysHarris777
Question Power Related Problem Questions p3p1 1 1,040 08-29-2017, 06:06 PM
Last Post: MarkHaysHarris777
  Wanted: Better power adapter for Pinebook. flingtoad 4 2,924 08-21-2017, 10:09 PM
Last Post: Siliconserf

Forum Jump:


Users browsing this thread: 1 Guest(s)