libssl-dev eon't install
#1
I need to install libssl-dev, but when I try I am getting the following error:

The following packages have unmet dependencies:
libssl-dev : Depends: libssl1.0.0 (= 1.0.1t-1+deb8u6) but 1.0.2l-1~bpo8+1 is to
be installed

/etc/debian_version says 8.9 and i installed the pine64-image-debianmate-310102bps-2.img 

uname -a gives the following output:
Linux dev-fs 3.10.102-2-pine64-longsleep #66 SMP PREEMPT Sat Jul 16 10:53:13 CES
T 2016 aarch64 GNU/Linux


How do I fix this?

Thanks for your time.

William.
  Reply
#2
(08-21-2017, 03:22 PM)williamcolls Wrote: I need to install libssl-dev, but when I try I am getting the following error:

The following packages have unmet dependencies:
libssl-dev : Depends: libssl1.0.0 (= 1.0.1t-1+deb8u6) but 1.0.2l-1~bpo8+1 is to
be installed

/etc/debian_version says 8.9 and i installed the pine64-image-debianmate-310102bps-2.img 

uname -a gives the following output:
Linux dev-fs 3.10.102-2-pine64-longsleep #66 SMP PREEMPT Sat Jul 16 10:53:13 CES
T 2016 aarch64 GNU/Linux


How do I fix this?

Thanks for your time.

William.

Hello William

I had this problem with the Debian Mate image, while trying to install. The problem is that I needed to install the libcurl4-openssl-dev library as well, which caused the confilict, which is dependent on libcurl3 librararies.

The solution was eventually to remove the libcurl4 dev libraries and seperately install the libcurl3 libraries and then it just installed without the error. I also had to force the version of the libssl-dev to a higher version. I did this all via the Synaptic manager.

Hope this helps.

Cool
  Reply
#3
(08-21-2017, 03:22 PM)williamcolls Wrote: I need to install libssl-dev, but when I try I am getting the following error:

The following packages have unmet dependencies:
libssl-dev : Depends: libssl1.0.0 (= 1.0.1t-1+deb8u6) but 1.0.2l-1~bpo8+1 is to
be installed

/etc/debian_version says 8.9 and i installed the pine64-image-debianmate-310102bps-2.img 

uname -a gives the following output:
Linux dev-fs 3.10.102-2-pine64-longsleep #66 SMP PREEMPT Sat Jul 16 10:53:13 CES
T 2016 aarch64 GNU/Linux


How do I fix this?

Thanks for your time.

William.
unless you need to run a build over a year old you should start over with a newer build
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Digital drawing tablet Huion - proper drivers install janeku 20 11,521 05-19-2019, 09:24 PM
Last Post: xinhua
  How install Qbittorrent on Debian? Callisto 5 3,364 03-17-2018, 10:31 PM
Last Post: Callisto
Exclamation How to install JavaFX tommypine 3 3,086 01-09-2017, 03:21 AM
Last Post: dkryder
  install shashlik bilylilyli 1 1,614 11-20-2016, 06:59 PM
Last Post: Ghelorn
  Install 32bit java Trond 7 3,471 11-03-2016, 10:07 AM
Last Post: Trond
  Cannot install Dstat on Debian Base PineA64 image ywoody 6 3,022 07-11-2016, 07:15 PM
Last Post: dkryder
  Debian Video Performance/"Driver" Install Fawks 8 4,084 06-15-2016, 07:55 AM
Last Post: Luke
  How to install modules into system? MicroDiery 6 3,042 05-27-2016, 06:44 PM
Last Post: JamesHarris
  debian fresh install 5/14 mkyb14 3 1,781 05-17-2016, 10:52 AM
Last Post: mkyb14

Forum Jump:


Users browsing this thread: 1 Guest(s)