Newbie question - should a Rock64 with no mmc card still output some video ?
#1
My unit arrived this week.  Powering it on doesn't elicit any response on either of my monitors.    The green, white and red LEDs remain on and stable.

Is this normal ?
#2
When the unit is powered on, it will first look for the valid boot image in either SD or eMMC to load. What did you install on your SD card? Android? Debian Jessie? Xenial?
#3
(08-18-2017, 02:23 PM)sgk Wrote: My unit arrived this week.  Powering it on doesn't elicit any response on either of my monitors.    The green, white and red LEDs remain on and stable.

Is this normal ?

Yes, as with most SBC's, there is no video output without a bootable image either on EMMC or SDC.

Good luck!
#4
(08-20-2017, 10:52 AM)blue Wrote:
(08-18-2017, 02:23 PM)sgk Wrote: My unit arrived this week.  Powering it on doesn't elicit any response on either of my monitors.    The green, white and red LEDs remain on and stable.

Is this normal ?

Yes, as with most SBC's, there is no video output without a bootable image either on EMMC or SDC.

Good luck!


There is no firmware at all;  nothing!  no bios, no eufi, nothing;   everything is in the image and that lives on the SD or the eMMC;   eventually we will have uboot on the on-board SPI flash, but not yet....
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
#5
Fwiw, I had this problem on my main monitor (no signal). I tried every combination of mmc / sdcard with no luck but when i plugged it into my 4k TV I had no problem at all. Maybe it was trying to output 4k video which isn't supported in my monitor (over hdmi at least). EDID broken?
#6
(08-23-2017, 02:16 PM)Bloop Wrote: Fwiw, I had this problem on my main monitor (no signal). I tried every combination of mmc / sdcard with no luck but when i plugged it into my 4k TV I had no problem at all. Maybe it was trying to output 4k video which isn't supported in my monitor (over hdmi at least). EDID broken?

I just installed a ran Debian Stretch on my Rock64 last night.  It happily output console text through HDMI to my non-4K computer monitor and so my experience is different from yours.
#7
(08-18-2017, 02:23 PM)sgk Wrote: My unit arrived this week.  Powering it on doesn't elicit any response on either of my monitors.    The green, white and red LEDs remain on and stable.

Is this normal ?

Hi

I followed the guide on wiki for booting android on emmc:

http://wiki.pine64.org/index.php/ROCK64_...se_version
http://files.pine64.org/doc/rock64/guide...o_eMMC.pdf

Please note that before flashing firmware, there won't be any signal coming out from hdmi port.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Rock64 No Audio @ Debian 12 dmitrymyadzelets 2 219 04-08-2024, 06:47 AM
Last Post: dmitrymyadzelets
  OpenWRT on the Rock64 CanadianBacon 14 8,180 04-03-2024, 08:48 AM
Last Post: helpmerock
  Rock64 bricked shawwwn 7 5,603 03-17-2024, 12:22 PM
Last Post: dmitrymyadzelets
  Rock64 won't boot luminosity7 10 4,034 03-16-2024, 08:33 AM
Last Post: dmitrymyadzelets
  Rock64 doesn't boot dstallmo 1 314 03-16-2024, 08:29 AM
Last Post: dmitrymyadzelets
  How well does Rock64 deal with HDR and Atmos on Kodi? drvlikhell 3 1,849 04-29-2023, 04:24 AM
Last Post: newestssd
  Rock64 board not working, no HDMI no Ethernet. EDited 3 3,475 01-17-2023, 02:31 PM
Last Post: Flagtrax
  ROCK64 v3 can it boot from USB? Tsagualsa 4 2,053 11-29-2022, 11:31 AM
Last Post: Macgyver
  rock64 v3 spiflash Macgyver 0 738 11-28-2022, 02:18 PM
Last Post: Macgyver
  my rock64 dosen't work rookie_267 0 939 10-07-2022, 07:50 PM
Last Post: rookie_267

Forum Jump:


Users browsing this thread: 1 Guest(s)