Newbie question - should a Rock64 with no mmc card still output some video ?
#1
My unit arrived this week.  Powering it on doesn't elicit any response on either of my monitors.    The green, white and red LEDs remain on and stable.

Is this normal ?
  Reply
#2
When the unit is powered on, it will first look for the valid boot image in either SD or eMMC to load. What did you install on your SD card? Android? Debian Jessie? Xenial?
  Reply
#3
(08-18-2017, 02:23 PM)sgk Wrote: My unit arrived this week.  Powering it on doesn't elicit any response on either of my monitors.    The green, white and red LEDs remain on and stable.

Is this normal ?

Yes, as with most SBC's, there is no video output without a bootable image either on EMMC or SDC.

Good luck!
  Reply
#4
(08-20-2017, 10:52 AM)blue Wrote:
(08-18-2017, 02:23 PM)sgk Wrote: My unit arrived this week.  Powering it on doesn't elicit any response on either of my monitors.    The green, white and red LEDs remain on and stable.

Is this normal ?

Yes, as with most SBC's, there is no video output without a bootable image either on EMMC or SDC.

Good luck!


There is no firmware at all;  nothing!  no bios, no eufi, nothing;   everything is in the image and that lives on the SD or the eMMC;   eventually we will have uboot on the on-board SPI flash, but not yet....
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
  Reply
#5
Fwiw, I had this problem on my main monitor (no signal). I tried every combination of mmc / sdcard with no luck but when i plugged it into my 4k TV I had no problem at all. Maybe it was trying to output 4k video which isn't supported in my monitor (over hdmi at least). EDID broken?
  Reply
#6
(08-23-2017, 02:16 PM)Bloop Wrote: Fwiw, I had this problem on my main monitor (no signal). I tried every combination of mmc / sdcard with no luck but when i plugged it into my 4k TV I had no problem at all. Maybe it was trying to output 4k video which isn't supported in my monitor (over hdmi at least). EDID broken?

I just installed a ran Debian Stretch on my Rock64 last night.  It happily output console text through HDMI to my non-4K computer monitor and so my experience is different from yours.
  Reply
#7
(08-18-2017, 02:23 PM)sgk Wrote: My unit arrived this week.  Powering it on doesn't elicit any response on either of my monitors.    The green, white and red LEDs remain on and stable.

Is this normal ?

Hi

I followed the guide on wiki for booting android on emmc:

http://wiki.pine64.org/index.php/ROCK64_...se_version
http://files.pine64.org/doc/rock64/guide...o_eMMC.pdf

Please note that before flashing firmware, there won't be any signal coming out from hdmi port.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Rock64 v2 Locking Up when Accessing External Storage theGAXman 2 87 01-14-2020, 05:44 AM
Last Post: tomarm
  rock64, compile problems "illegal instruction", "memory fault" -> ddr_333Mhz? hunderteins 6 577 01-14-2020, 05:36 AM
Last Post: tomarm
  Rock64 problems with external Hard Drive and powering mjd 1 112 12-14-2019, 10:05 AM
Last Post: helsinki92
  ROCK64 as VPN Gateway Talkabout 18 507 12-14-2019, 03:42 AM
Last Post: Talkabout
  Rock64 Long Term stability ramprasad 1 122 12-09-2019, 04:34 PM
Last Post: evilbunny
  doesn't boot, no video cjyar 7 268 11-15-2019, 03:45 PM
Last Post: ab1jx
  Selling Rock64's dugalbug 6 397 10-19-2019, 12:12 PM
Last Post: dugalbug
Exclamation Rock64 v2 freeze help! JuanDTM 5 293 10-16-2019, 06:37 PM
Last Post: Rocklobster
  Rock64 for video surveillance martinschm 6 527 09-19-2019, 01:56 AM
Last Post: Jozek
  ROCK64 not booting TheGiolly 10 606 09-09-2019, 06:57 AM
Last Post: Rocklobster

Forum Jump:


Users browsing this thread: 1 Guest(s)