Serial Console for the Rock64
#31
THere is this one from Amazon, https://www.amazon.com/Adapter-Serial-Co...S486A9CQ0R  and some other  cheaper ones ones .
also.  

I know this one has worked for me.
#32
The "USB to Serial" I use is the same product(probably ?) as the one below.
And it works correctly.

https://www.amazon.com/PL2303HX-Download...ics&sr=1-3
https://www.amazon.com/s?k=PL2303HX&i=el...e-asc-rank

---

However, products of this genre have a large number of fakes.
For example, It is often the case that the item description and the actual item are different.

Please be careful about that point.
#33
So an update- I ordered the following adapter from Sparkfun https://www.sparkfun.com/products/14050 which uses the CH340G Chip

uname output: 
Code:
Linux carbon 4.13.0-46-generic #51-Ubuntu SMP Tue Jun 12 12:36:29 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

The following output is from dmesg:
Code:
[  396.785621] usb 2-1: new full-speed USB device number 5 using xhci_hcd
[  396.927062] usb 2-1: New USB device found, idVendor=1a86, idProduct=7523
[  396.927069] usb 2-1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[  396.927073] usb 2-1: Product: USB2.0-Serial
[  396.961478] usbcore: registered new interface driver usbserial
[  396.961509] usbcore: registered new interface driver usbserial_generic
[  396.961526] usbserial: USB Serial support registered for generic
[  396.964206] usbcore: registered new interface driver ch341
[  396.964250] usbserial: USB Serial support registered for ch341-uart
[  396.964267] ch341 2-1:1.0: ch341-uart converter detected
[  396.965807] usb 2-1: ch341-uart converter now attached to ttyUSB0

I connected only the RX and GND from the serial adapter to ports 8 and 6 on the RockPro respectively (GND to 6, RX to 8)

I've tried both picocom and minicom with the following arguments:
sudo picocom /dev/ttyUSB0 -b 1500000
sudo minicom -s -D /dev/ttyUSB0 -b 1500000

And i'm getting no signal on the console when powering on the RockPro64. I also tried different combinations of TX/RX to ports 8/10 on the board to no avail. 

Unsure if it could be related to my OS/SDCard as well so I have tried a few different distros using both Etcher and the Pine64 installer. So far i've tried Ubuntu Bionic Minimal (ayufan), Bionic Desktop (ayufan) and Rasbian stretch. 

Any ideas of where to go from here? at this point i'm starting to wonder if I could've gotten a bad board Sad

Also it's possible that my laptop seeing the CH340G as a "CH341" is a potential issue? But not sure.

*EDIT*
I am reading in other forum posts that there should be some other white LED if the SDCard is able to boot? This is a brand new 64GB SDCard I bought from the Pine store so I don't know if that could be the issue. Also reading it's highly likely the SD Card slot on my board is dead, as apparently this is common. Any way to verify that before I go ahead and send this back for a replacement? This is starting to get very frustrating :/
#34
I too neglected to purchase the serial console with my initial order.

Very clever Pine Microsystems, Inc., now I get to order more gear.

In the meantime, could I be tweaking the linux build of my choice on the card and when I have the serial console, use an imaging software (Clonezilla for instance) to write the SD to the emmc? Sorry if it's a ridculous question.

1. Image the sd build.
2. Use that image to write to the emmc (instead of pulling an image from the network).
3. Boot into the emmc build.
4. Wipe the sd card and use it for additional storage.
I'm guessing not at all that simple but thought I'd ask.
____________________________________________________
SeatsAndChairs.com Inc.


Possibly Related Threads…
Thread Author Replies Views Last Post
  OpenWRT on the Rock64 CanadianBacon 5 873 03-31-2022, 01:29 PM
Last Post: CT456
  Rock64 bricked shawwwn 6 1,572 01-29-2022, 05:49 AM
Last Post: shawwwn
  Rock64 board not working, no HDMI no Ethernet. EDited 2 769 01-26-2022, 08:46 AM
Last Post: TRS-80
  Rock64 <--> Rock64 Serial Connection mark1250 1 597 12-23-2021, 09:27 PM
Last Post: barray
  Are you guys still using Ayufan's OMV on your Rock64? AkiraSensei 0 600 11-26-2021, 07:01 PM
Last Post: AkiraSensei
  Rock64 kernel panics clay 15 4,128 10-17-2021, 06:30 PM
Last Post: Rocklobster
  Pine Rock64 eMMC lifespan moonspell79 3 1,721 08-19-2021, 06:46 PM
Last Post: bcnaz
  Rock64 No Audio - Solved wbecks 12 21,670 08-13-2021, 01:23 PM
Last Post: blakeadam
  Trustzone support for Rock64 capablegh 1 1,223 07-17-2021, 10:15 AM
Last Post: capablegh
  Python GPIO Library for the Rock64 (R64.GPIO) Leapo 37 46,798 07-02-2021, 03:20 PM
Last Post: klausfelix

Forum Jump:


Users browsing this thread: 1 Guest(s)