[Jan 14] KDE Neon (20190113-1500) - Pinebook1080P / Pinebook |[Jan 14] Q4OS (2.7-r1) - Pinebook1080P / Pinebook | [Dec 07] DietPi(v6.18) - Pinebook / Manjaro KDE (preview3) / Manjaro LXQT (preview3) - Pinebook |[Dec 06] Armbian Debian Stretch (5.67) / Armbian Ubuntu 18.04 Bionic Desktop (5.67) - RockPro64 |[Dec 05] DietPi(v6.18) - 1080P Pinebook

Project Inspiration | Get Started | IRC Logs | Forum Rules/Policy


Proof of concept script to disable the touchpad while typing
#21
(11-24-2017, 09:06 AM)rookieone Wrote:
(11-23-2017, 08:51 PM)southern.cross Wrote: Has anyone gotten this script to work in the Armbian OS for Pinebook? I get the following errors when I try to use it:

Code:
Traceback (most recent call last):
 File "/usr/lib/python3.5/threading.py", line 914, in _bootstrap_inner
   self.run()
 File "/usr/lib/python3.5/threading.py", line 862, in run
   self._target(*self._args, **self._kwargs)
 File "touchpadsleep.py", line 312, in timeoutThread
   device_number = self.findXInputDeviceNumber()
 File "touchpadsleep.py", line 303, in findXInputDeviceNumber
   res = subprocess.run(["/usr/bin/xinput", "list"], stdout=subprocess.PIPE).stdout
 File "/usr/lib/python3.5/subprocess.py", line 693, in run
   with Popen(*popenargs, **kwargs) as process:
 File "/usr/lib/python3.5/subprocess.py", line 947, in __init__
   restore_signals, start_new_session)
 File "/usr/lib/python3.5/subprocess.py", line 1551, in _execute_child
   raise child_exception_type(errno_num, err_msg)
FileNotFoundError: [Errno 2] No such file or directory: '/usr/bin/xinput'

Looks like xinput is not installed:

https://packages.ubuntu.com/search?keywo...ection=all

After a:

sudo apt-get install xinput

it ill probaby work? (works on my pinebook, Armbian 5.34)

@rookieone
That's all it was...

<sheepish grin>

Thanks.
Reply
#22
Adding python3 and the script to sudoers is not necessary. You need to call python3 using the full path! This works just fine on the 0.6.2 ubuntu mate image. Added user to 'input' group (sudo usermod -aG input USERNAME), copied script content to file '/usr/local/bin/touchpadTame.py' for and made executable for testing. Worked fine. Added below line to startup list via System -> Preferences -> Personal -> Startup Applications, logged out, logged back in... works like a charm! Thanks for putting it together @daid! I'll add it to my collection of scripts at https://github.com/pfeerick/pine64-scripts/


Code:
/usr/bin/python3 /usr/local/bin/touchpadTame.py
Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  How to enable touchpad natural scrolling? plumlis 2 160 12-08-2018, 10:35 AM
Last Post: Surehand53
  Disable touchpad tap to click? colin.faulkingham 15 1,592 08-04-2017, 09:36 PM
Last Post: MarkHaysHarris777
Sad touchpad edges scrolling kurai021 11 1,003 07-09-2017, 05:56 PM
Last Post: Luke

Forum Jump:


Users browsing this thread: 1 Guest(s)