Switching to analog audio in Ubuntu
#1
Music 
I'm running the most recent Ubuntu Xenial image by longsleep. I'm just playing around with all the ports, and I see on the Euler bus, there is a pin for EAROUT_N. I assumed that was for headphones, so I wanted to try sending audio to that. I enabled the universe repository and got mplayer installed, and it seems to be playing the audio file I am testing with, but I get no audio out of my headphones. I have the Pine connected to a monitor without speakers, so I don't get any audio through the HDMI, though I assume that's where the audio is being sent to. I found some documents that said I can use amixer to switch to analog audio, but I can't figure out if what I am providing to it is even valid information. Has anyone got audio coming out of their headphone jack in this build of Ubuntu yet? I've never been good with the audio side of things in Linux.
  Reply
#2
as this a is a debian based distro you may want to look at this

Bug Fix - Playback Of Mulitple Audio Streams - ALSA - April 10th 2016

If you like my work be sure to check out my site or wish to donate to the cause

Cheers Big Grin
  Reply
#3
(04-10-2016, 04:22 PM)lenny.raposo Wrote: as this a is a debian based distro you may want to look at this

Bug Fix - Playback Of Mulitple Audio Streams - ALSA - April 10th 2016


Thanks for this I will be adding this to my Ubuntu Distro!
"Weakness of attitude becomes weakness of character."

-Albert Einstein

-Anderal (Michael Eddy Larson)
  Reply
#4
(04-10-2016, 04:22 PM)lenny.raposo-pine64.pro Wrote: as this a is a debian based distro you may want to look at this

Bug Fix - Playback Of Mulitple Audio Streams - ALSA - April 10th 2016


That bug fix has been removed from the top message in the thread, and it doesn't show up in the bug tracker at https://www.pine64.pro/bug-reports-3-10-65-bsp/

Was there a problem with the fix? If not, should it have been incorporated in the 20160501 image? I'm having what looks like the same problem.

Thanks,

Ran
  Reply
#5
Hello,

A solution have been found for sound have on jack outpout and no in hdmi outpout ?

Thank You,

Quentin
  Reply
#6
(06-12-2016, 06:31 AM)2pseud Wrote: A solution have been found for sound have on jack outpout and no in hdmi outpout ?

Hi Quentin,

Just checking, do you you mean sound on the jack and not on the HDMI? or are you asking why there is sound on the earphone jack but not on the hdmi as well?

If you mean you want sound on the earphone jack and not on the HDMI, that has been discussed here, and I have documented the commands I ran to get my setup running here.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  SPI on ubuntu IlyaM 4 1,313 07-16-2018, 03:00 AM
Last Post: kingflab
  Ubuntu password not working joemassimino 4 724 05-18-2018, 03:33 PM
Last Post: Luke
  After flashing Ubuntu- how to get graphical desktop Partymack711 6 1,629 02-01-2018, 09:45 AM
Last Post: Partymack711
  (ARCHIVED) Ubuntu Xenial Image (BSP Kernel) longsleep 337 150,236 01-31-2018, 11:58 AM
Last Post: Luke
  PPTP doesnt work with ubuntu escovedo 2 2,083 08-23-2017, 09:28 AM
Last Post: gilbertotcc
Question HELP Ubuntu Mate password recovery procedure Captain Anni Hilator 5 1,966 08-03-2017, 03:52 PM
Last Post: Luke
  Ubuntu boot very slow with wifi driver remainder 9 2,130 08-03-2017, 07:23 AM
Last Post: victorssantos
  Recovering root access in Ubuntu Scientomancer 3 690 07-28-2017, 02:53 PM
Last Post: Scientomancer
  Pine64 2Gb Ubuntu Mono not updating and stuck petec 0 604 07-08-2017, 09:34 AM
Last Post: petec
  Ubuntu Xenial - Firefox add support for H264 and EAC3 klode 1 1,450 05-26-2017, 11:10 AM
Last Post: Gnx

Forum Jump:


Users browsing this thread: 1 Guest(s)