Sound coming out both speakers and headphones
#1
Hello,

I've noticed that when I attempt to plugin headphones to my pinebook and play a video that sound still comes out the internal speakers and the headphones.  Is this how it's supposed to work?  Any ideas how to troubleshoot or fix this?

I'm running the default ubuntu mate on it and I poked around in the sound settings and didn't find anything there that looked like the answer to this problem.
#2
(07-06-2017, 09:15 AM)eclay Wrote: I'm running the default ubuntu mate on it and I poked around in the sound settings and didn't find anything there that looked like the answer to this problem.

If you run alsamixer from the console, there are different volumesliders for speaker and headphone (as I remember) if you do scroll to the complete right side....
#3
(07-06-2017, 09:43 AM)guidol Wrote:
(07-06-2017, 09:15 AM)eclay Wrote: I'm running the default ubuntu mate on it and I poked around in the sound settings and didn't find anything there that looked like the answer to this problem.

If you run alsamixer from the console, there are different volumesliders for speaker and headphone (as I remember) if you do scroll to the complete right side....

Yes, for now mute output via speakers in alsa. Someone is currently working on autodetecting headphones in Linux.
You can find me on IRC, Discord and Twitter


#4
(07-06-2017, 09:43 AM)guidol Wrote:
(07-06-2017, 09:15 AM)eclay Wrote: I'm running the default ubuntu mate on it and I poked around in the sound settings and didn't find anything there that looked like the answer to this problem.

If you run alsamixer from the console, there are different volumesliders for speaker and headphone (as I remember) if you do scroll to the complete right side....

It seems like possibly on the pinebook alsomixer isn't showing thins in easy to understand words like "speaker".  I see output devices like the following.

Headphone (easy enough to understand what this is)
phoneout mixer lout_mixer_switch [off]
phoneout mixer mic1 boost [off]
phoneout mixer mic2 boost [off]
phoneout mixer rout_mixer_switch [off]
phoneout gain control
i2s hub func [off]
..
..
..
Eventually I found headphone/speakers at the end of this long list.  I was able to turn the volume done on the speakers but there has to be an easier method to switch between headphones and pc speakers.  Like something that detects the headphone being plugged in and muting the speakers like when I'm running linux on a normal intel laptop.  This post mentions something about auto_mute.

https://askubuntu.com/questions/150887/s...d-speakers

Also interesting that when I look at lspci I see no devices lsusb shows the camera and the hardware hubs.  Using aplay -l I can see some useful info but I'm not sure how to translate that into what driver is used for the analog sound device.  Looking at the above post it mentions adding some lines to the /etc/modprobe.d/alsa-base.conf to resolve this issue.

Thanks again for helping me figure this out.
#5
Its the very last setting on the right hand-side labled 'speaker':

[Image: EXj8BuU.png]
You can find me on IRC, Discord and Twitter


#6
(07-06-2017, 10:38 AM)Luke Wrote: Its the very last setting on the right hand-side labled 'speaker':

[Image: EXj8BuU.png]

Thanks, I found it.  Still seems like there should be an automatic method of muting them like other laptops.  Maybe it's not possible.
#7
As I already said, its being worked on.
You can find me on IRC, Discord and Twitter


#8
Just ran into this last night and had to do this workaround. Can't wait for an OS level fix.
#9
(07-06-2017, 02:27 PM)jordanjay29 Wrote: Just ran into this last night and had to do this workaround. Can't wait for an OS level fix.

I don't know if this will be happening anytime soon... the 'normal' detection / software response methods rely on ACPI, etc, and are thus not present. There's no handy kernel event that udev can hook into either.

So far, there are options. Run this command manually to mute the external speaker on demand:

amixer -q set "External Speaker" mute

and the corresponding

amixer -q set "External Speaker" unmute

to, um... unmute? the external speakers. 

Or in alsamixer, go to the far right, and you'll find the external speaker volume / mute option.

In the mean time, I have this proof of concept that I need to look at turning into something a bit more... palatable in operation for inclusion into the images... Basically download it, make it executable (chmod +x [script-name]) and run it. It only does it's 'magic' whilst running, as it isn't a background service. You could probably stuff it in /etc/rc.local in a pinch, with an '&' after it so it runs in the background. Note the 'Raw' button on the github page if you want the downloadable version.

https://github.com/pfeerick/pine64-scrip..._detect.sh


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pine64 laptop sound? bobn9lvu@sbcglobal.net 3 1,588 08-09-2017, 03:01 PM
Last Post: Luke

Forum Jump:


Users browsing this thread: 2 Guest(s)