activate microphone?
#1
Hi, I can't use the microphone with Linux and I do not know if this is normal for other users, how could I activate it from Alsamixer?
  Reply
#2
I did it before on Pine64 boards, configuring the codec in alsamixer is a bit complicated because it has 113 controls. Looking at the PB schematic MIC1 is wired to the internal MIC and MIC2 is wired to the headphone jack for 4 ring connectors. I'll see if I find some time tonight to play with the settings... it works on Android so the hardware should be good Smile

Looking at what Android does:

MIC1:

Code:
 <path name="media-main-mic">
   <ctl name="AIF1OUT0R Mux" value="AIF1_AD0R" />
   <ctl name="AIF1OUT0L Mux" value="AIF1_AD0L" />
   <ctl name="AIF1 AD0R Mixer ADCR Switch" value="1" />
   <ctl name="AIF1 AD0L Mixer ADCL Switch" value="1" />
   <ctl name="ADCR Mux" value="ADC" />
   <ctl name="ADCL Mux" value="ADC" />    
   <ctl name="LADC input Mixer MIC1 boost Switch" value="1" />
   <ctl name="RADC input Mixer MIC1 boost Switch" value="1" />
   <ctl name="ADC volume" value="180" />
 </path>


MIC2:

Code:
<path name="media-headset-mic">
   <ctl name="MIC2 SRC" value="MIC2" />
   <ctl name="LADC input Mixer MIC2 boost Switch" value="1" />
   <ctl name="RADC input Mixer MIC2 boost Switch" value="1" />
   <ctl name="ADCL Mux" value="ADC" />
   <ctl name="ADCR Mux" value="ADC" />
   <ctl name="AIF1 AD0L Mixer ADCL Switch" value="1" />
   <ctl name="AIF1 AD0R Mixer ADCR Switch" value="1" />
   <ctl name="AIF1OUT0L Mux" value="AIF1_AD0L" />
   <ctl name="AIF1OUT0R Mux" value="AIF1_AD0R" />
   <ctl name="ADC volume" value="160" />
 </path>

Can someone try to set those in alsamixer and report back? I dont have a PB with me atm...
Come have a chat in the Pine IRC channel >>
  Reply
#3
I'll try to find some time later today to fiddle with this, but when we had a look last night, I got one of internal mics working by just toggling the LADC input Mixer MIC1 boost Switch as it was off (one of the settings near the end in alsamixer in the playback mode) and the other 'just worked' when I plugged in a TRRS/four pole headset (and no, it wasn't the internal mic on the headset, I did check). However, I'll report back, and we can put together a post to pull all this info together in one place.
  Reply
#4
(06-29-2017, 04:56 AM)kurai021 Wrote: Hi, I can't use the microphone with Linux and I do not know if this is normal for other users, how could I activate it from Alsamixer?

http://sprunge.us/YbaX 
---

sudo cp /var/lib/alsa/asound.state /var/lib/alsa/asound.state.bak
cp /link/above/save/filename /var/lib/alsa/asound.state
sudo alsactl restore

enjoy your working mic.

(ALL credit to pfeerick on this one!)
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)