+PINEBOOK How to go about setting up your own Jenkins build system for pine64 / pinebook images
#1
Question 
This is basically a place to try and document what I have done, and find out what I need do in order to get this working. I've flagged it as pine64 and pinebook related as ayufan's builds support both at this point in time.

So, what am I trying to do? Basically, I have crappy internet, and come computers around which are more than capable of grunting their way through compiling and building images for the pine64 / pinebook. This would also let me look into customising the images, and doing some work on them myself... maybe. Angel I've played with docker a little bit, and have used Travis CI in the past, so thought how hard could this be? Famous last words. Dodgy

I decided one of my pine64 servers could be the jenkins boss, so loaded jenkins 2.46 (as it's the LTS version) on that that. Easy peasy, had everything up and running in under 20 minutes. Set up a build node or two on the ubuntu x64 boxes, so that they could be responsible for the actual builds, so the pine64 only had to manage them from afar. Since the Jenkins file in the repo wanted a node with both the docker and linux-build tags, I made sure one of them had that, was running LTS 16.04, and had docker on it, and had actually also manually build the build-environment docker on it also (but that was more to test if it was working than actually configure anything, and I did end up deleting it at one point just in cause it was the cause of the issue).

I then setup the new pipeline, configured it as a pipeline script from SCM -> Git -> https://github.com/ayufan-pine64/linux-build and left pretty much everything else as defaults. Tried running the pipeline, had to double back and install the AnsiColor plugin, and then the build ran. It downloaded the repo file, logged into the build node, and started building the docker container without any dramas. So it gets to the end of the docker build, and promptly and consistently dies. I'll include some logs below, but does anyone (especially ayufan or tkaiser) have any ideas what I'm doing wrong? Am I missing some blindingly obvious configuration step that I should have known about before attempting any of this?

I even setup jenkins on the same machine that was doing the build, and set it as the docker/build node, tried playing with docker plugins with no luck, and installed blue ocean just incase it was related to a plugin it added.

I *think* the issue is related to this entry in the log, but I'm not sure, and I don't know how to correct it, hence this post. asus-h55d is the host-name of the node which the build was slaved out to, and it's this line that stands out as different from the logs from ayufan's builds.


Code:
[Pipeline] withDockerContainer
15:33:39 asus-h55d does not seem to be running inside a container

This is the plain text build log: http://sprunge.us/LaPW

This is the log that blue ocean shows, which rather helpfully doesn't actually show why the environment stage failed: http://sprunge.us/IiVU

Can anyone help?
  Reply
#2
You need to make sure that you have global variables configured in Jenkins interface. This are required variables: https://github.com/ayufan-pine64/linux-b...insfile#L3
Homepage: https://ayufan.eu

Releases:
Rock/Pro 64/Pinebook Pro: LinuxChromium OS
So/Pine A64/Pinebook: LinuxAndroid 6.0Android 7.1

Buy me a Beer
  Reply
#3
(05-31-2017, 01:38 AM)ayufan Wrote: You need to make sure that you have global variables configured in Jenkins interface. This are required variables: https://github.com/ayufan-pine64/linux-b...insfile#L3

Wooho! I added the Global Variable String Parameter Plugin (not 100% I need to, but I don't remember seeing any mention of parameters or global variables until I did), added the parameters to the pipeline config (only 'difference' is I did multi-line string as text wasn't an option... just different verbage?), and its now about five minutes into the build stage.

Now to see what happens if and when it finishes... Wink
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Pine64 not powering up. skylab 5 391 05-03-2019, 02:48 PM
Last Post: Mendota
  Pine64 LTS vs Rock64 4 GB LTS gops 2 191 04-15-2019, 10:56 AM
Last Post: gops
Thumbs Down Pine64 was a Useless Project pushpendrak 14 3,125 03-07-2019, 08:48 AM
Last Post: dkryder
  Pine64+ 2GB board for sale with WiFi module and case ~clumsy~ 1 408 10-21-2018, 04:54 AM
Last Post: aeiltz
  Video Chat with Pine64 mathiraj 0 246 07-02-2018, 02:33 PM
Last Post: mathiraj
  Selling my PINE64 2GB Set Philippines / Asia only $115 racann 4 2,102 06-17-2018, 12:53 PM
Last Post: racann
  Supply DC power to Pine64 via Pi-2 Connector & Euler Bus? crapped 2 509 05-24-2018, 01:58 AM
Last Post: crapped
Shocked Selling my PINE64 2GB+ board with WIFI/BT module and extras $30 or best bid in ebay moondark 0 364 04-14-2018, 12:31 PM
Last Post: moondark
  Is possible to install Home Assistant on pine64 2gb? polv89 1 1,375 04-02-2018, 05:22 PM
Last Post: tllim
Thumbs Up Pine64 For sale. UK montyflange 2 1,515 01-07-2018, 04:10 PM
Last Post: racann

Forum Jump:


Users browsing this thread: 1 Guest(s)