Pine 2GB won't boot Android anymore
Been using Ayufan's A6.1TV HDMI build for quite some time now. We use it primarily for Kodi and Netflix. Until last night. 

Last night I noticed the board was off. This was odd to me because we let it run continuously, 24/7. But the other half has been known to unplug it before, so I checked the power supply. Still plugged in to the wall with the OEM power supply. Hmm... Check the supply at the board. Yep, still plugged in. OK.... Let's power it on with the power button, holding the button down long enough for the red led to brighten slightly after initial power-up. Ok, Samsung TV seems to recognize incoming signal (1080/60p). After a few moments of no activity, the tv said "no signal." I looked at the pine, and the led power indicator was out.


Maybe retrying the previous process will do the trick.



Maybe the PNY SD card went bad. Let's try the Samsung Evo SD card with WiKi's Rooted A5.1.1 LCD build burned on it.

Hey! The LCD still works! Booting hangs on the PINE A64 screen for a couple minutes, but A5.1.1 LCD eventually boots. Of course, still no HDMI display, but I know it's not meant to have HDMI & LCD outputs simultaneously.

Ok great, my pine didn't destroy itself or something.

Let's try the PNY SD card again with Ayufan's A6.1TV HDMI.

Same as before. Nothing and shut off on its own.

Ok, let's try the official Pine 64 SD card with Rasbian burned on it. Yep, that works. (I'm illiterate with that os, so I don't use it)


Let's use Apple-pi Baker on OSX 10.12.4 to burn Auyfan's tried and true A6.1TV HDMI build on the official Pine 64 SD card.

After successfully "baking" my pi, I double checked the .uEnv file on the BOOT disk for uncommented 1080/60p (per my tv). Ok, that's good to go. Eject "BOOT" from MacBook.

This is it. It's going to work.

Nope. Exactly the same outcome as my original PNY SD card with the same, long-time working, A6.1TV HDMI build from Ayufan.

It's time for bed, let's ask the community tomorrow.

Does anybody have any ideas as to why my pine will not boot A6.1TV HDMI and even shut off shortly after powering on?

Sorry for the lengthy post, I just wanted to be as clear and accurate as possible while conveying my issue to you guys (and gals).



I just burned WiKi's Android 7.1 TV. Uncommented 1080p60 and booted. Kodi is up and running again. Still curious as to anybody else had the 6.1 issues I experienced and or solutions.

+1 me if I have helped you in any way. Thank you.
Same thing happened last night with 7.1. Nobody has any insight on this issue? It like the builds are getting g stick in a boot loop.
+1 me if I have helped you in any way. Thank you.
one thing comes to mind is, and since i have not used android in a while i'm not sure if it has this feature, if you have the app store set to auto update and it picks up that supersu binary needs updating and goes ahead and updates and executes binary update routine then of course your build is now broken and gets into a boot loop and won't boot. the root on these new builds is being reported as broken by root checker right off the bat. something to do with improper root user id so i'm thinking that this may, as well as chainfire trying to do systemless root on every build now and that conflicts with how root is being established by ayufan or whomever is coding the root establishment.
That wouldn't explain why I couldn't re-burn ATV6.1.
+1 me if I have helped you in any way. Thank you.
(05-29-2017, 06:54 PM)Bluphire Wrote: That wouldn't explain why I couldn't re-burn ATV6.1.

Since the pine64 is powering off... it sounds like it isn't seeing a valid boot device. er, scratch that... I just double checked, and it didn't do what I thought... , as I thought the pine64 powered off after 30 or so seconds if you powered it on without a microSD card present... Dodgy

It's going to be hard to debug what's going on, because at the moment, it is a literal black box. Do you have a USB to Serial adapter / cable which you can connect the the GND and Tx pins on the EXP header (have a look at the pinout guide in my signature, and connect Tx on the pine64 to Rx on the USB to serial adapter). It doesn't need to be a 3.3v tolerant as you don't need to connect to the Rx pin on the pine64, and regardless of that, the EXP header on the pine64 appears to have a mosfet level shifter on the serial Rx line (but all the other pins are 3.3v IOs only). If you can give us the output you get when powering up the board when it doesn't want to work properly, we might be able to work out what's going on. Other than that, what dkryder sounded plausible... except that wouldn't happen with a squeaky clean new (old) image which hasn't even been let online yet.
(05-29-2017, 06:54 PM)Bluphire Wrote: That wouldn't explain why I couldn't re-burn ATV6.1.

well, based on your story it might be an operator error that created a somewhat messed up sd card. i don't work with apples and sd cards so i'm not sure of the process of unmounting the sd card prior to eject but that might be it. might be the apple screwed the sd card during the process even though the operator followed all steps correctly. could be a whole list of things that you or anyone else will never pinpoint. my question is, why is it such a big deal? obviously you can't figure it out. you stated your wife likes to unplug running pines, that will really screw a sd card. yet, it may not show it until certain things happen. the pine64 does not scan a whole sd card before each boot to mark fubar sector/areas . these cards just work until they don't.  when you put an os on an sd card it mostly puts or lays down the os in the same fashion each time. it's entirely possible the sd card is just bad and happens to manifest by not booting an os after working for years. welcome to the world of sd cards.
put the card through a verifier and see what is reported.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Android 6.0 Tablet and TV (release candidate, maintained) ayufan 228 402,792 12-29-2020, 01:13 AM
Last Post: firmwarefile
Shocked Remote for Android? liodra 18 31,001 12-23-2020, 06:11 AM
Last Post: Learnincurve
  Adding an accelerometer to Android modsbyus 11 17,509 11-02-2020, 08:12 PM
Last Post: Little_Johnny
  Android Things OS dqvsra 2 7,260 12-03-2019, 09:52 AM
Last Post: hangglider
  Is there another link for Android images? Maalth 3 7,365 10-10-2019, 07:57 AM
Last Post: tophneal
Question Android SDK Oreo NGC6691 2 5,877 07-15-2019, 08:29 PM
Last Post: dazza5000
  Putting Android 9 RockPro64 source into easier to manage repositories dazza5000 0 3,500 07-15-2019, 08:29 PM
Last Post: dazza5000
  Bliss OS (PINE A64(+)) pineadmin 4 12,775 06-07-2019, 09:01 PM
Last Post: nukedawg
  Android 5.1.1 TV (old-stable, no longer maintained) ayufan 194 269,399 03-12-2019, 04:53 PM
Last Post: neosapien
  Issues with SD Card and Running Android Twistedx 0 3,680 02-26-2019, 11:58 AM
Last Post: Twistedx

Forum Jump:

Users browsing this thread: 1 Guest(s)