Turning off RPI GPIO 5v on boot (SOPine)
#1
I was wondering if there was any way to turn off the 5v+ on the RPI GPIO (or Euler) for the SOPine, because even a really low amp 5v fan connected to the RPI GPIO prevents it from booting.

I bought the kit WITH the power supply and yet it STILL has trouble booting without the HDMI cable plugged in, and now it seems like I have to buy a higher power PSU for it as its going in a cluster, headless.

Right now I have the SoPine's fan plugged in to one of my other Pine64's (NOT SoPine) in the cluster but that is not a good way to do things, and I really don't want to power all my fans separately.  I'm using CanaKit's 2.5 Amp RPI PSUs for those and they are working BEAUTIFULLY!

I'd like to use a PWM fan but those usually run full power with no PWM input so that still is not an option without turning off the +5v on the buses.

I'm considering using one of the PWM outputs for a non-PWM fan but I don't know if it could handle the AMPs and I don't want to add a bunch of extra unnecessary electronics for a stupid little fan.  (yah yah I know it would just be a transistor and a couple resistors, that's not the point, a stupid little low amp fan should NOT need that...)

The power for both GPIOs should be off on default during boot, because the SOPines seem to have such bad boot power problems.

I do intend to eventually buy a gutsy Mauser power supply for all of them, but for just a few Pines that is overkill right now.  

Any suggestions?  

-Tek
#2
The 5V on the headers are connected to the 5V DC-IN directly if the 5V jumper is in the DC-IN position so it shouldn't prevent anything from booting unless there is something going on with the inductive load the motor presents? Is that a fan with integrated BLDC controller or just a plain 5V DC fan and what rating does it have?
Come have a chat in the Pine IRC channel >>


Possibly Related Threads…
Thread Author Replies Views Last Post
  [Star64] Help needed in understanding Yocto and U-boot build process InterestedinFOSS 0 410 04-23-2024, 10:58 AM
Last Post: InterestedinFOSS
  Boot Ox64 after SPI Flash IC replacement kotnitro 1 1,448 05-26-2023, 02:19 AM
Last Post: kotnitro
  Star64 first boot (and success) bortzmeyer 1 1,916 05-24-2023, 02:45 AM
Last Post: draintroup
Exclamation Quartz64 model a wont boot AndyNZAUS 0 1,695 09-13-2022, 06:35 AM
Last Post: AndyNZAUS
  Maximum size of boot MicroSD for RockPro64 and Pinebook Pro commiecam 0 1,821 08-07-2022, 10:47 AM
Last Post: commiecam
  Wi-Fi/Bluetooth for PINE64, Model: Sopine A64 lamson 0 1,910 08-24-2021, 08:17 AM
Last Post: lamson
  How to boot from SD card on pinebook pro linux123 3 6,424 12-02-2020, 10:29 AM
Last Post: linux123
Lightbulb Live boot with persistence? r00tn3rd 1 3,409 10-23-2020, 01:30 AM
Last Post: HotChocolate
  Occasional boot toiny 0 2,247 10-18-2020, 01:41 PM
Last Post: toiny
  1 of 7 SoPINE compute modules not receiving DHCP lease ClusterMaker 2 3,708 09-08-2020, 03:03 AM
Last Post: Dippywood

Forum Jump:


Users browsing this thread: 1 Guest(s)