(ARCHIVED) Ubuntu Xenial Image (BSP Kernel)
(07-25-2016, 05:28 AM)xalius Wrote: Can you hop onto the IRC chat? Maybe we can figure out your problem there...

Did you manage to solve it? I'm having the same problem...
For some reason after changing in /etc/NetworkManager/NetworkManager.conf managed=false and rebooting, the pine doesnt boot up anymore. I used a fresh image from 15.12.

I also have a cluster where I ran the kernel update, fix whatever, resize and uboot update from longsleep. After the update some pines boot up, some dont.

Did anybody have a similar problem or knows how to fix this?
Everything happens on purpose by accident.
I have a Pine64+ 2GB. Downloaded longsleep and booted fine with a hdmi monitor

I attached the 7" lcd monitor. I can boot it fine with an android image.

However, the longsleep image does not work with the lcd monitor. It starts to boot, attempts to access the lcd panel and then freezes.

Question: Is there any plan to support the lcd touchscreen panel with ubuntu? If it is already supported, are there config changes I need to make (or debug info I can provide)?

Apologies if this is a duplicate question
(01-31-2017, 02:06 PM)osterhus Wrote: I have a Pine64+ 2GB. Downloaded longsleep and booted fine with a hdmi monitor

I attached the 7" lcd monitor. I can boot it fine with an android image.

However, the longsleep image does not work with the lcd monitor. It starts to boot, attempts to access the lcd panel and then freezes.

Question:  Is there any plan to support the lcd touchscreen panel with ubuntu? If it is already supported, are there config changes I need to make (or debug info I can provide)?

Apologies if this is a duplicate question

I found this in the forum, which seems to answer part of my question.

http://forum.pine64.org/showthread.php?tid=2896

I would still like to know if this support is included in the xenial image and if not, encourage that it is.

Thanks all,
Just ran /usr/local/sbin/pine64_update_kernel.sh and rebooted. Bricked. Nothing is working now. Not even HDMI to monitor is working. Have tried several times to reboot and nothing. What now? How do I recover?
(02-01-2017, 10:51 AM)utdrmac Wrote: Just ran /usr/local/sbin/pine64_update_kernel.sh and rebooted. Bricked. Nothing is working now. Not even HDMI to monitor is working. Have tried several times to reboot and nothing. What now? How do I recover?

Use the backup image you created before updating...

... <sorry, that was cold>  use a serial TTL usb bridge cable ( attached to the EXP header serial console pins ) and monitor the bootup to find out where its failing.  Technically, you cannot brick the pine board;  just load a good image on a new SD card and start over. It would be difficult to know specifically what happened in your case, but booting up with a serial cable monitor would be helpful.
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
(02-01-2017, 11:36 AM)MarkHaysHarris777 Wrote: ... <sorry, that was cold>  use a serial TTL usb bridge cable ( attached to the EXP header serial console pins ) and monitor the bootup to find out where its failing.

Yea, that's a bunch of greek to me.

I did the Windows method: format and reinstall with latest image. Things working now. Thanks!
I know there is a limited interest in this feature, but does Ubuntu support other resolutions than 1080/720 already? My Pine is catching dust because my spare 1050p 16:10 monitor isn't supported.

I would try to solve it by myself, but my knowledge isn't sufficient for this task.
(03-13-2017, 12:52 PM)Darkover Wrote: I know there is a limited interest in this feature, but does Ubuntu support other resolutions than 1080/720 already? My Pine is catching dust because my spare 1050p 16:10 monitor isn't supported.

I would try to solve it by myself, but my knowledge isn't sufficient for this task.

You might be able to get your monitor to work with the hdmi-->vga adapter from the pine store.

There is intense interest in this subject;  however, there are some technical hurdles ;  and a couple of legal issues.   The weak link on the Pine platform ( particularly for gnu+linux ) is the hdmi video output from the gpu.
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
Hi all,

I've observed a weird issue with the xenial-pine64-bspkernel-20161218-1.img image whilst trying to get it to run headless on my Pine64. Based on an evening of flashing and re-flashing SD cards I have concluded that:
  • If an HDMI display is connected on the first ever boot then it seems that the OS will NEVER boot without an HDMI display. 
  • If NO HDMI display is connected on the first ever boot then the OS will boot happily - with or without a display for ever more.
This has tripped me up on an OpenHABian derivative image that exhibits the same behaviour (see issue at https://github.com/openhab/openhabian/issues/105).

I figure there is a script that is running on the first ever boot that sets a piece of configuration differently depending on whether a display is connected or not. Thus far I've not figured out what that is or how to fix it so that a system booted with HDMI the first time can later be booted headless.

Sadly I do not have a serial cable for my P64 so am unable to see the console and figure out what's happening.

Sounds suspiciously like unintended behaviour - if anyone has any suggestions then I'd be glad to hear them.

Many thanks,
Simon


Possibly Related Threads…
Thread Author Replies Views Last Post
  Ubuntu server 20.04 request phi0x 2 849 12-30-2020, 08:02 PM
Last Post: phi0x
  Xenial Minimal Image (PINE A64(+)) 0.6.2-77 pineadmin 4 11,864 08-30-2020, 10:35 AM
Last Post: jrronimo
  Kickstarter P64 with LCD, working image? MostHated 1 1,667 01-04-2020, 10:32 AM
Last Post: igorp
  USB Wireless Drivers with Longsleep Linux Kernel jacobscarter 15 9,981 03-06-2019, 02:26 PM
Last Post: tllim
  Allwinner A64 RTC bug fix on bionic image? tkaivola 1 1,807 02-01-2019, 05:09 AM
Last Post: tllim
  SPI on ubuntu IlyaM 4 4,224 07-16-2018, 03:00 AM
Last Post: kingflab
  Ubuntu password not working joemassimino 4 3,673 05-18-2018, 03:33 PM
Last Post: Luke
  How can I get a wireless dongle working on Xenial Desktop latest build Rocklobster 1 1,791 04-16-2018, 03:09 PM
Last Post: Rocklobster
  After flashing Ubuntu- how to get graphical desktop Partymack711 6 4,973 02-01-2018, 09:45 AM
Last Post: Partymack711
  PPTP doesnt work with ubuntu escovedo 2 4,674 08-23-2017, 09:28 AM
Last Post: gilbertotcc

Forum Jump:


Users browsing this thread: 1 Guest(s)