Multiple Pine64s on Network Fail
#1
I have been having a heck of a time trying to get 2 Pine64s to work on the same LAN. 

Router - Verizon ActionTec - I know, I know.  It sucks.

Pine64 1
Hostname: Pine64Server2
Static IP: 192.168.1.100
OS: Ubuntu headless

This works fine.  When I first plug it in after flashing the OS, it comes up as just an address (like 192.168.1.8) or I think it used to come up as "Pine64." I change the hostname (and hosts) and set the static IP and it works great. 

Here's where things get wonky.  When I try to add a second Pine64, flashed with the same OS, two things happen (or don't happen):
Pine 64 2
Hostname: Pine64 (default)
IP: DHCP
OS: Ubuntu headless

When I look on the router, suddenly my original Pine64 at 192.168.1.100 is named "Pine64" and I can't see the new Pine64 listed on the router and I can't Putty into it.

Am I doing something wrong?

Thanks
  Reply
#2
(02-05-2017, 08:08 PM)JCMPine64 Wrote: I have been having a heck of a time trying to get 2 Pine64s to work on the same LAN. 

Thanks

You may find that both PineA64 units have the same mach address.  rats

... so make the mac address of each machine unique.  Try this in a terminal:

cat  /boot/uEnv.txt

The mach address should begin  with  00:06:dc: xx:xx:xx

Make sure that each mach address is unique : the last three xx:xx:xx can be anything you want, but they must be unique for your network.

The script :  /usr/local/sbin/pine64_eth0-mackeeper.sh

... handles keeping the mach address unique.  You can edit the mach address in /boot/uEnv.txt, or you can delete the address line from /boot/uEnv.txt and the pine64_eth0-mackeeper.sh script will set it.   I prefer to setup the mach address myself and make sure they are unique.
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
  Reply
#3
How interesting!  I'll give that a try, thanks.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  No boot-up . Initializing SDRAM fail . Siim 1 393 09-27-2017, 04:20 PM
Last Post: dkryder
  Swap out cards with multiple OSs? BeerSnob 1 401 06-15-2016, 10:31 AM
Last Post: jl_678

Forum Jump:


Users browsing this thread: 1 Guest(s)