Ethernet connection issues
I ordered two Pine64s and am connecting them via Ethernet to the same router. Using the Ubuntu Xenial base image. I worked through an issue where both cards had the exact same MAC address by doing the following:

- edited /etc/network/interfaces.d/eth0:
iface eth0 inet dhcp
 hwaddress ether 00:00:00:00:00:00

For 00:00...00:00 I put a custom mac address. I then rebooted the Pine. This exact process seemed to work for one Pine board, but not the other. It's strange because for the second Pine board, I can connect fine using the default mac address, but once I change the address by editing the interface file and reboot, the ethernet fails to connect (I get no lights period from the ethernet port).

Can anyone explain to me what might be the issue? Since I am flashing both pines with the same image and executing the same steps, I can only assume there is some hardware issue that I am encountering.
From your message, since you have different MAC addresses on both devices now, I don't know what could be causing it.

However, the root problem re: same mac addresses stems from the fact that mac address is hard-coded in the /boot/uEnv.txt file (so it's on the 50MB fat partition that windows can see). My uEnv.txt for a recently provisioned longsleep ubuntu image looks like this... (which I haven't bothered changing). So in the first instance, it may be easier / worth ensuring it is different there on both pine64s (and not bothering with the /etc/network/interfaces override), or removing it from the uEnv.txt and specifying it in the /etc/network/interfaces config only.

console=tty0 console=ttyS0,115200n8 no_console_suspend

Also, I seem to remember (although this may be from another forum and for a completely different matter) that there was some issue with changing the first three octets from the manufacturer specified one? So maybe only change the last one?

An even easier fix if you're using the minimal Ubuntu Xenial image is to use the Armbian one instead, as IIRC Armbian generates a random mac on first run?
uEnv.txt seems to have worked. Thank you!

The uEnv.txt file immediately after flashing the card, but before booting it in a pine, did not have an ethaddr line. I added it, changing only the last octet:


I made sure to do this before booting it in the pine board, just to make sure.

Thanks for the tip on Armbian! I may check it out.

**UPDATE: The ethernet problem came back again later today, so I may have spoken too soon**
I've installed the armbian ubuntu xenial image instead, and so far seems to be working better. Will update again if the issue reoccurs

Possibly Related Threads…
Thread Author Replies Views Last Post
  Issues out of nowhere fsa317 16 7,439 05-13-2018, 07:01 PM
Last Post: pfeerick
  New Ubuntu ML-Anderal 4-20-16 Issues AUDIOTEK 2 2,011 08-14-2016, 06:03 PM
  Ethernet not working on Xubuntu 20160528 build a_fad 2 1,883 06-26-2016, 01:19 AM
Last Post: dkryder
  Auto updater issues Ubuntu Mate Gnx 0 888 06-10-2016, 04:51 PM
Last Post: Gnx
Question Issues with Ubuntu MATE joneszn 5 4,990 04-23-2016, 12:52 PM
Last Post: joneszn

Forum Jump:

Users browsing this thread: 1 Guest(s)