Is the Wifi module working?
#1
I have Pine64 running under Debian with a Wifi module installed that came with the board.
However, I can access the network only by plugging a Wifi adapter into one of the USB
connectors.

Without Wifi adapter the terminal command "ip link" shows no Wifi just
a link called "sit0" and another "dummy0". Is one of those the Wifi module?

How can a get the module active and how can I find its MAC address?
  Reply
#2
(11-14-2016, 09:37 AM)clawinus Wrote: I have Pine64 running under Debian with a Wifi module installed that came with the board.
However, I can access the network only by plugging a Wifi adapter into one of the USB
connectors.

Without Wifi adapter the terminal command "ip link" shows no Wifi just
a link called "sit0" and another "dummy0". Is one of those the Wifi module?

How can a get the module active and how can I find its MAC address?
Firstly, check that your wifi module is plugged in the right way around - there are more pins on one side than the other, meaning there is a wrong way around and and aright way around.
Which debian distro are you using? 
No, they are not the wifi module - it should have been called wlan0 and wlan1. 
Check your /etc/network/interfaces file - is wlan0 enabled? you can leave wlan1 disabled.
  Reply
#3
Thanks for replying to my inquiry.
I am using Debian Jessie Base & Mate Images
downloaded from the Pine64 site.

How I installed the wifi module and the contents of the interfaces file

are shown in the attached photos.

I hope I have put in the wifi module the right way.

I took the photo of the interfaces file when the Wifi adapter was not plugged into the USB slot.

A wlan 0 and wlan1 are recognized. How do I disable wlan1?    
   
  Reply
#4
(11-18-2016, 07:55 PM)clawinus Wrote: Thanks for replying to my inquiry.
I am using Debian Jessie Base & Mate Images
downloaded from the Pine64 site.

How I installed the wifi module and the contents of the interfaces file

are shown in the attached photos.

I hope I have put in the wifi module the right way.

I took the photo of the interfaces file when the Wifi adapter was not plugged into the USB slot.

A wlan 0 and wlan1 are recognized. How do I disable wlan1?


Simply remove the '#' from in front of iface wlan1 inet manual. This makes it so the network manager no longer manages wlan1.

From your picture, that looks to be the right way around.

Have you been able to configure your wifi connection yet, or are you still stuck? If you are, have a look at this post, as those steps should get you working. If not, just about any generic linux command line wifi instructions (like this one) should get you 90% of the way ;-)
  Reply
#5
Thanks for your extensive reply.

I will try things. My current status is that I have wifi network access through an USB Wifi adapter which is fine but I need the USB connection position on the Pine64 for drive attachment et al. The second USB connector is taken by the wireless keyboard. So I would like to get the installed wifi module going.

The page you recommended [quote='MarkHaysHarris777' pid='22353' dateline='1478902296'] suggests a command to find whether the wifi module is alive by using:
iwconfig.

My terminal answers: unknown command.

Why is that?

Regarding the MAC address of the wifi module
you wrote to me on Nov 8 [quote='pfeerick' pid='22229' dateline='1478574844']:

Not sure about the bluetooth, but if you are on linux, to get the wifi mac address, run ifconfig | grep "HWaddr" and look at the wlan1 line.

On android, it you should be able to find it under System -> About (tablet) -> Status.

Again, my terminal replies unknown command.

It is getting difficult.
  Reply
#6
(11-19-2016, 04:07 PM)clawinus Wrote: iwconfig

My terminal answers: unknown command.

Why is that?

I don't have my pine64 running at the moment (card is currently re-imaging) so I can't verify the permissions but try running iwconfig as root (sudo iwconfig) and see if it works then. Otherwise, it is missing, and you'll need to run sudo apt-get install wireless-tools to install the missing bits. The same is probably the case for ifconfig as well (although I don't remember needing to use sudo - but it becomes second nature after a while when a command that should work doesn't) - you generally need root privileges (sudo) to make any system configuration changes. Hence since most of the command listed earlier need sudo, you use sudo -i to enter the root environment and stay there until you exit it, so you don't have to keep adding sudo to every command.
  Reply
#7
Thanks for the additional information.
The system confirms that I have the latest version of wireless-tools installed.
The config commands return connection information only when I have
an USB wireless adapter or an Ethernet cable attached. When both are
off I get no results; obviously the built-in Wifi module cannot be found.

Would you like to see screen photos of the various replies?
  Reply
#8
(11-21-2016, 04:16 PM)clawinus Wrote: Thanks for the additional information.
The system confirms that I have the latest version of wireless-tools installed.
The config commands return connection information only when I have
an USB wireless adapter or an Ethernet cable attached. When both are
off I get no results; obviously the built-in Wifi module cannot be found.

Would you like to see screen photos of the various replies?

Ok, a quick clarification then - when on the debian mate image, why can't you use the network manager applet icon up on the top right (it probably has two green dots and a spinny thing if the ethernet isn't plugged in)? Your wifi module is plugged in the right way around (the antenna connector is on the inside edge), so using the debian mate image there is no reason it shouldn't just work unless you have a faulty module. Has the module ever worked?

My apologies, the check of the /etc/network/interfaces file was really only relevant if you were using the minimal (non-GUI) debian version, so there's no point fiddling in that. Since you're using the GUI, it should just work - when you click the network manager applet icon in on the top right, it should the list of available networks and you then click on the network name to enter your password, etc. And if you need more options, there is an 'edit connections' entry that lets you do that.
  Reply
#9
Yes, I have been using the Network Manager at the right upper corner of the Debian screen.
Currently I work with the Ethernet connection only. When I disconnect the Ethernet with the Network Manager and then pull the Ethernet Cable
I cannot create a new Wifi connection. The Network Manager does not find Wifi hardware. Perhaps I can find it if I knew the MAC address of the
installed Wifi module, but I do not know how to find it.

It all suggests that the Wifi Module is not working.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
Bug WiFi enabled but refuses to connect cardboardmaster 4 69 6 hours ago
Last Post: pfeerick
  WiFi issues Pinebook Pro sunnystormy 6 125 05-28-2020, 05:44 PM
Last Post: Luke
  wifi issues george2524 9 557 06-13-2019, 04:25 PM
Last Post: evilbunny
  Input not working after a forced shutdown dic1911 1 241 12-24-2018, 07:45 PM
Last Post: tllim
  Any success working with OpenCV on the PineA64? Tonny91 0 393 10-16-2018, 09:16 PM
Last Post: Tonny91
  Mini-Tutorial to get a linux Desktop GUI working on Pine64+ speedro86 15 8,998 04-05-2017, 01:45 PM
Last Post: speedro86
  RESOLVED - LCD screen not working, HDMI does asuras 10 2,353 04-02-2017, 08:12 AM
Last Post: Luke
  Getting z-wave module working under ubuntu marcosti 6 2,756 02-10-2017, 07:53 AM
Last Post: JamesWatt
  how to install Wifi/Bluetooth module danlcarr 2 843 10-08-2016, 09:59 PM
Last Post: danlcarr
  WiFi module causes boot loop BnEc 17 5,768 09-24-2016, 09:12 PM
Last Post: pfeerick

Forum Jump:


Users browsing this thread: 1 Guest(s)