dual wifi, one as access point
#1
Did anybody bringing both network interfaces, one in access point mode ? How does it work for you ?  
I am concerned that both interfaces have same MAC address 34:c3:d2:7a:ba:77, and adding hwaddress in /etc/network/interfaces
does not change that. so my wlan0 connects to my home wifi router, that part works, but if i do that the access point on wlan0 does not work, clients can't connect to it 

ifconfig
wlan0     Link encap:Ethernet  HWaddr 34:c3:d2:7a:ba:77  
          inet addr:192.168.0.113  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::36c3:d2ff:fe7a:ba77/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1910 errors:0 dropped:53 overruns:0 frame:0
          TX packets:1365 errors:0 dropped:1 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:277533 (277.5 KB)  TX bytes:320881 (320.8 KB)

wlan1     Link encap:Ethernet  HWaddr 36:c3:d2:7a:ba:77  
          inet addr:10.0.0.1  Bcast:10.0.0.15  Mask:255.255.255.240
          inet6 addr: fe80::34c3:d2ff:fe7a:ba77/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:976 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 



iwconfig
wlan0     IEEE 802.11bgn  ESSID:"yyyyy"  Nickname:"<[email protected]>"
          Mode:Managed  Frequency:2.447 GHz  Access Point: 28:C6:8E:73:6E:07   
          Bit Rate:72.2 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
          Power Management:off
          Link Quality=99/100  Signal level=-45 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

dummy0    no wireless extensions.

sit0      no wireless extensions.

lo        no wireless extensions.

wlan1     IEEE 802.11bgn  ESSID:"xxxxx"  Nickname:"<[email protected]>"
          Mode:Master  Frequency:2.447 GHz  Access Point: 36:C3Big Grin2:7A:BA:77   
          Bit Rate:72.2 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/100  Signal level=-95 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
          RX bytes:0 (0.0 B)  TX bytes:112 (112.0 B)
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Frustrations with Wifi, VNC, Longsleep, etc. NexusDude 1 132 06-05-2019, 11:43 PM
Last Post: igorp
  Ubuntu boot very slow with wifi driver remainder 9 2,228 08-03-2017, 07:23 AM
Last Post: victorssantos
  Recovering root access in Ubuntu Scientomancer 3 742 07-28-2017, 02:53 PM
Last Post: Scientomancer
  Problem connecting to specific wifi network JamesWatt 1 851 07-03-2017, 02:09 PM
Last Post: ChristianC123
  Network Access Error coolnine98 5 950 06-29-2016, 06:15 PM
Last Post: coolnine98
  Python access from the menu coolnine98 2 511 06-27-2016, 05:03 PM
Last Post: coolnine98
Question Set-up the wifi module jereze 9 6,718 05-18-2016, 12:02 PM
Last Post: jereze
  Remote access to Mate desktop using VNC jl_678 2 1,796 05-09-2016, 09:31 PM
Last Post: tllim

Forum Jump:


Users browsing this thread: 1 Guest(s)