Can't seem to change keyboard layout...
#1
Hey guys

Got Ubuntu 16.04 up and running (thanks to everyone that worked on that Big Grin) but the keyboard layout is stuck in US whereas I have a Portuguese keyboard. /etc/default/keyboard returns the correct XKBLAYOUT="pt", and dpkg-reconfigure keyboard-configuration seems OK, but the actual keyboard layout is still wrong.

For what it's worth, after keyboard-configuration runs, I get a couple of error messages saying "update-rc-d: start and stop actions are no longer supported", but I don't really see how that should affect the keyboard layout.

I've tried rebooting, doing this with and without sudo, with my standard user and as root, and nothing sticks Sad

Help??

Thanks!
  Reply
#2
Which desktop are you using?

... have you tried System --> Preferences --> Keyboard; and click the Layouts tab?
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
  Reply
#3
I was going for a headless server setup, no desktop Smile hoping for a CLI solution.
  Reply
#4
(08-17-2016, 04:21 AM)pqueiro Wrote: /etc/default/keyboard returns the correct XKBLAYOUT="pt", and dpkg-reconfigure keyboard-configuration seems OK, but the actual keyboard layout is still wrong.

ok... the dpkg-reconfigure keyboard-configuration is only for this session.

... you need to edit | modify your /etc/default/keyboard  file.  It looks like something is interfering with that file... something maybe in rc.d  ?   ( I don't know )

You should be able to change your keyboard layout (and type) by editing your  /etc/default/keyboard  file;  on debian, ubuntu, and  'real'  PC  debian.
marcushh777    Cool

please join us for a chat @  irc.pine64.xyz:6667   or ssl  irc.pine64.xyz:6697

( I regret that I am not able to respond to personal messages;  let's meet on irc! )
  Reply
#5
Hello,

First day with my Rock64, just arrived today  Big Grin . All works really fine but i have the same issue with the keyboard but in this case with the Spanish Layout.

I'm using Armbian and the keyboard layout is stuck in US

This is my /etc/default/keyboard

# KEYBOARD CONFIGURATION FILE

# Consult the keyboard(5) manual page.

XKBMODEL="pc105"
XKBLAYOUT="es"
XKBVARIANT=""
XKBOPTIONS=""

BACKSPACE="guess"

I've tried also from desktop ( system > keyboard ) and nothing change ...

[Image: zn9zwl.png]


After many trials, reboots and even a few fresh installations, nothing change.

Thank you so much
  Reply
#6
Hello again,

Already fixed. I don't know exactly why before wasn't working, but finally my keyboard layout is fine.

Regards,

Javier
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  How to change DSI setting value from DTS r.tanaka 8 425 08-28-2018, 03:52 AM
Last Post: r.tanaka

Forum Jump:


Users browsing this thread: 1 Guest(s)