Failed firmware change for the Quectel EG25GGBR07A08M2G modem of PPP Explorer Edition
#1
The Quectel modem EG25GGBR07A08M2G of a recently (January 2024) purchased PinePhone Pro Explorer Edition became non-functional after an attempt to replace its firmware with the community one:

https://wiki.pine64.org/wiki/PinePhone#Firmware_update

The described process with the fwupd (0.7.2 is the latest version available there) on Mobian 12 ended up with the modem stably disappeared from the system, without returning back after rebooting or un-/re-powering the device. The recipes from the community repository helped to boot the modem in the QDL mode and flash it again - but it doesn't function any more: it is visible to the system and is generally responding to the AT interface, but it can't be enabled. In particular, some of the AT commands fail - e.g. it is impossible to return IMEI or SN. This seems regardless of firmware: the latest (0.7.4) community version and all the stock versions from the recovery repository were tried with the same result.

So the questions I have:
  1. What is the exact version of the stock firmware for the Quectel EG25GGBR07A08M2G modem which the PPP Explorer Edition are being shipped with today?
  2. Is there any further way to diagnose and fix the issue?

Thank you!
  Reply
#2
https://forum.pine64.org/showthread.php?tid=19058
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  PinePhone Pro Explorer's edition Qualcomm modem recovery shifras 7 1,613 03-24-2024, 02:22 PM
Last Post: zetabeta
  Messed Up Modem dorkydev 13 2,317 12-23-2023, 03:02 PM
Last Post: dorkydev
  Bypass contact points on PPP developer edition cyrelk 1 1,297 10-10-2023, 10:23 AM
Last Post: fxc
  modem isn't online - Arch config bad? brb78 3 2,971 12-10-2021, 08:51 AM
Last Post: Danct12

Forum Jump:


Users browsing this thread: 1 Guest(s)