Rock64 won't boot
#1
I have a setup running 4 Pine 1 boards (the first board developed by Pine).  Earlier this year I purchased a Rock64-2G as well as the power supply listed in the Pine website to use for the Rock64.  I also downloaded the Armbian software listed for the Rock64 on the Pine website.  Using the Etcher executable on Windows I installed Armbian on a micro sdcard.  Then after plugging a ethernet plug, an HDMI plug, a keyboard and mouse and finally the power cord.  A red light on the card turns on but nothing appears on the HDMI terminal.  Again, this setup works fine for my Pine 1 boards.  Does anyone have any idea what I am doing wrong?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  HDMI doesn't work on rock64 Noung1991 1 442 11-21-2023, 08:33 AM
Last Post: as365n4
  Rock64 + Klipper + KlipperScreen Instructions godzilla62 0 426 10-22-2023, 01:52 AM
Last Post: godzilla62
  Rock64 Debian 11 (Bullseye) install problem jbize 15 7,652 10-12-2023, 05:14 PM
Last Post: tpaul
  slarm64 (unofficial slackware) Rock64 RK3328 (aarch64) mara 133 184,222 10-09-2023, 03:31 AM
Last Post: mara
  arch rock64 does not boot nemnob 0 452 07-09-2023, 03:28 AM
Last Post: nemnob
  RXDP from Win10 to Armbian on Rock64 Transportsicherung 0 504 05-27-2023, 06:11 AM
Last Post: Transportsicherung
  Disabling last mount time check on boot acwest 0 498 03-03-2023, 09:24 PM
Last Post: acwest
  DietPi OS for ROCK64 MichaIng 41 30,898 12-07-2022, 08:22 PM
Last Post: luminosity7
  Using multiple UART's on Rock64. ramprasad 0 853 08-29-2022, 01:22 PM
Last Post: ramprasad
  Using multiple UART's on Rock64. sachineswar 0 835 08-29-2022, 12:31 PM
Last Post: sachineswar

Forum Jump:


Users browsing this thread: 1 Guest(s)